0

Bluetooth keyboard and mouse frequently stops reconnecting. I see them trying to find the computer but they don't reconnect. Pressing connect manually from the bluetooth settings never works.

  • This only happens with my bluetooth mouse and keyboard. My 2 types of bluetooth headphones reconnect just fine.
  • It happens unpredictably and frequently (like once a day)
  • I can't reproduce it by just turning off, on my mouse or keyboard or just suspending my laptop. But I can reproduce this by doing both.

To get them connected again I go to the Bluetooth settings and re-pair the devices. Removing the existing devices for them isn't actually necessary.

When this happens I checked hciconfig, it looks like my laptop's bluetooth device was in a pscan mode. So a fix mentioned in the following comment probably won't work for me. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/249448#yui_3_10_3_1_1586957376032_691

hciconfig
hci0:   Type: Primary  Bus: USB
  BD Address: 9C:B6:D0:D4:B2:52  ACL MTU: 1024:8  SCO MTU: 50:8
  UP RUNNING PSCAN
  RX bytes:2197035 acl:32474 sco:2270 events:215262 errors:0
  TX bytes:132474588 acl:214704 sco:1717 commands:365 errors:0

Probably not relevant but it's super weird that the device is both listed under Paired Devices as Nearby devices. {image}

Not sure if relevant but while pairing a couple of times, using other tools I notice the mac address of my mouse seems to change:

  1. D8:2F:80:B9:15:8E
  2. D8:2F:80:B9:15:8F
  3. D8:2F:80:B9:15:90
  4. D8:2F:80:B9:15:91

I also used bluetoothctl to trust and connect but that doesn't change anything. This is the info after successfully pairing.

Device D8:2F:80:B9:15:91 (random)
    Name: M720 Triathlon
    Alias: M720 Triathlon
    Appearance: 0x03c2
    Icon: input-mouse
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: no
    UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
    UUID: Battery Service           (0000180f-0000-1000-8000-00805f9b34fb)
    UUID: Human Interface Device    (00001812-0000-1000-8000-00805f9b34fb)
    UUID: Vendor specific           (00010000-0000-1000-8000-011f2000046d)
    Modalias: usb:v046DpB015d0007
    RSSI: -67
    TxPower: 4

I tried reconnecting using bluetoothctl but it also fails.

~ bluetoothctl
Agent registered
[bluetooth]# devices
Device D8:2F:80:B9:15:91 M720 Triathlon
Device 20:9B:A5:82:E8:EC SoundBuds Slim
Device 20:9B:A5:91:46:58 SoundBuds Slim
Device 2C:41:A1:E8:2E:1F Bose QuietControl 30
[bluetooth]# connect D8:2F:80:B9:15:91
Attempting to connect to D8:2F:80:B9:15:91
[bluetooth]# connect D8:2F:80:B9:15:91
Attempting to connect to D8:2F:80:B9:15:91
Failed to connect: org.bluez.Error.Failed
Failed to connect: org.bluez.Error.Failed
[bluetooth]# connect D8:2F:80:B9:15:91
Attempting to connect to D8:2F:80:B9:15:91

I was thinking I would write a workaround script that would automatically remove and re-pair these devices, but the changing address makes that much harder.

Update: I have bluez version 5.50-0ubuntu0ppa1 from the ppa:bluetooth/bluez repository.

0

I think I solved this when I tried fixing another issue: my Bluetooth headphones kept connecting in low fidelity mode.

First a note, some tips adapt /etc/bluetooth/audio.conf, but since Ubuntu 16.04+ (elementary 0.4 Loki) you actually need to edit /etc/bluetooth/main.conf.

I changed /etc/bluetooth/main.conf to just contain:

[General]
Enable=Source,Sink,Media,Socket
AutoConnect=true

Following this advice: https://jabriffa.wordpress.com/2019/04/29/fixing-bluetooth-headset-playback-profile-on-ubuntu-18-04-lts/

I then noticed that sudo service bluetooth restart wasn't enough, I needed to restart.

Since I did that both my issues have been fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.