2

Everything was working perfectly until some days ago, but now every time I open the spotify app the wingpanel crashes. I'm not sure if it was an update on spotify itself or something within Elementary.

Syslog shows this:

Nov  1 12:49:15 saitama kernel: [11051.128510] wingpanel[5958]: segfault at 38 ip 00007fefabb5be2b sp 00007ffe7ca147a0 error 4 in libsound.so[7fefabb4b000+27000]

Elementary version: Loki
Spotify version: 1:1.0.38.171.g5e1cd7b2-22

I've tried to uninstall and reinstall spotify already, even tried the 0.9.17 version with the same effects. Also tried to uninstall some indicator apps, but nothing solved it.

I would like to know if anyone else has the same issue or if someone has any ideas of what could be happening.

Is there any way to install other versions of spotify? I've tried sudo apt install spotify-client=1:1.0.37.152.gc83ea995-42, but it couldn't find that version...

2

So, I've found the culprit!

The wingpanel-indicator-sound version 2.0.3 is the one that's crashing and thus making the entire wingpanel disappear.

Removing the package is a temporary solution.

I've already submitted a bug report on the wingpanel-indicator-sound project page.

0

Wingpanel is behind spotify, if you use the applications menu shortcut (Super+Space) it will appear again, not perfect but it works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.