10

I recently bought aa Razer Blade Stealth laptop which I'm having issues with Elementary Loki on. This laptop uses the 7th gen Intel Kaby Lake chipset with an HD 620 graphics chip and a HIDPI touchscreen (12.5" 2560x1440 QHD).

I can boot to the installer without issue and proceed through the install (even the touchscreen works!). Once installed It boots to the login screen (lightdm) and I can move my mouse, type password etc without problem, but as soon as I login the machine crashes with a garbled screen.

While at the login screen I can alt-F1 to another console and login there without issue. while there I've checked a bunch of logs but they all end abruptly, I'm guess it crashes before it has a chance to log anything.

Things I've tried:

Every time a crash as soon as the desktop starts to load.

I've installed Xubuntu 16.04 (as I had the ISO handy) and that works without issue - I can load the desktop fine (though the HIDPI support is a bit poor). From there I added two elementary repos, ppa:elementary-os/stable and ppa:elementary-os/os-patches and using apt installed elementary-theme elementary-icon-theme elementary-default-settings elementary-desktop (as per this post - https://askubuntu.com/questions/766673/pantheon-on-ubuntu-16-04) but it still crashes as soon as I try and log in to Pantheon (XFCE still works fine).

I'm out of ideas - are there any commands I can pass to the kernel at boot, some sort of safe mode, or debugging? It's strange that lightdm works fine, XFCE works fine, but pantheon crashes hard.

Sorry for the essay - was trying to get as much info in as possible!

Cheers, Andrew

EDIT: Added the fact it is a HIDPI display

  • Did you ever end up figuring this out? I had the same issue and now I'm trying to install any linux distro but it won't work. – Snubber Dec 30 '16 at 21:11
  • 1
    Same. I am able to run Arch, Ubuntu, Windows perfectly fine on the stealth but have run into same issues as you describe. Please halp. Don't even know where to start debugging this issue. – RATabora Jan 3 '17 at 17:06
  • No I never got it working - tried a few more things (mostly around different xorg configs) and have hunted through a bunch of logs but nothing gets logged when it crashes. After a few days tinkering I gave up and installed Ubuntu 16.10 with Gnome 3 – Andrew Jan 6 '17 at 11:21
  • I thing the Kaby Lake concerns are not the cause, at least I'm using a Dell XPS 13 9360 and it's working perfectly. I did upgrade the kernel, but it was running without the update. Wish I had gone through similar, to help, but afraid my KL chipset works fine. – SamMorrowDrums Feb 9 '17 at 16:31
  • Has there been any progress on a fix for this? I have the exact same issue. – Odyss3us Apr 2 '17 at 9:55
1

I've made progress, done updates and used clamtk to neutralise the trojan that caused it. I think it came from an ad-spamming website hdeuropics, where I watched a frebbie movie, I went searching for every possible file it could have got to but went too far and destroyed my profile's system shared user files, meaning I couldn't log in. I used terminal to find and obliterate all related trojan files, update system and cleaned it all up and it now logs in but then straight back out again on that profile. I can log into the admin profile and my son can log into his. I could make a new profile and then maybe transfer the files to that. Unfortunately one of the folders has my registered user files for a game that I love so that's why I haven't made another profile, as you can't have 2 profiles with the same name. I was thinking to chown the files then move them and then move them again to a new profile and chown them back again, it could work.

  • I'm pretty sure it's "busybox" and that isn't present on my fresh install of Loki try in terminal dpkg -L busybox before updating and adding packages to see if it's present – Sapa Nov 5 '17 at 17:25

protected by Community Dec 4 '18 at 21:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.