0

i have downloaded, from the official page, last week and installed yesterday the Elementary OS but i'm having trouble to install basically everything that needs to add ppa. Every new ppa i add gives me

W: Failed to fetch http://ppa.launchpad.net/mpstark/elementary-tweaks-daily/ubuntu/dists/sid/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/mpstark/elementary-tweaks-daily/ubuntu/dists/sid/main/binary-i386/Packages 404 Not Found

This is an exemple of the last ppa i tried to add. When it happens i try to clean or update but nothinh happens, so i remove the ppa add. I was ignoring it but now i'm just too pissed about it. It happened intalling java, tweak tool, dependencies for opencv and other programs. Some of then i have to do a lot of work till i can installed. Not it's not probabli my network connection because i tried at 3 different networks :/ Maybe this is a problem with my iso? Or what i'm really pissed of :( :(

1

How do you add the PPAs?
When I use sudo apt-add-repository ppa:mpstark/elementary-tweaks-daily and do a sudo apt-get update I'm able to install elementary-tweaks without any problems.

So maybe you're right and something is wrong with your installation file.
Did you check the SHA256 sum after downloading the iso?
According to ElementaryOS Installation docs you should do the following to verify the integrity of your file:

In this example the latest 64-bit eOS ISO has been used.

sha256sum elementaryos-0.3.2-stable-amd64.20151209.iso
The output should be: ee737ffa6bf33b742c5a7cee17aa26dec5ee3b573cbbc4b53cbe2a2513c9197a

If you still have the copy of the ISO you used to install eOS, you can check if the file is corrupt. If so, you have to download the ISO and install eOS again.


EDIT: The links you posted doesn't work for me either. So maybe you just have to correct these in your /etc/apt/sources.list or the corresponding file in /etc/apt/sources.list.d/....
To be sure, I would remove all the PPAs wich gave you a 404 error and add them with sudo add-apt-repository ppa:example-ppa/abc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.