10

It can be done in Fedora with the Gnome 3 theme: http://fedoramagazine.org/make-firefox-look-native-fedora/

It should be like this:

enter image description here

but it looks like this:

enter image description here

6

In the article that you've linked, they recommend using the HTitle add-on. Afterwards, you also need to add the headerbar userstyle and set Hide titlebar: Always in HTitle's add-on preferences.

There are several other Firefox add-ons that attempt to make it appear more native, but there's only so much that can be done. Firefox just isn't a native Gtk+ app. Your mileage may vary.

6

Since Firefox Quantum, the extensions mentioned in the accepted answer has been discontinued. However, as noted by Mehmet Hanoğlu since Firefox 60+, the feature is supported out of the box.

To enable it, open the Customise option in the Firefox main menu and uncheck the Title bar check box.

enter image description here

For more information, see the bugzilla bug report or omgubuntu.

(Tested on elementary 5.0)

  • This works great for me on FireFox 68.0.2 on Elementar 5.0 - thank you! – Matias Forbord Aug 25 at 16:04
2

The simple workaround would be use addon:

Hide Caption Titlebar Plus

  • I appreciate for your answer, but the result looks weird, so it isn't what I need, but still thanks! – JulianLai Dec 27 '15 at 7:18
  • its ok :D @JulianLai :) – Ravan Dec 27 '15 at 7:19
1

Just in case someone else is looking for this I followed the second step on this article How To Remove Maximized Windows Titlebar In GNOME Shell and it worked perfectly.

even though it says that this only applies for Adwaita theme I was able to find the same files and xml structure on the Elementary theme


The below instructions are for Adwaita theme but you can of course do this for other themes and will only remove the titlebar for maximized windows.

To remove maximized windows titlebar in GNOME Shell, open "/usr/share/themes/Adwaita/metacity-1/metacity-theme-3.xml" (firstly make a backup of this file!) as root and search for frame_geometry name="max" and edit it so that it looks like this:

<frame_geometry name="max" has_title="false" title_scale="medium" parent="normal" rounded_top_left="false" rounded_top_right="false">
         <distance name="left_width" value="0" />
         <distance name="right_width" value="0" />
         <distance name="left_titlebar_edge" value="0"/>
         <distance name="right_titlebar_edge" value="0"/>
         <distance name="title_vertical_pad" value="0"/>
         <border name="title_border" left="0" right="0" top="0" bottom="0"/>
         <border name="button_border" left="0" right="0" top="0" bottom="0"/>
         <distance name="bottom_height" value="0" />
</frame_geometry>

Basically you need to change all the "distance" and "border" values for frame_geometry name="max" to 0 and append has_title="false" to the frame_geometry name="max" line.

Then press ALT + F2 to reload GNOME Shell and you're done.


If alt + F2 doesn't restart your shell, just reboot your computer

0

This problem solved with Firefox 60.0b2 :)

enter image description here

0

To get rid of the title bar and to make Mozilla Firefox look more native to elementary OS with properly placed window and tab buttons etc. do the following:

  1. Uncheck the Title Bar option from the Customise menu inside Mozilla Firefox. (The one with the paintbrush icon.)
  2. Install the following theme: https://github.com/harveycabaguio/firefox-elementary-theme
  3. Restart Mozilla Firefox.
  4. Optionally further fine-tune the user interface from the Customise menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.