0

I installed anaconda navigator and it installed successfully too. But when I write anaconda-navigator in terminal and press enter, the following screen comes but the anaconda-navigator does not start: enter image description here

I do not know that it is an anconda related problem or OS related.

It is neither running in root or as normal user. If someone can guide me through this, I will be very grateful to them. Thank you very much.

1

I don't think you're supposed to run anaconda-navigator as root.

You'll want to make sure that you have installed the application as a normal user and not as root. So don't prefix the command to run the installer with sudo but just run it with your current user's permissions.

Once you're installed, try activating the Anaconda virtual environment before and then running the application. This should add the program to your PATH. The steps below activate Anaconda's virtual environment and start anaconda-navigator.

  1. If you installed Anaconda in your home directory in a folder called anaconda3, the default location, then use the following command.
source ~/anaconda3/bin/activate
  1. Now run anaconda-navigator.
anaconda-navigator

This worked for me.

2
  • I installed and uninstalled Anaconda several times. It was only then I realised that the program installation was as root. That was the reason it was not letting me open it as root. But when I install it as normal user, the problem is solved. I am now able to run anaconda-navigator from the terminal and use Anaconda. Thank you for writing answer. Thanks. :) – Maverick Feb 18 at 13:19
  • 1
    No problem. I'm glad you got that figured out! I've updated my answer to include the fact that Anaconda shouldn't be installed as root. – jwillikers Feb 19 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.