I am a relative noob. I have done a fresh install of Elementary OS 5.1 and I can't seem to get my WiFi working. Below is the output of lshw and iwconfig.

pshone@Mecer:~$ sudo lshw -c network
[sudo] password for pshone:         
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 07
       serial: 00:e0:4c:40:e5:01
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.045.08-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:45 ioport:3000(size=256) memory:aa000000-aa000fff memory:c0000000-c0003fff
       description: Wireless interface
       physical id: 2
       bus info: usb@2:6
       logical name: wlxac5d5c4d601a
       serial: ac:5d:5c:4d:60:1a
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8xxxu driverversion=5.0.0-37-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11
pshone@Mecer:~$ iwconfig
enp1s0    no wireless extensions.

lo        no wireless extensions.

wlxac5d5c4d601a  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

Please can someone help?

2 Answers 2


Many laptops don't have wifi drivers installed by default. What you have to do, is find a way to connect to the internet. Once you have internet, going in the "app store" will allow you to see and install the latest nvidia or other drivers.

Here are the ways to get internet:

  1. Ethernet (if you have an ethernet port, just plug your laptop)
  2. Shared Cellular connexion (I had to resolve to do that, since my laptop didn't have ethernet ports). I used the shared connexion via USB feature on my Android phone, and connected it to the computer.

Hope that helps !

  • Thanks Jeremy, I have tried a lot of things and nothing seems to be working, even updated driver from Realtek site. Ethernet now works but still not luck with WiFi. :( Commented Jan 15, 2020 at 17:37
  • I found that if I updated the kernel to 5.4 the WiFi became more reliable, but still not totally stable. Commented May 15, 2020 at 13:47
  • Type in terminal sudo update-initramfs -u and provide results.
    – Sysadmin
    Commented Jul 10, 2020 at 14:52

I had a similar problem with my installation. What worked was to disable the 'Secure Boot' option in bootloader settings.

I don't remember now how I did that but that's what helped for sure.

  • Secure Boot must be disabled in BIOS.
    – Sysadmin
    Commented Jul 10, 2020 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.