1

I am very new to linux. I want to install Private Internet Access VPN app. they have a nice Linux app which works well on Linux Mint. I have now installed Elementary and it's great. But I can't get PIA VPN to install with an APP. Instead I followed the CLI instructions and I now have OpenVPN working, but it's nowhere near as good as the app. I have to enter my password constantly, it doesn't seem to have any kill switch (critical for me), it doesn't replace my default DNS with PIA's DNS, and I can't find an auto connect at startup option. I NEVER want to use my native ISP connection so I want VPN always on. I downloaded the PIA run file from here https://www.privateinternetaccess.com/installer/x/download_installer_linux but Elementary can't run the program (.run). Any tips on how to make this install please?

  • What do you mean by Elementary can't run the program? Does it show any errors? – Vlad Pop Dec 26 '19 at 3:53
  • Sorry. What I mean is, when I download the .run installer from PIA, Elementary doesn't know what to do with it (and nor do I). It asks which Application I want to run it with, and I have no idea. When I used the PIA installer on Linux Mint it just installed beautifully with the full PIA application running perfectly. I need that as the Built in OpenVPN configuration seems way too basic, no kill switch, no auto connect, etc etc. I could probably have just asked: "How do I run PIA's VPN app on Elementary OS please?" :D :D – stanlloijo Dec 26 '19 at 12:53
  • On the website address you provide there is no app option, just the one with the .run file and there are instructions on how to run this file in order to install the application. Do you have any problems with installation or not? Because from the source you provide there is no another option to install the app - if the nice app works with linux mint, there is a chance to work with elementary OS also, but on the website you provide the version for all linux distributions (including Linux Mint) is one and the same and it is the same .run file. – Bo rislav Dec 26 '19 at 14:39
2

The file you downloaded is a script. After downloading it, you must mark it as executable and then run it in Terminal.

  1. Right-click on the .run file, and go to Properties. Here, go to the Permissions tab and click on the first Execute button and then Close.

  2. Open a Terminal window and then drag-and-drop the .run file inside, and press Enter. Type your password when prompted.

  3. Enjoy PIA VPN!

enter image description here

| improve this answer | |
  • Wow, what a great answer thank you! – stanlloijo Dec 27 '19 at 14:31
0

Wow, what a great answer thank you! Will this show it in AppCenter afterwards or will I need to run it from Terminal every time? I have installed it. It shows on dock but it behaves funny. PIA on Mac/Win/Mint will have an icon in notification/clock/statusbar type areas, showing green or red depending on whether it's connected or not. I can't seem to make that happen in Elementary. I have adjusted all options in PIA (show in system tray is the one usually) but it still doesn't show. I can manage with it as i use the kill switch so I will know if the VPN drops as I won't be able to visit any websites, but I just mention it in case you know of a way to make it show on top right area. Thanks again, great help

| improve this answer | |
  • Unfortunately, the tray icon will not work properly in elementary OS untill the PIA developres decide to adapt the app to the elementary ecosystem. When they do that, it will most likely also appear in the AppCenter (maybe). Until then, you will only be able to run it from the Applications menu, in the upper left corner. Now please accept my answer so others can find it easier :) You could also send a message to the PIA devs to update their app to work better with elementary OS. You could also look for a way to enable ayatana-indicators in elementary OS, and to enable the tray indicators. – Vlad Pop Dec 27 '19 at 16:26
  • I can not see any way to 'accept' your answer, but I am grateful for it! I have looked for ages and see no accept option anywhere but I noticed Stack doesn't like privacy extensions and VPNs, or some combination of them, as it says "suspicious activity". Par for the course for anyone who wants privacy online these days :( – stanlloijo Dec 28 '19 at 23:26
  • You can accept an answer by clicking the grey checkmark, under the upvote/downvote buttons. This images.app.goo.gl/i8iUKad7Vm6q2FrA6 will help you find it. The 'suspicious activity' means that VPN actually works, and the Stack Exchange servers cannot determine your location. – Vlad Pop Dec 29 '19 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.