0

After 2 years without an issue, since 2 days ago my Loki has started freezing during the shutdown (as well as rebooting) process.
I have tried the most common solutions found on the internet (working on GRUB, booting into an earlier Kernel), but to no avail.
When I shut down, it freezes on the shutdown image (elementary OS logo, at this point not "pulsating" any longer, just stuck, and the screeen won't turn off). Pressing ESC reveal what you can see in the picture below, fixed and unchanged.
I will be very grateful to anyone trying to help with this!

enter image description here

ADDENDUM:
Running apt policy systemd
Gives me

systemd:
  Installed: 229-4ubuntu21.10
  Candidate: 229-4ubuntu21.10
  Version table:
 *** 229-4ubuntu21.10 500
        500 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     229-4ubuntu4 500
        500 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  • 1
    Did you updated systemd recently? | Could you run the command apt policy systemd? – Sebastian Dec 19 '18 at 11:24
  • That's very likely. Added the output in the question – ed0 Dec 19 '18 at 15:41
1

I could tell you to downgrade systemd right away, but you will be able to do it only to the first release not the last update. You'll miss a lot of fixes with it, check the changelog below for more details.

http://changelogs.ubuntu.com/changelogs/pool/main/s/systemd/systemd_229-4ubuntu21.10/changelog

I recommend you to report this to:

https://bugs.launchpad.net/ubuntu/+source/systemd

, and then decide what to do.


Now If you want to test to downgrade systemd anyway...

Run:

sudo apt install systemd=229-4ubuntu4

Hold that version:

sudo apt-mark hold systemd

You'll probably have some unmet dependencies like libsystemd0

Just add that dependency to the line

sudo apt install systemd=229-4ubuntu4 libsystemd0=<version_needed>
  • Thank you very much for your advice. As you foresaw, I need to add that line for adjusting the dependancies. However, installing those dependancies will prompt the removal of great part of my DE (appcenter, pantheon-files pantheon-shell pantheon-xsession-settings, gnome-settings-daemon etc.) – ed0 Dec 19 '18 at 18:01
  • pastebin.com/zGeiFvrE (check the lower portion for the exact output of the command) – ed0 Dec 19 '18 at 18:04
  • 1
    then you can't downgrade... maybe the base version of xenial differs from the base of loki – Sebastian Dec 19 '18 at 18:37
  • It shouldn't be any different, as far as I know. Is there a way to retain those packages, or would cause great trouble (e.g. really break my system)? – ed0 Dec 20 '18 at 16:10
  • 1
    Could really break the system – Sebastian Dec 20 '18 at 19:42
1

The bug was resolved with the latest kernel update, version 4.15.0-42-generic. No further action was required

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.