6

I cannot shutdown my elementary OS in my ASUS G56JR Notebook. I am trying other solutions I have found here in StackExchange but no changes, I am using actual version LTS of elementary OS Freya.

  • what you have tried till now? Have you tried shutdown from terminal sudo shutdown -h now and to reboot sudo reboot – Ravan Oct 25 '15 at 17:29
  • 1
    Possible duplicate of Unable to reboot and/or shutdown? – Ravan Oct 25 '15 at 18:15
  • No Ravan, I have tried that solution. – Alex Ferrer Oct 26 '15 at 9:45
  • I will try with sudo shutdown -h now – Alex Ferrer Oct 26 '15 at 9:46
  • let me know the result @Alex =) – Ravan Oct 26 '15 at 9:59
3

Finally the best way to solve this problem is installing Nvidia Graphics driver and choose Intel Graphics device in Nvidia X Server Panel. After reboot, now I can shutdown and reboot my laptop normally.

  • I have done this, but after it the computer hangs on boot. I had to start in nomodeset mode, and then removed all nvidia packages using sudo apt-get remove --purge nvidia*. After that I can shutdown and reboot normally, but I am not sure still which graphic car I am using. – Guillermo Gutiérrez Sep 17 '16 at 4:51
0

I faced the same problem with my ASUS GL552VW. Fixed with a simple kernel parameter change.

1) Install Grub Customizer

sudo add-apt-repository ppa:danielrichter2007/grub-customizer -y
sudo apt update
sudo apt install grub-customizer

2) Open Grub Customizer and Edit the grub entry (with the Pencil Icon) Grub Customizer

3) Now make the desired changes. In this case,Edit Menu

you need to add a parameter on the second last line that starts with linux /boot/vmlinuz-xxx.... add acpi=force before ro quiet splash $vt_handoff Click OK and Save. Now hard reset your laptop. It should be fixed from the next boot.

I'm using these parameters to boot and this fixes all the function keys operations, keyboard backlight, graphics and the shutdown problem.

linux /boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=7e43add9-fbc2-4946-a640-0b269d17c117 i915.modeset=0 nouveau.modeset=1 nvidia.modeset=1 idle=nomwait acpi=force acpi_osi=! acpi_backlight=native ro quiet splash $vt_handoff

-1

Hit the same problem several times while trying to install elementary OS for the first time and fiddling to get window size other than VGA -- Mac OS host with Virtualbox -- and the advice above did work for me:

from Terminal

sudo shutdown -h now

and to reboot

sudo reboot

Once I got the installation and updates and window size fix working, the normal shutdown and restart pulldown menus work fine.

I did hang the VM once since then, by trying to change Files view from Icons to List -- had to power cycle again because terminal/mouse/keyboard weren't live.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.