8

I recently changed a few settings in the Software updater; one of them being:

Notify me of a new ubuntu version: For any new version.

When it rechecked for updates, this message appeared:

The software on this computer is up to date. However, elementary 15.04 is now available (you have 14.04).

Is it a good idea to perform the upgrade, or should I wait until a new version is released on the elementary.io web page (and revert that setting back to normal)?

  • @Lewis Why was the duplicate done in that direction? The duplicate of this was asked much later - heck it links to this one! – user3 Dec 13 '17 at 18:10
  • The other question is more general, and addresses the idea of upgrading any base vs this one which specifies a version. Mostly though, it's likely this one was flagged and placed in a moderator queue. – Lewis Goddard Dec 14 '17 at 21:40
11

There are two reasons why it's a very bad idea to upgrade.

  1. elementary OS 0.3 (Freya) is based on Ubuntu 14.04 (Trusty). It will almost certainly not work if you were to update to 15.04 - the packages do not exist for it.

  2. 15.04 will be EOL soon; end of life. This means it no will no longer get vital security updates, and so you would need to upgrade again to 15.10 before January 2016.

  3. Based on the past release schedule, elementary OS 0.4 is likely to be based on 16.04 LTS and released around to a year after 16.04 is:

You should update to elementary OS 0.4 (Loki) when it is released. You should only update to new elementary OS releases, never an Ubuntu release as it has different software sources.

It's sensible to revert that change.

7

As the answers before were not that clear IMHO, here's an answer: No, do not upgrade to the 15.04 base. Freya is built upon 14.04 LTS and only that. elementary OS' repositories do not even contain packages for 15.04 (or 15.10, for that matter). You will end up with a broken installation.

The updating software unfortunately is still something elementary OS "imports" from Ubuntu. The less you touch it the better for you. There is work being done on AppCenter which should replace the Ubuntu-specific update routine (which is not meant for elementary OS) in Loki.