2

Trying to compile this simple example, but having this error when trying to run exec:

~/projects/vala-snippets/Fast-Examples/DazzleChart(master ✔) meson build
The Meson build system
Version: 0.49.2
Source dir: /home/stsdc/projects/vala-snippets/Fast-Examples/DazzleChart
Build dir: /home/stsdc/projects/vala-snippets/Fast-Examples/DazzleChart/build
Build type: native build
Project name: exec
Project version: undefined
Native C compiler: ccache cc (gcc 7.4.0 "cc (Ubuntu 7.4.0-1ubuntu1~18.04.1) 7.4.0")
Native Vala compiler: valac (valac 0.40.19)
Build machine cpu family: x86_64
Build machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (0.29.1)
Dependency glib-2.0 found: YES 2.56.4
Dependency libdazzle-1.0 found: YES 3.35.3
Build targets in project: 1
Found ninja-1.8.2 at /usr/bin/ninja
~/projects/vala-snippets/Fast-Examples/DazzleChart(master ✗) cd build 
~/projects/vala-snippets/Fast-Examples/DazzleChart/build(master ✗) ninja
[3/3] Linking target exec.
~/projects/vala-snippets/Fast-Examples/DazzleChart/build(master ✗) ./exec
./exec: symbol lookup error: ./exec: undefined symbol: dzl_graph_view_model_iter_set_value
3
  • According to valadoc.org/libdazzle-1.0/Dazzle.GraphModel.iter_set_value.html, the method is avilable in libdazzle-1.0 since 3.30. I can only seem to be able to install 3.28.1. Can you detail on how you got version 3.35.3 ?
    – Vlad
    Feb 23 '20 at 15:46
  • cloned from official repo and installed
    – stsdc
    Feb 23 '20 at 15:48
  • 1
    Got it, managed to get the same error.
    – Vlad
    Feb 23 '20 at 18:08
0

There was an old libdazzle-1.0.so in /usr/lib/x86_64-linux-gnu. pkg-config used it instead of freshly compiled version 3.35.3, which was installed at /usr/local/lib/x86_64-linux-gnu.

Removed one at /usr/local/lib/x86_64-linux-gnu and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.