2

I'm running Freya on my system, though I never did a clean install of the stable, I always just kept updating the beta. I don't get any notification badge on plank, except for Geary, but I know for a fact that Thunderbird and Update Center are supposed to work, too. Maybe it's an issue related to non-default apps then.

How can I enable these badges?

  • There aren't so many apps making use of this feature. One of them is Geary, have you tried it yet? – tom Jul 2 '15 at 9:47
  • Yep, no luck. Thunderbird and Update Center are supposed to display badges, too. – Giulio Sant Jul 2 '15 at 9:52
  • Wait, my bad. Geary's badge actually works now. I'll update my question. – Giulio Sant Jul 2 '15 at 10:25
  • You probaply know that it is recommended to make a fresh install of Freya. – davidak Jul 2 '15 at 13:31
2

App badges on Plank cannot be enabled or disabled — they simply appear when apps that have implemented support for Plank app badges. Unfortunately, not every application on Linux has implemented this integration. Thus, the only thing you can do is be sure you are using an application which supports that feature. These include:

  • Geary
  • Files
  • Midori
| improve this answer | |
  • As far as I know apps using the unity LauncherAPI for this should be supported as well. (at least it worked last time i tried.) – Jonathan Jul 4 '15 at 19:05
  • Plank uses the Unity API last I checked, so support for one means support for the other. – Avi Romanoff Jul 4 '15 at 22:43
  • I have accepted Avi's answer. Badge display is an app-side feature, so there is nowhere to look in elementary's settings. Upon further investigation, I found out that in the case of Thunderbird there's an extension which provides Unity integration (it had got disabled in my installation, don't know why). I wonder about Update Manager now, do you guys get any badge at all? – Giulio Sant Jul 7 '15 at 8:25
  • Pantheon Mail CountBadge source code, if you want to edit it out manually – wolf Oct 9 '16 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.