2

It's actually quite simple. Run the following commands. sudo nano /etc/xdg/autostart/nm-applet.desktop Find the following line. NotShowIn=KDE;GNOME; Change it to the following instead. NotShowIn=KDE;GNOME;Pantheon; Then save, and restart. That's it!


1

Apparently it works if you set English(US) at first (I don't know why, but English Intl. didn't work for me) and then some other language, the icon magically appears. I had the same issue with EN/PT.


1

Try pressing Super+Space (Or Win+Space) to force it back, worked for me. Keep pressing it if it doesn't stick, because it will eventually.


1

Sorry the late response. I eneded up restoring an image from a few days prior. I tried several things, but I am pretty good about backing up, so decided to go with that option. I used Clonezilla, so just reimaged the drive and went forward from there.


1

Some guy on elementary subreddit helped me. There is a bug discussed on github: https://github.com/elementary/wingpanel-indicator-keyboard/issues/80 As suggested, I've changed org.gnome.desktop.input-sources from [('ibus', 'us'), ('xkb', 'ru')] to [('xkb', 'us'), ('xkb', 'ru')] with the dconf-editor GUI tool, and the indicator is visible now.


1

I had the same issue and solved it by deleting all languages in keyboard settings, and re-adding them again, as stated in this post: Problem with keyboard language indicator


1

I solved this problem by installing Namarupa Hat tip to Anderson Laverde from the ElementaryOS Slack Channel


Only top voted, non community-wiki answers of a minimum length are eligible