We’re rewarding the question askers & reputations are being recalculated! Read more.
10

I managed to make it work with: git clone http://github.com/bulletmark/libinput-gestures cd libinput-gestures sudo make install sudo apt install libinput-tools xdotool sudo gpasswd -a $USER input libinput-gestures-setup autostart And create the file '~/.config/libinput-gestures.conf' with the next contents: gesture swipe up xdotool key super+Left ...


6

If you use synaptics driver you will probably have the synclient program installed. In terminal have a look at you current touchpad settings: $ synclient -l You will get a list with many settings. We are interested in the "TapButtonX options". The X is for the number of fingers, so in your case "Tapbutton3". I guess it will be disabled: TapButton3 = 0 Now ...


6

Answered already in the previous answer's comments. Restating here for the upcoming users, so it would be easy to follow. Solution: sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms sudo apt-get update sudo apt-get install focaltech-dkms sudo modprobe -r psmouse sudo modprobe psmouse Note: This works on all debian based distros (Ubuntu, ...


6

This is a bug reported here if you could contribute your laptop model there for testing purposes. (The issue appears to be that the synaptics driver does not take precedence over the libinput driver.) Some of the reporters had some success from installing synaptics and changing libinput's priority: sudo apt install xserver-xorg-input-synaptics sudo mv /usr/...


5

Edit - This works in Freya NOT Loki Here is my solution for disabling the touchpad in elementary OS when attaching a USB mouse. I created these instructions based on the following websites: https://bbs.archlinux.org/viewtopic.php?id=188918 https://bbs.archlinux.org/viewtopic.php?id=170396 As well as the arch wiki on Synaptics touchpad, but I'm only ...


5

You can change it in System Settings (internally called Switchboard) in the Mouse & Touchpad pane. 0.4 Loki Set the value of "Scrolling" to "Edge". 0.3 Freya Untick "scroll with two fingers", which in turn will enable edge scrolling.


4

There's no beta version at the moment. There's only the stable Freya (0.3) version available on elementary.io. Please, install elementary OS from the official source. If the problems are still there, then see this: How can I report an issue with elementary OS to the developers?


4

Be aware that the input stack simply does not support multitouch trackpads right now. You can interpret or simulate gesture support using things like touchegg, but you won't be able to get 1:1 finger tracking or in-app gestures for things like pinch-to-zoom. This won't be possible until the move to Wayland and LibInput


4

TLDR You can enable touchpad (that is disable auto-disable) with xinput set-prop DEVICE PROP 0 where you can check for your device ID and prop ID with xinput and xinput get-props DEVICE respectively. Let's explain this a little bit: there is a new interface to do this in elementary OS 0.4 Loki xinput. In a terminal window you should look for your touchpad ...


4

I don't know how to get this to work with libinput, but here is how to install synaptics and set it up how you want. The process is fairly easy. Just install synaptics and set up a conf file. If you want to have multitouch gestures then you have to build synaptics instead of installing the package. You will also have to set up a second conf file. It is a ...


3

Thanks for providing the necessary information, after a lot of googling and reading bug reports, it seems the main solutions are as follows, I'll start with the easiest although I know you have already tried it. Adjust the touchpad settings using synclient. synclient -l will give a list of options, for your problem in particular I would start with pressure ...


3

You need to enable the 'Tap to Click' option in Application > System Settings > Mouse & Trackpad You can also enable Two Finger Scroll in the same applet If you don't see Mouse & Trackpad, you can install it with sudo apt install switchboard-plug-gcc-mouse


3

Missing panels in Switchboard doesn't really have anything to do with hardware. Most likely, you've installed some third party software, possibly from a third party PPA that conflicts with Switchboard. You'll need to reinstall the missing switchboard-plug-gcc-* packages from Terminal. For example, for sound: sudo apt install switchboard-plug-gcc-sound You ...


3

Try to add the command to your ~/.profile-file, that should auto-execute this command everytime you log on. But I don't know if it is harmful if the command is executed while the touchpad is working.


3

On elementary OS Loki you can't disable the touchpad from System Settings, you have to install dconf-editor, open it and go to org->gnome->desktop->peripherals->touchpad there on send-events select disable or disable-on-external-mouse, with that you disable the touchpad.


3

I just posted a solution for another question that might help you for this as well on: Way to enable vertical two-finger scrolling, but not horizontal? I removed the libinput drivers for the touchpad and installed the synaptic drivers instead I did: sudo apt-get remove xserver-xorg-input-libinput libinput-tools This removes libinput touchpad driver. Then ...


3

I just posted a solution for another question that might help you for this as well on: Way to enable vertical two-finger scrolling, but not horizontal? I removed the libinput drivers for the touchpad and installed the synaptic drivers instead I did: sudo apt-get remove xserver-xorg-input-libinput libinput-tools This removes libinput touchpad driver. Then ...


3

Running the following command in the terminal could solve this: xmodmap -e "pointer = 1 25 3 4 5 6 7 8 9" To make this persistent, edit your ~/.Xmodmap with a text editor either from the terminal: nano ~/.Xmodmap or with a graphical text editor: open files --> go to your home directory --> open .Xmodmap (a hidden file) with a right click in "...


3

This answer applies only to Loki Okay, so I might have just proven myself wrong. I did: sudo apt-get remove xserver-xorg-input-libinput libinput-tools This removes libinput touchpad driver. Then install synaptics: sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics Then restart. In terminal type: ...


3

You can enable tap-to-click with follow command: gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true


2

X55 series uses elantech touchpad. Upgrade to kernel 4.0 or above it will solve the problem.


2

Reverse Engineered ALPS driver People report successful multitouch support with some alps touchpads when using the driver located at this page. Download that file then in a terminal do the following... cd ~/Downloads tar vxf psmouse-alps-1.3-alt.tbz sudo cp -r ./usr/src/psmouse-alps-1.3/ /usr/src/ sudo dkms add psmouse/alps-1.3 sudo dkms autoinstall sudo ...


2

Try to connect devices by "bluetooth settings" (not just klicking "Connect" in the top bar - this will make it appear to connect but it doesn't connect). Google the "pin option" for your devices, I think it is 0000 but I am not sure. This way I have connected magic mouse, track pad, and apple wireless keyboard on a pc usually being a hackintosh. Just the ...


2

Well, thanks to some assistance on the Purism forums I found the answer to this. (Unfortunately, not before paving the OS, returning to PureOS, and wasting a lot of time tearing my hair out.) The solution is extremely straightforward, so much so it made me feel very stupid. Pressing Fn + F1 enables/disables the touchpad on the Purism Librem 13. So at some ...


2

If you use synaptics driver you will probably have the synclient program installed. In terminal have a look at your current touchpad settings: $ synclient -l | sort (Of course it will show the settings without the "sort" - but it is much easier to find settings when they are listed in alphabetically order) You will get a list with many settings. We are ...


2

Have a look here: Two-finger Scroll is not working for my touchpad of ASUS X200MA Maybe you have better luck in terminal...


2

switch to the synaptic driver: sudo apt install xserver-xorg-input-synaptics then force the synaptics driver to load, achieved by putting the synaptic config file into X11 directory for customisation sudo mkdir /etc/X11/xorg.conf.d sudo cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d


Only top voted, non community-wiki answers of a minimum length are eligible