11

You can launch the shutdown menu with the following command dbus-send --session --print-reply --dest=com.canonical.Unity /org/gnome/SessionManager/EndSessionDialog org.gnome.SessionManager.EndSessionDialog.Open uint32:2 uint32:0 uint32:0 array:objpath:[]


6

As far as I know this isn't supported by elementary. If you really want this feature then you will have to write something custom. If you can trigger a script by hotkey (autokey etc) then you could run "wmctrl -l" and count the lines of output by piping into wc like so: "wmctrl -l | wc -l". Since plank and wingpanel are also counted you would write an if ...


5

Not quite what you wanted, but here was what I was able to find: Shutdown directly: dbus-send --system --print-reply --dest=org.freedesktop.login1 /org/freedesktop/login1 "org.freedesktop.login1.Manager.PowerOff" boolean:true Reboot directly: dbus-send --system --print-reply --dest=org.freedesktop.login1 /org/freedesktop/login1 "org.freedesktop.login1....


4

Finally the best way to solve this problem is installing Nvidia Graphics driver and choose Intel Graphics device in Nvidia X Server Panel. After reboot, now I can shutdown and reboot my laptop normally.


2

I found the solution. The problem is a driver issue with the Intel Skylake graphics chipset. You can solve it by upgrading to kernel 4.3 and upwards. For instructions to update to kernel 4.4 see here: http://ubuntuhandbook.org/index.php/2016/01/how-to-install-linux-kernel-4-4-in-ubuntu/ The only problem is that now there are some random graphical glitches ...


2

The problem is caused by the Thermal Daemon Service not shutting down properly. The default timeout is 90s. This can be resolved by changing the timeout length. Run this command sudo io.elementary.code /etc/systemd/system.conf Delete the # in front of the the two lines below and change the 90s to something lower. I've set mine to 6s and my system ...


2

Try this sudo nano /etc/systemd/system.conf and edit as the image then run uncommented (remove the "#") the fields above to DefaultTimeoutStopSec=9s Then run this command to reload systemctl daemon-reload if you find it still not working, set StartSec to 9s


2

I had the same problem and could not find a solution, you can set the timer to a smaller value in: /etc/systemd/system.conf. (If it is empty, here is a copy: https://p.ip.fi/bZfs) Uncomment line DefaultTimeoutStopSec=90s then change it to a lower value. Then run systemctl daemon-reload Hope it helps...


1

What helps to me in a similar situation was to reinstall plymouth. I recommend doing it on recovery mode - on the grub bootloader screen select advanced options for elementary os and on the next screen choose the [recovery mode] option. Once there first select 'Configure network' in order to have a network connection and after this choose Root. Once there ...


1

According to Dewa Sembiring on askubuntu, Go to tty mode using Ctrl+Alt+F2, if you can't, insert a live cd then get into chroot, try to reinstall your plymouth but before reinstalling the plymouth, try to reconfigure the plymouth first, sudo dpkg-reconfigure plymouth && sudo update-initramfs -u if it doesn't work. ...


1

Try installing tlp it's a must have for laptop power management, the default settings are great but it is also very customisable. $ sudo add-apt-repository ppa:linrunner/tlp $ sudo apt-get update $ sudo apt-get install tlp tlp-rdw


1

The bug was resolved with the latest kernel update, version 4.15.0-42-generic. No further action was required


1

I could tell you to downgrade systemd right away, but you will be able to do it only to the first release not the last update. You'll miss a lot of fixes with it, check the changelog below for more details. http://changelogs.ubuntu.com/changelogs/pool/main/s/systemd/systemd_229-4ubuntu21.10/changelog I recommend you to report this to: https://bugs....


1

Unfortunately I don't know of a real graphical way to achieve that. But because elementary is based on Ubuntu and thus uses systemd, you should be able to do it with a systemd service. Basically create a file /etc/systemd/system/myshutdown.service with something like that: [Unit] Description=Do something on shutdown [Service] Type=oneshot RemainAfterExit=...


1

I'm not sure what is happening there when you press the Shutdown button on the top right corner, but you can always shutdown by opening the terminal and type shutdown -h now


1

I have the same laptop the problem is with Nvidia driver. you need to install "additional drivers" sudo apt update sudo apt install ubuntu-drivers-common Or you can open AppCenter and install "additional drivers" from there. I'm not sure that the package is called exactly that but you can look it up for the exact name after everything is installed ...


1

You can use the command pkill wingpanel in a terminal window or with Alt+F2 to restart stuck wingpanel.


1

I have experienced this type of problem on a number of different systems, but after a lot of work I tracked it down to the lid being opened (after suspend) not being recognised. The fix was simple in the end, just add the following to you kernel parameters button.lid_init_state=open Basically this tells ACPI to emit an extra open event when waking from ...


1

Do this: Open terminal. Type: sudo apt-get install dconf-tools Hit Enter After installing dconf-tools, on screen (desktop), click on Applications (top left of the screen), then find and click on dconf Editor (normally the logo is a Magnifying glass with a checked red box) In dconf Editor, go to: org > gnome > settings-daemon > plugins > power ...


1

You have to edit logind.conf in /etc/systemd, and change the line as shown below (remember to unhash it): HandlePowerKey=poweroff Now I'm on Manjaro, so I can't confirm if it works, but it should.


1

Try: sudo apt-get install indicator-session Then reboot and it should be there again


1

A quick search has revealed that your laptop has an AMD Radeon R5 M240 graphics card? If that is true, the problem probably is driver related, I had the same problem with an AMD Radeon R5 M335, none of the changes you mentioned would work. I fixed it by activating the proprietary fglrx driver for AMD video cards in the additional drivers tab of the update ...


1

Try typing: sudo sync && sudo poweroff WARNING: This program will instantly shut off the computer so you may want to save some data if you are currently working. If that doesn't work too and your pc restarts, there might be a hardware or BIOS configuration problem.


1

OK, so the problem can be solved much easier than installing a new kernel - namely by activating the proprietary drivers for AMD Radeon graphics card (called fglrx). You can choose between fglrx and the open source xorg drivers in the additional drivers tab of the update settings. After fglrx has been installed, the problem doesn't occur anymore. So it ...


1

You wont be able to take an actual screenshot, although if the error occurs early enough in the shutdown process (before the logger service is stopped and the hdd's have been unmounted) it should be visible in your logs via less /var/log/syslog. If you can't see anything obvious, these answers show various ways to enable more thorough logging. Alternately ...


1

The original poster's temporary fix was to restart lightdm via the command line, which would be: sudo service lightdm restart OR sudo systemctl restart lightdm You can also try reconfiguring lightdm.


1

Use gshutdown. Install from software center. Now open gshutdown and adjust settings as per your need. To adjust delay, select After a delay You can enable notification for gshutdown in Edit --> preferences --> Misc Alternatively you can use complexshutdown and easyshutdown. Download .deb for easyshutdown and install it via software center. EDIT: (...


1

I mean, you could just add a sleep 60 && before your shutdown -P 1, turn that into a shell script, I guess. You would have no visible timer but it should give you 60 seconds before shutting down your pc. BTW working with a bright displays as the only light source, late at night, up until 60 seconds before literally going to bed, is seriously messing ...


1

I have a laptop the same obsolete GPU.It was having artifacts and I could fix it by running sudo apt-get install mesa-utils sudo mkdir /etc/X11/xorg.conf.d/ echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf sudo reboot


Only top voted, non community-wiki answers of a minimum length are eligible