57

Use Eddy (the recommended, graphical, elementary way) Read this other answer about using Eddy, which can be installed in AppCentre. Use gdebi-cli sudo gdebi package.deb Use gdebi GUI sudo apt install gdebi Then open the package using gdebi Use apt (the proper cli way) sudo apt install ./package.deb Use dpkg (the way that doesn't resolve dependencies)...


38

As far as I know it is intentional from the eOS team. I also had such issues in Loki beta. In order to add PPAs run the following in the terminal sudo apt install software-properties-common


23

I had this same issue and found out it was actually due to a conflicting keyboard shortcut with Alt+Shift which changes keyboard layout. Going to Settings > Keyboard > Layout and changing the Switch Layout binding to Alt+Caps Lock made Alt + Shift + Tab behavior consistent again.


22

You can change it by editing the file sudo -i scratch-text-editor /etc/lightdm/pantheon-greeter.conf There you will find the line default-wallpaper=/usr/share/backgrounds/elementaryos-default Add a line to the file something like this: default-wallpaper=/usr/share/backgrounds/168.jpg Logout and you can see the change.


20

You can install redesigned version elementary tweaks on Loki. sudo apt install software-properties-common --no-install-recommends sudo add-apt-repository ppa:philip.scott/elementary-tweaks sudo apt update sudo apt install elementary-tweaks Note: please, read elementary team's stance before installation tweaks.


20

You can get the plank preferences by doing either Ctrl+right-click on the plank, or from a command line plank --preferences.


15

elementary have a saying about release dates, and they are quite serious. When it's ready. elementary releases are targeted to features and bugs being fixed, rather than some arbitrary release date.


15

elementary OS does not support GtkStatusIcon (commonly referred to as system tray), and will drop support for the Ayatana Indicator API in the next release. GtkStatusIcon (the old API for apps to place icons in the panel) has been deprecated since 2014 and is not implemented in elementary OS. Please file a report with application developers that are still ...


13

Just copy your wallpaper to /usr/share/backgrounds (you're going to need root privileges to do so) and then select your wallpaper from System Settings -Desktop - Wallpaper. That should also change the login background. In fact there is a bug where the login picture cannot be changed: https://bugs.launchpad.net/elementaryos/+bug/1391716 also: https://...


13

A solution (or at least temporary workaround) proposed in the bug discussion - https://bugs.launchpad.net/elementaryos/+bug/1596377 - is to rename the file: /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled This fixed it immediately for me.


12

I don't have dual graphics, but I do have a Haswell based machine with a GTX 960. I installed the release version of Loki and had slow, stuttering Nouveau graphics even though I had selected to install proprietary drivers during installation. This is what I did to fix it, afterwards I had fully accelerated binary drivers from Nvidia and a smooth, fast ...


11

elementary OS releases are made on a task-based cycle and not a time-based cycle. Releases basically happen like this: Currently, elementary OS releases are built from Ubuntu repositories. At the beginning of the cycle, we choose a target repository to work from. For Loki, that repo is Ubuntu 16.04. We set up a daily repository where we build our source ...


11

Actually this issue touches two different bugs in Loki: Printscreen "PrtScn" button doesn't actually take a screenshot Custom keyboard shortcuts not working, loki fresh install


10

According to this tweet from the official elementary OS Twitter account, it won't be possible to directly upgrade. A clean install will be required. See also: Should I download loki beta or freya?


10

There continues to be no officially supported way to upgrade between version of elementary OS. This is due to the installer being a patched Ubuntu/Debian installer with no custom elementary support for upgrades, only detection (which I believe has been upstreamed). Clean installation is the recommended method, this creates a new working environment and ...


10

One easy way to install Debian files easily is to install Eddy. Run this command to install it sudo apt install eddy As Seth noted out in the comments, the previous does not work in Elementary OS 5.0 Juno. Try this instead: sudo apt install com.github.donadigo.eddy To install a Debian package with Eddy first you open it and it will show this page: If ...


10

Elementary will not install Gimp, or any other third party app, during install. Elementary has it's custom apps that are installed and everything else is left to the user to install. But it's very easy through the App Center or via the command line. Elementary is also not setup to add PPAs by default for security/usability reasons. You can set your system ...


9

There is no final list. You can see the current list by going to https://launchpad.net/elementary/+milestone/loki-beta1 Currently, there's 39 blueprints linked to the Loki Beta 1 version. The list is constantly being changed and that's perfectly fine for the current state of the release. The AppCenter is currently being developed and will probably be a ...


9

What would it take to create an unofficial 32-bit version of Loki? A lot of work without using our existing build infrastructure. What would be the steps required to build it from the source? Again, a lot of work and fiddling. I don't believe there are succinct instructions anywhere. What would be missing or non-functional? Nothing, so long as ...


9

You can install manually that program with this : sudo apt-get install software-properties-gtk sudo apt-get install update-manager


9

No, there is no 32-bit iso. Only 64bit.


9

For Gmail: Go to Go to https://myaccount.google.com/security Click App passwords: Generate it and copy In calendar app enter google email and generated password.


9

Step 1. Update Open up AppCentre Navigate to the Updates tab Install all available updates Reboot if required Now your System Settings > About section should look like the following image. Note that it states "elementary OS 0.4.1 Loki", not 0.4. Step 2. Upgrade Kernel [Optional] While your system now runs the latest version of elementary OS, it may ...


8

Ctrl + right click on a plank icon In this menu you can now click on preferences (of plank) There you can choose between some themes...choose 'transparent'


8

While the "suggested" upgrade path is to install Juno from scratch, and if you have your /home as a separate partiton might be the best method to be safe, I've just updated both my PCs with the apt method and all went well. Since Juno is based on Ubuntu 18.04 (bionic) while Loki in based on 16.04 (xenial) it was a simple matter of substituting all ...


7

There isn't currently a way to upgrade from one release of elementary OS to another. From the release announcement: elementary OS Luna users should back up their data and perform a clean install. Upgrading to elementary OS Loki will probably require a clean install as well. Upgrade support is planned for a future version of elementary OS, though.


7

You can use the options already provided. Or you can install Gnome Software. sudo apt install gnome-software Gnome Software is the new shop for Ubuntu 16.04. With it you can install the .deb package, and the same list these softwares installed, options that the AppCenter doesn't have. The Gnome Software does not disable AppCenter.


7

elementary has a full screen mode that might get close to what you're looking for. It's disabled by default, but you can enable it by going into the Settings app, editing keyboard shortcuts, and assigning a key to fullscreen mode. In full screen mode, the top bar and plank aren't shown, and each fullscreen app gets its own workspace (Super-Tab to cycle ...


7

There is already a bug report for this problem, see Bug #1596377. As suggested in the comments, the following workaround seems to fix the problem for some users: sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.backup This worked for me, no delayed startup for the last couple of days (before it was ~2min after ...


Only top voted, non community-wiki answers of a minimum length are eligible