Hot answers tagged

9

What worked for me: Switch to next desktop (windows key + right arrow) Now you can click the "X" to dismiss the notification Return to your daily business


5

The Connection field should contain the protocol and the local address of the printer, something like socket://hostname or http://hostname:631/ipp/. There are several ways to try: Use sudo hp-setup -i in Terminal and follow the instructions Go to CUPS and add the printer from here Find your printer's local IP or (preferably) assign a static IP (either ...


4

First open a terminal and launch system-config-printers or search Slingshot for "System-Config". When it's open it looks like this: Right click and check it is shared: Now we have to change the server settings as per this instruction: And then check the two check marks Publish shared printers connected to this system and optionally Allow printing from the ...


3

You can install the package hplip via the command line in a terminal: sudo apt install hplip


3

Open an email, click on downward arrow--> print.


3

You can disable notifications for your printer under: System Settings -> Notifications For me there are two entries Printer and System Config Printer Notification. Maybe just toggle them off/on helps to dismiss the notification.


2

Brother has an Debian Linux installer (which will work for elementay OS, by virtue of it being based on Ubuntu which is based on Debian) for the HL-2040. The HL-2040 is the closest driver available and which will most likely work for the HL-2030. Their starting page has links for each region supported. Click on the link for the region where the printer is ...


2

Accoring to the official HPLIP-homepage your printer needs al least HPLIP version 3.14.10. Unfortunately elementary OS only provides HPLIP version 3.14.3 in it's repositories. You need to install the latest version of HPLIP in order to get your printer running. I'd suggest you take a look at godslayer_69's answer to a familiar question, the installation ...


2

Go to http://localhost:631 (web-based-printer-setting), select Administration and then checklist Server Settings as follows ...


2

You can (re)install cups with sudo apt install cups


2

I found on Canon's website link to drivers for your printer: Drivers Just select Linux 64bit and download. ;)


2

UPDATE All of the hp-setup and installation was unnecessary. After new install and updated elementary OS 5.0 Juno, just open up http://localhost:631 in your browser, click on Administration, then Add Printer. Enter your local username and password. Select Discovered Network Printers of choice (in my case HP OfficeJet Pro 8710) and continue with prompts ...


1

You have CUPS as printing system, however you have a nice GUI to configure it in the Switchboard (System Settings) as well:


1

As you have only one printer in the list, you could not set another one as default. I guess this is really rather a feature than a bug.


1

try with: sudo system-config-print -> Add -> search your printer and install -> then click secondary -> properties -> politics -> check activate and accepting jobs Note: if system-config-print is not installed, do: sudo apt install system-config-print


1

Sounds like it may not be sent to the right printer....or the printer needs to be power cycled. In the printer settings, you should note if the printer appears with a green indicator over the printer icon. If not, it's not ready t print. Usually when I print, I go to print, a dialog box asking me to choose my printer pops up (very important step), I select ...


1

If it's supported in Ubuntu 16.04, it's also supported on eOS Loki. I had a similar problem with a HP printer. When you first plug it in, you have to select it from a list. The names are approximate. I have a Deskjet Ink Advantage 3785. When I selected from the Ink Advantage series it didn't work, I had to select it from the Deskjet 3700 series. So try ...


1

Running the following resolved it for me: sudo apt-get install hplip --reinstall I also removed and re-added the printer in System Settings. When selecting the driver via the add printer wizard, ts easy to miss that the right hand driver pane is scrollable so I think I may have previously been selecting the incorrect driver. There is a driver for the 3520 ...


1

fixed! You need to install SMBclient (I did it through synaptic package manager) once done you then have the option to look for a SMB shared printer in the printers app.


1

Strange, I have a CDW 9330 printer and it works well. Scanning does not. I gave up on that. So, I can understand the madness. Please breathe deeply and try again. First, test if you can reach the printer from your eOS machine by pinging it. Printing over WLAN is notoriously unreliable in our house. There really are differences between devices.To rule this ...


1

This is how it works with scan machine from Brother (all-in-one). Maybe you should just replace scan command to print command? And of course need to replace IP adres and name of machine. Download and install those packages : brscan4, brscan-skey and brother-udev-rule. Check if you Brother model is available to configure - run command in terminal: ...


1

You can install these drivers via the command line by installing the debian packages you see in the folder. Issue the following command line in a terminal window (right-click on the Files window and select Open in/Terminal) sudo dpkg --install *.deb


1

Run sudo apt-get install gcc-4.8-base:i386 libgcc1:i386 libc6:i386 The follow these instructions for your Brother printer. Or in Synaptic, search and install these: brother-lpr-drivers-laser brother-cups-wrapper-laser brother-lpr-drivers-common


1

To add to above since I can't comment yet... You also have to fill out the description before the 'Add' button enables. It will have example text, but I thought it would just use that, so I kept trying different things and it wasted my time for no good reason. At the time of this writing, the minimum to trigger the 'Add' button (assuming http) is 'http://' ...


1

I use HP Officejet and in my case I just plugged the printer and clicked print - It worked without installing any software. :)


1

You can check at http://www.openprinting.org/printer/Epson/Epson-XP-412_413_415_Series You should install the amd64 deb package from this site, download it and use the command line user@machine:~/Downloads$ sudo dpkg --install epson-inkjet-printer-201301w_1.0.0-1lsb3.2_amd64.deb After this you might have to install missing depenencies as well: user@...


1

elementary OS doesn't have an option like Ubuntu of loading directly from PPD. I would recommend instead downloading the driver directly from the manufacturer's website with their install script and following elementary's prompts. If you would like to configure additional administrative features, run system-config-printer in your Terminal. Alternatively, ...


1

To get the scanner to work you have to download and install the drivers from canon. This also supplies a scanner program that should work with your scanner. The installation is done by untarring the downloaded file by right clicking on it and selecting expand here (could be slightly different as i am translating from a dutch system). This will create a new ...


1

i have tried a lot different stuff. I uninstalled Hplip and Reactive HP LaserJet 1018/1020 after reloading paper. (strange packet name, huh?) It worked by default adding printer via Settings / Printers.


1

Download the printer packages and install: ESC/P-R Driver (generic driver), Epson Printer Utility. Then, open a terminal and go to the folder containing the downloaded files: 1°:ls 2:cd Download 3°: sudo dpkg -i epson-printer-utility_1.0.0-1lsb3.2_amd64.deb, for example. After instalation, open System Tools, click printers and add printer. Search for the ...


Only top voted, non community-wiki answers of a minimum length are eligible