The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Hot answers tagged

16

I tried installing pm-utils and invoking sudo pm-hibernate but that didn't work. Can you be more specific? As @Lewis noted, hibernate is disabled by default (even in Ubuntu). If you wish to hibernate manually with pm-hibernate examine the pm-utils logs (less /var/log/pm-suspend.log) for clues. Enable Hibernate If everything appears to be successful in ...


7

The solution given by cheekyngeeky does not work for some laptops. Alternate solution: sudo vim /etc/systemd/logind.conf find line "#HandleLidSwitch=suspend" Replace line with "HandleLidSwitch=ignore" finaly, restart service: sudo restart systemd-logind


4

elementary OS Freya is designed to resume from where you left it even when you Switch Off the machine. For instance, opening Scratch will, by default, open all the files you were editing last time. As such, a design decision was made to remove it, coupled with the fact that hibernate is hardware dependent, and does not work on many systems.


4

Aside from already suggested answers (force enabling of hibernation, and normal shutdown as apps should resume where they left, which obviously doesn't work for non-elementary apps like LibreOffice etc.), there is a third option: Suspend. If you just want to start a new day where you left the day before, the prefered way is to suspend rather than hibernate. ...


4

Long story short, it's not something that could be done technically in Freya. In the next release, with the migration to SystemD, it will be technically possible to implement the feature again.


3

You can configure the power button by opening System Settings -> Power and making your selection from the dropdown labeled "Power button" There is not currently an option to show the end session dialog. This is not something that is provided by the upstream software component that elementary OS uses for this feature.


3

I wanted this functionality as well but couldn't find it online anywhere. It looks like the Hibernate option was removed a long time ago because it fails on some systems (which perhaps was the case a long time ago :-). On my Dell XPS 9350, hibernate works just fine with elementary OS (via 'sudo systemctl hibernate'). This aspect of elementary OS is handled ...


3

If you click on the menu entry called Shutdown... it does not turn off the system immediately but instead opens a dialog, where you can also click on Restart (pictured in the middle). Alternatively you can just type "Restart" into Slingshot or use the terminal command sudo shutdown -r now.


2

Calibrating the battery may help with this. To calibrate it you just need to fully charge it, then use it and discharge completely and charge it again til 100%. If you still experience the same issue then is probably what cheekyngeeky pointed out.


2

I believe this to be a solution for what you're wanting to do: Open a Files window as admin by right clicking Files and selecting "New Window as Administrator. Navigate in the File System to /etc/systemd and open logind.conf with Scratch Text Editor. Directly below the line reading #HandlePowerKey=poweroff add a new line of text reading: HandlePowerKey=...


2

Check TLP Settings: All TLP settings are stored in the config file /etc/default/tlp USB USB_AUTOSUSPEND=1 Set autosuspend mode for all USB devices upon system start or a change of power source. Input devices like mice and keyboards are exluded by default (see USB_DRIVER_BLACKLIST below). Possible values: 1 – enable 0 – disable Note: TLP activates USB ...


2

The command line 'copy-pasta' method for the impatient: gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing' gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action 'nothing' You can change to one of the following values


1

Update: Augustin found a better approach for using a SystemD service: One option to make this powertop tune permanent: Copy the command powertop executes when switching the nvidia tunable from bad to good. In my case that was: /bin/echo auto > /sys/bus/pci/devices/0000:02:00.0/power/control Add a SystemD service that executes that command: create: /etc/...


1

Try this: sudo su su - -s /bin/bash lightdm gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing Note that if you 'sudo' instead, it won't work properly. This fixed it on my XPS 15 9560 :)


1

You should check wether your current graphics card drivers are up-to-date. Moreover, disabling such drivers can help to see if the issue is fixed. If using the intel-based graphics card, you can use these commands to fix the issue. /etc/default/grub and add acpi osi=linux to GRUB_CMDLINE_LINUX=. The run update-grup, it should work properly.


1

TL;DR It's up to apps to tell the system that they want to block sleep The problem is that there's no way to know the semantic content of an audio or video stream without the app declaring it. You and I know that we don't want the computer to suspend in the middle of a movie, but the computer doesn't know the difference between a movie and a visualizer or ...


1

The issue is now solved: first I followed these two tutorials: 1. Improving Power management in EOS Freya (though using Loki 0.4.1) 2. Most Effective Ways to Reduce Laptop Overheating in Linux Then I had a system update (drivers and intel chip) and since then resume from Suspend is going rather smoothly, and also lid close to Suspend goes fine too now.


1

You could use Terminal and gsettings set org.gnome.desktop.lockdown disable-lock-screen true or use dconf editor and go to: org > gnome > desktop > lockdown and set disable-lock-screen on true This way you still can have the screen sleep and also enter suspend but still wake up directly into your desktop (without lock screen).


1

I'm not sure if this will be the solution for your problem, but you could try turning of the Screen Lock (normaly it shouldn't exit applications). Got to System-Settings->Security->Locking: Also try to set "Sleep when inactive" to "never" under Energy


1

You have the option to dim the display automatically when you aren't using it (on battery). Also you can suspend your laptop automatically, saves much more energy than turning the screen off, and it takes just a few seconds to load everything again. Brightness has nothing to do with plugged in / battery so it's good where it is now. I mean, you change the ...


1

I found the solution. I needed to add the ppa for caffeine sudo add-apt-repository ppa:caffeine-developers/ppa sudo apt-get update sudo apt upgrade That seemed to do the trick. Now I have caffeine indicator. Works well.


1

Disabling USB autosuspend completely – as described in the previous answer – will increase power consumption considerably. I finer approach would be to isolate the offending USB device by blacklisting the devices one by one: USB_BLACKLIST="1111:2222" and apply the new setting by: sudo tlp usb Refer to TLP Troubleshooting for background on the subject.


1

you might also want to try the following at grub boot... hit e on the line with /vmlinuz ... try adding the option nomodeset towards the end of the line then boot I have found that many display issues are "fixed" by this ... EXCEPT seens to not work with multi-monitor setup


1

Install dconf-editor, and open up org/gnome/settings-daemon/plugins/power And there you can find various useful power-related settings that you can tweak/toggle:


1

Boot using the recovery option in your grub. Then open a terminal window and type: sudo nano /etc/default/grub Add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT: It should now look like this GRUB_DEFAULT=0 GRUB_HIDDEN_TIMEOUT=0 GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=5 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` ...


1

You should install TLP and Thermald Be careful, TLP is NOT compatible with acpid or Laptop_mode_tools. One more tweak: open a terminal and type gksu gedit /etc/default/grub then look for GRUB_CMDLINE_LINUX_DEFAULT=" " and add intel_pstate=enable finally save and close gedit after that write in the terminal: sudo update-grub Reboot and done. This ...


1

I use elementary OS freya and there is a GUI app for powermanagement. Remove all instances of sleep, suspend and hibernate. You can leave turn the display off. That disables automatical suspend, but will leave the manual suspend up in the menu in the right upper corner. Mbr Patte


Only top voted, non community-wiki answers of a minimum length are eligible