2

While it probably won't result in a noticeable difference, a 32 bit install will use slightly less RAM overall as the OS addresses it differently and you don't need to load both 32 and 64 bit libraries into memory if programs require them. Use the free -m command to see if you are running out of RAM when these stutters occur. If you have a little to spare ...


2

Have you tried restarting lightdm?? When you get you screen locked, press CTRL + ALT + F1 and you will enter in console mode, then log in and execute the next command. sudo service lightdm restart if nothing happend then press again CTRL + ALT + F1 and check for an error message


2

In my opinion, Freya will have lower performance. I have not a single fact but I remember the "exposé effect" much smoother in Luna that in Freya, for example.


2

Because this is a subjective question I’m sure you will get different opinions here (especially as it is an elementary OS User forum). Firstly elementary is stable (I have similar specifications to you) and the drivers are supported. I spend much of my time helping Windows user transition to Linux (specifically elementary) and there are clues in your ...


1

Check this: https://snapcraft.io/auto-cpufreq Hope, this will suit your needs.


1

The first step in resolving these issues is to see if you can establish whether your system is CPU bound, I/O bound, or memory bound. This is just a fancy way of saying you have a bottleneck at the CPU, disk/network, or memory. Install Gnome System Monitor from the AppCenter and when you start to notice the system is slowing down or freezing open it up and ...


1

Try installing tlp it's a must have for laptop power management, the default settings are great but it is also very customisable. $ sudo add-apt-repository ppa:linrunner/tlp $ sudo apt-get update $ sudo apt-get install tlp tlp-rdw


1

To install updated drivers for all hardware run the following command in a terminal and reboot your system once it completes, reference: sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04 To get the latest stable graphics drivers (for better performance and compatibility with newer games) you can add this PPA to your ...


1

You have only 2GiB of RAM. It's normal that your computer can't handle multitasking really well. You have a few options: A) Buy some extra RAM. If you have a laptop you can also add more RAM sometimes. B) Take it easy. Don't rush to open all the programs. Let them some time to load and save their data to the swap. You can also invest in a SSD to make your ...


1

I suggest reading these two articles since I can't be any better in stating my point of view. (I will put a extract of them for those who want to decide if the articles are worth reading): "A couple of years ago, gaming on Linux was a joke. There were a few open source games that, while fun, were nothing compared to the Call of Dutys, Battlefields, ...


1

One terminal command you can use is called 'top'. The link is here. I personally would use that and leave the terminal window open and just monitor it to see what process is causing the issue. This will at least give you an idea to where to start looking.


1

The System Recommendations are: Intel i3 or comparable dual-core 64-bit processor 1 GB of system memory (RAM) 15 GB of disk space Internet access That being said: I run freya on a Dell Laptop from 2003. While it is slow, it's still faster than anything but LXDE. There is also a way you can turn off animations in pantheon, which will speed ...


1

If andrew's solution didn't work, make sure that you got your video drivers installed properly, or your system might run in software-rendering mode, because then your video will be rendered via CPU. You can also check that with: glxinfo | grep OpenGL Take a look at Direct Rendering, if it says no, your CPU is rendering everything.


1

open a terminal and the command sudo rmmod intel_powerclamp will remove the powerclamp module from your running system. If that fixes it, you can can enter the following in a terminal cd /etc/modprobe.d sudo su echo install intel_powerclamp /bin/true > intel_powerclamp.conf to stop it loading when your system restarts.


1

On ark.intel.com your processor only capable handle 2GB memory RAM is useless if you use 64bit OS, since pointers can take up twice as much space on a 64-bit operating system. You should go with 32bit version.


Only top voted, non community-wiki answers of a minimum length are eligible