Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.
27

There are multiple ways to remove a PPA. Option 1 : Open the Applications menu ( super + space ) and search for Software and Updates In the Software and Updates app, select the Other Software tab and select the desired PPA from the list. Click Remove to remove it. Option 2: In Terminal, use the -r or --remove flag to remove, similar to how the PPA was ...


12

Depends what distribution you're comparing elementary OS with. Comparing with Arch and derivatives the packages are outdated, simply because elementary is stable and not bleeding edge. Comparing with Ubuntu, elementary OS freya uses the same repositories as Ubuntu 14.04 for most of it's software including the kernel (3.16). Within the Ubuntu world you ...


5

It is a known issue, it's reported and confirmed here: https://bugs.launchpad.net/appcenter/+bug/1587975 I'm still waiting for an fix or update myself.


4

As per these comments, using --no-install-recommends prevents the extra packages from installing.


3

You dont need 'gdebi' anymore...just open Appcenter and install Eddy.


3

When you get permission denied try adding sudo before the command. Your commmand should be sudo apt-get update.


3

Ubuntu itself is apparently working on replacing Deb packages with Snappy apps, and GNOME is working on cross-distro sandboxed applications. I wouldn't be surprised if one of these projects made it into Ubuntu LTS, which could get rolled into Elementary. To be clear, that's 100% speculation on my part. That said, folks from upstream projects definitely are ...


2

There are not any plans to switch away from Debian/apt at this time


2

The solution is after discussion in chat. Thanks to @Sneetsher for his assistance/help. The main error: dpkg: error: too-long line or missing newline in `/var/lib/dpkg/arch' The simple command will do the trick: sudo sh -c 'echo -e -n "amd64\ni386">/var/lib/dpkg/arch'


2

Reinstalling libglib2.0-0 will fix this error in my case. sudo apt-get install --reinstall libglib2.0-0 libglib2.0-bin libglib2.0-data


2

Seems to me you can only do is to reinstall elementary OS. If there some files you want to backup, try it, but that's what I would do, reinstall system.


2

Do not add Debian sid to the sources as this will overwrite all the Freya / Ubuntu packages with Debian sid ones and will break your system.You might be able to find a PPA somewhere though


2

I'm not sure if Sean Patterson's answer is enough to prevent it from being updated by the AppCenter in the future. Hence, I'd also mark the package as held back using ‘apt-mark’ command in terminal with root privileges. For example, making your package say Firefox unavailable for install, up-gradation or uninstall, type: apt-mark hold firefox To make ...


2

Install Synaptic Package Manager sudo apt install synaptic launch the program and search for firefox select it, then select Package at the top select Force Version... from the pull down select the version you want click Apply


2

Try these commands out. sudo apt-get update sudo apt-get install software-properties-common sudo apt-get update sudo apt-get install gdebi Those will let you install third party applications and repositories in the terminal.


2

TLDR: You may safely remove libdvd-pkg with sudo apt remove libdvd-pkg if you don't run DVDs. This is probably a problem with the package and doesn't seem to be a problem specific to elementary OS as it also affects vanilla Ubuntu 18.04. It's removal may affect if you run DVDs.


2

all you have to do is: sudo dpkg-reconfigure libdvd-pkg


1

If you installed a third party kernel and then removed the source this could happen It's not ElementaryOS's problem (because EOS didn't had that kernel version - Release Candidate) but I may help you You can remove the package even if it's broken with the command: $ sudo dpkg --remove --force-remove-reinstreq <package> And lastly, it's sudo apt ...


1

libgfortran3 depends on gcc-5-base version 5.3.1-14ubuntu2. But you have version 5.4.0-6ubuntu1~16.04.9. Downgrading gcc-5-base to required version should solve your problem. To downgrade to required version, run this command. sudo apt install gcc-5-base=5.3.1-14ubuntu2


1

You can use the tool "apt-clone" for this. http://manpages.ubuntu.com/manpages/yakkety/man8/apt-clone.8.html But i would recommend to start fresh and install only those packages you currently use..


1

After trying to fix this countless of times I found a solution. First I ran sudo dpkg --configure -a then sudo apt-get install -f (Too see what package gives the problem) After I saw the problem was still there I edited it manually. I Located the corrupt package, and removed the whole block of information about it and saved the file. sudo -i nano /var/...


1

Looking at your error list in screen 1, it seems as if you have a DNS failure - perhaps check that you can reach, say apple.com, with Epiphany, and go from there. HTH


1

I had the same problem and it showed a black screen after the boot logo. But then on the black screen I pressed enter and then entered my password. Then after a while when I pressed the volume button it made the noise hence confirming that there something went wrong with the graphics driver. So,from the Grub loader I went to the recovery mode and then to the ...


1

With no other solution, I did a fresh install. For other users, that have to do a fresh install when running into the HWE hardware-enablement stack impass, be advised: don't chose the option to update while installing. I did, and it got me exactly in the same place. A stall after booting and not going to the logon screen. Following @Ryan-DeBeasi advice, ...


1

You can use y-ppa manager To install open terminal and run: sudo add-apt-repository ppa:webupd8team/y-ppa-manager sudo apt-get update sudo apt-get install y-ppa-manager It is GUI tool to remove, purge etc. PPA. It is also used to remove duplicate PPAs and to import missing gpg keys etc.,


1

What did you do last? This can happen when you remove a 32-bit package on a 64-bit system.After that the system does not need these libraries and will add them to autoremove. If it is that then safely remove (but create a system snapshot before so you can restore if anything breaks)


1

Try running: sudo apt-get clean and then try again this command: sudo apt-get install -f then: sudo dpkg --configure -a and finally update your packages: sudo apt-get update If this doesn't work I'd advise you to install synaptic package manager (it's a gui client) and it will be way easier to manually remove the broken packages. To install synaptic ...


1

To install the latest and correct Krita on Ubuntu and derivatives (elementary OS) run the following commands sudo add-apt-repository ppa:kubuntu-ppa/backports sudo apt-get update sudo apt-get install krita This will add the PPA and install Krita.


1

While what you saw was likely a bug and I'm on Loki (the next release) and unable to check this in Freya, I think there are a few things worth clarifying. While elementary OS is based on Ubuntu Long Term Support editions, "support" has a really specific scope. Major Ubuntu releases are "supported" with fixes and upgrades for nine months and the five-year "...


Only top voted, non community-wiki answers of a minimum length are eligible