Questions tagged [package-management]

Tools for installing and maintaining software packages.

Filter by
Sorted by
Tagged with
0 votes
1 answer
91 views

Support for Ubuntu applications in Elementary

I am confused about support for applications packaged for Ubuntu, whether distributed directly by Ununtu or in third-party repositories, in Elementary OS. I have searched for LibreOffice and Firefox (...
brainchild's user avatar
0 votes
1 answer
47 views

Unmet Dependancy Error while installing new package

I was trying to install elementary-tweaks using the instructions from their github page. I first did a sudo apt install software-properties-common. Then sudo add-apt-repository ppa:philip.scott/...
Aswin Haridas's user avatar
1 vote
2 answers
75 views

Linux: How to Completely Remove ALL Traces of a Program? [closed]

Is there a way to completely remove ALL traces of a program in Linux? I've researched a lot on this, and I've seen people talk about apt-get remove packagename, apt-get purge packagename, apt-get ...
user avatar
0 votes
2 answers
54 views

Can I run 'sudo apt autoremove' safley?

I'm just wondering if I can run sudo apt autoremove with the following packages installed. I have run it a number of times before on ubuntu and I am on a laptop and sometimes the GUI fails, sound card ...
Robert Johnstone's user avatar
0 votes
0 answers
45 views

How do I install a newer version of a package on elementary-os?

elementaryos 5.1.4 Hera is based on ubuntu bionic (18.04) which contains zfsutils-linux at version 0.7.5. However I need version 0.8.0+ which introduces encryption. What is the proper way, to install ...
John Smith's user avatar
1 vote
0 answers
380 views

Install R 3.6.3 on elementary OS: unmet dependencies

I couldn't find R or Rstudio on the built-in Elementary app store thingie, so I'm following instructions from the R project to install R in my new Elementary OS sandbox. sudo apt-get install r-base-...
eric_kernfeld's user avatar
0 votes
1 answer
134 views

xsetwacom on elementary OS Hera?

I'd love to use xsetwacom to look into some wacom issues & features. For example improving the usability with multiple monitors. But I can't find or install it. Following: https://medium.com/@...
Peter Uithoven's user avatar
1 vote
0 answers
79 views

Can't see sound settings on Loki after upgrading from AppCenter

AppCenter were indicating for months that there was an update for ibus and gir. I never use the AppCenter so I continued to use my bash alias to update the system: alias upd8="sudo apt update &&...
Vinícius Ferraz's user avatar
0 votes
3 answers
112 views

File manager deleted after update, now can't reinstall it (broken dependencies)

After a recent update and apt autoremove, the Elementary OS files app was somehow removed. I tried to reinstall it from the appstore, only for it to complain that tumbler and tumbler extras needed ...
adamdesign's user avatar
0 votes
0 answers
391 views

Error: could not find a distribution template for elementary/juno

I have a problem on my elementary os Juno. So when I want to add a ppa, it answers me : arthur@arthur:~$ sudo add-apt-repository ppa:mpstark/elementary-tweaks-daily Traceback (most recent call last): ...
Arthur's user avatar
  • 1
2 votes
4 answers
5k views

libdvd-pkg: `apt-get check` failed?

I get this message after installing any program via terminal libdvd-pkg: apt-get check failed, you may have broken packages. Aborting... as seen in the image: note: i don't really know if this ...
pole's user avatar
  • 51
0 votes
1 answer
191 views

cant sudo apt-install

whenever i try to install i get this error: E: The package linux-headers-4.1.0-040100rc2-generic needs to be reinstalled, but I can't find an archive for it. or E: The package linux-headers-4.1.0-...
Peter Hauer's user avatar
0 votes
2 answers
3k views

Cannot install gcc and g++ on Elementary OS Juno

Yesterday, I installed Elementary OS Juno. This is a fresh install. When I tried to install g++ it gave me following stream of Errors. Basically some dependencies are unmet. When I tried to install ...
cstayyab's user avatar
  • 121
0 votes
1 answer
352 views

Package manager blocked

Since I had no answers writing in Portugese, I'll try to translate my problem to English. I am trying to update the system and some apps via AppCenter (I guessing the name of the store like ...
Levy Mota's user avatar
0 votes
1 answer
240 views

Can't upgrade my packages

Short version: I can't upgrade my packages (I'm using Elementary OS 0.4.1, based on Ubuntu - that's why I'm asking here). Long version: First step I try fetching package informations via sudo apt-...
Thomas Artmann's user avatar
0 votes
1 answer
274 views

Unmet Dependencies and Package Broken

Getting this error even after installing packages manually as the depends warning continues. Packages installed : libgegl-0.3-0 libumfpack5.7.1 libcholmod3.0.6 liblapack3 ...
Akshay Girhepuje's user avatar
0 votes
2 answers
129 views

How can I roll back Firefox back to previous version?

After doing a dist-upgrade Firefox got updated to the latest version, how can I go back to the previous version?
Lewis12's user avatar
0 votes
3 answers
5k views

How to install gdebi?

I have a freshly installed system, and i've not been able install any third party software or packages via the terminal or software center. Please help me out
Hansatanu Roy's user avatar
0 votes
1 answer
120 views

How to migrate all packages to elementary OS

I wish to switch to elementary OS from Ubuntu. Thing is, I've installed lots of software on Ubuntu. And I'm not patient enough to install all of them again once I install elementary OS. Is there any ...
Saurabh Lambe's user avatar
0 votes
2 answers
209 views

(apt-get) Pipe error

The last thing I have installed was lazarus and now when I try to install anything with apt I get a error. Lazarus compiles just fine without any errors. Example. $ sudo apt-get install ffmpeg [sudo] ...
Newb101's user avatar
  • 11
0 votes
1 answer
561 views

How to install GPaste?

GPaste is quite a sexy pasteboard manager: What's the preferred way to install this on Elementary? I've seen some old Ubuntu ppa's for it, but nothing up-to-date. Any solutions that have worked for ...
ylluminate's user avatar
2 votes
1 answer
359 views

Haskell Platform last version

I have installed the latest available version of the Haskell platform on Elementary with apt-get But the actual version is pretty old: > sudo apt-get install haskell-platform Reading package lists....
Marco Turchetto's user avatar
1 vote
0 answers
69 views

Log jam with AppCenter

I have installed Loki 0.4 (64bit) and am running it successfully. However I am now experiencing problems downloading apps from the AppCenter. I successfully downloaded several apps, but now it seems ...
Denny in Ohio's user avatar
3 votes
1 answer
6k views

packagekitd takes a lot of CPU when starting Loki [closed]

I have a loud fan and don't like when CPU goes hot for no reason. When I start Loki 25% of CPU is taken by packagekitd which is enough to make the fan too loud. Anyway, I expect that to check for ...
user avatar
2 votes
2 answers
588 views

Cannot boot after updating newest hardware-enablement stack

0.3.2 Freya on a i7-3537U CPU 2.00GHz, NVIDIA GK107M [GeForce GT 740M] After getting the dialog box this user got, I searched for a solution and eventually used this one: Kernel version is still 3....
hainish's user avatar
  • 65
0 votes
1 answer
109 views

I think I just broke elementary and have no idea what to do, can someone help?

I've made two stupid mistakes today: I mistakenly uninstalled a lot of programs through the terminal & I tried receiving help on the ubuntu stack exchange instead of here (which I didn't know ...
Aric's user avatar
  • 1
0 votes
1 answer
137 views

Is it safe to remove all these packages?

The following packages were automatically installed and are no longer required: fonts-horai-umefont git git-man glib-networking:i386 gnome-exe-thumbnailer gnome-session-canberra i965-va-driver:...
user avatar
0 votes
2 answers
4k views

Problems with broken packages

I'm trying to install musescore but this error comes ahead: I tried sudo apt-get install -f but nothing happens. Any ideas?
jacosro's user avatar
  • 800
1 vote
1 answer
165 views

Packaging system broken: Error with libqtcore4 package when installing krita (Freya)

I tried to install Krita via terminal sudo apt-get install krita and got an error message. Many packages depend on libqtcore4 (>= 4:4.8.0) which is not going to be installed. I am using ...
jmjr's user avatar
  • 133
5 votes
1 answer
181 views

How to show the support status of packages in freya?

I've recently read this article (http://www.heise.de/open/meldung/Ubuntu-LTS-Lauter-Sicherheitsluecken-trotz-Langzeitpflege-3181830.html - sorry, it's in German) about Canonical's LTS policies and how ...
deesnook's user avatar
  • 944
1 vote
1 answer
83 views

Bleeding Edge Non-elementary OS Packages

I want to install the latest Konsole on elementary OS. I'm considering adding debian sid to the sources, but I'm not exactly sure how I should go through with this.
Myrl Hex's user avatar
1 vote
1 answer
1k views

How to run Package Manager

I got an error message that said please run Package Manager from right-click menu or apt-get in a terminal to see what is wrong. I don't know what right-click menu this refers to. When I run apt-get ...
rebster's user avatar
  • 11
-1 votes
2 answers
339 views

There's any plans on switching to a new package manager (like dnf or pacman)?

I was a very devoted Elementary OS user (I used Elementary 0.2 for more than a year and a half) but in the last year I've moved to Fedora 20 for stability reasons. Elementary OS is an awesome OS, but ...
Fernando Paladini's user avatar
2 votes
1 answer
564 views

Problems with broken packages and apt-related issues

At the moment I'm unable to update my system or install/uninstall any package. The source of the problem seems to be a broken package (tv-maxe installed from ppa:venerix/pkg) with unmet dependencies ...
Giulio Sant's user avatar
  • 1,423
1 vote
1 answer
684 views

How to install current packages for elementary OS development/build support?

In general my problem is that I am using elementary OS Freya and need newer versions of packages to build projects from sources. In particular, I tried to fix a bug in Gala. But since there was a ...
skorz's user avatar
  • 13
2 votes
3 answers
5k views

How can I remove elementary-tweaks?

I installed Tweaks from here, by method described in the README.md. curl -sL http://i-hate-farms.github.io/spores/install | sudo bash - sudo apt-get install elementary-tweaks Now I want to delete ...
png2378's user avatar
  • 4,575
1 vote
0 answers
37 views

GRUB packages removed during installation?

I'm not sure exactly why these packages were removed, unless for an upgrade. But this current installation of elementary OS that I'm running was finally installed after 2 failed attempts where grub ...
Jackson Goode's user avatar
2 votes
1 answer
763 views

How to add a package to the live CD (iso)?

I'm having trouble installing on my Surface Pro (see this question) and I suspect that it is related to this recent bug fix on LaunchPad. The Surface is a UEFI based system, which might explain why ...
sonelliot's user avatar
  • 181
3 votes
1 answer
150 views

How can I install indicator-session without pulling in extra packages?

I removed indicator-session by accident. Now, when I try to install it again through apt-get I get this. The following NEW packages will be installed: indicator-session libaccount-plugin-1.0-0 ...
Harshit Jain's user avatar
18 votes
2 answers
23k views

How do I remove a PPA?

I've added multiple third party PPAs and there are bunch of PPAs which I don't need any more. Is there simple way to remove a PPA?
Snykri's user avatar
  • 1,903
5 votes
2 answers
2k views

Cannot install wine and playonlinux

sudo apt-get install wine Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you ...
user avatar
7 votes
1 answer
331 views

Does elementary OS feature outdated packages?

A few days back I was reading a post regarding elementary OS and in the comment section there was a few people mentioning that there are a lot of outdated packages and that if anyone wanted to use the ...
Adam's user avatar
  • 215
11 votes
1 answer
2k views

Can I use aptitude instead of apt-get without problems?

I would like to use aptitude since its parameters are more consistent. You can install it with: sudo apt-get install aptitude Are there any reasons not to use it with elementary OS?
davidak's user avatar
  • 786