Hot answers tagged

12

I don't have dual graphics, but I do have a Haswell based machine with a GTX 960. I installed the release version of Loki and had slow, stuttering Nouveau graphics even though I had selected to install proprietary drivers during installation. This is what I did to fix it, afterwards I had fully accelerated binary drivers from Nvidia and a smooth, fast ...


10

Thanks to @cl-netbox for instructions/assistance. You did not provide any details about the hardware (desktop PC or notebook), especially about the GPU. But you mentioned in your comment below xserver-xorg-video-nouveau, so I assume you have a NVIDIA GPU. I will give you a comprehensive answer which should address nearly every possibility to solve your ...


4

I don't recommend you to add any PPA to install your graphics driver. If you want a stable system, stick to the official repos. You could use bumblebee to switch between graphics card for some apps, but it's harder to configure than nvidia-prime so I don't recommend bumblebee unless you want a fully open source installation (both the nvidia driver and ...


3

First we should probably blacklist anything that could conflict. You don't have to do this, but a bad update later might do some damage otherwise. sudo nano /etc/modprobe.d/blacklist.conf At the end of the file add the following lines: blacklist nouveau blacklist nvidiafb blacklist rivafb blacklist rivatv blacklist vga16fb Then simply run the following ...


3

You need to install the nvidia-352 package and you need to disable nouveau (open source driver for Nvidia graphics) in GRUB. Press CTRL + Alt + F1 and log in by entering a username and password. CAUTION: this will deactivate elementary OS's graphical interface, leaving you with a command line, so read this entire set of instructions first. Execute following ...


3

You can remove them by using: sudo apt-get autoremove nvidia* It will remove everything related to nvidia, so make sure to double check before continuing. You can also try this: sudo apt-get purge nvidia* sudo apt-get autoremove I'm not sure if removing nvidia drivers will stop your nvidia GPU. It will probably still work and use Nouveau drivers, but ...


3

I had the same problems and after either an eOS update or drivers update (from 3.6. to 3.7.) I managed to fix it. Try to go back to 3.75 and see if the issue persists. Would have left the comment instead of an answer, but my reputation is 29 :( Edit : Danke for the upvotes, now I can comment :D


2

In my experience bumblebee is a fine balance between performance and battery life. It has been reported, however, that installing nvidia-prime will cause better performance on gaming, for example. Nvidia-prime cannot be activated in a per-app basis, so if that is what you need from it you should go with bemblebee. You can arguably install the latest ...


2

After several attempts of completely wiping the suite of pre-installed Nvidia drivers and attempting to install new ones off the website I cut my losses and reinstalled. After I reinstalled I did not attempt to update to any Nvidia drivers this install. I'm just using the default nouveau drivers and haven't had any graphical issues.


2

I was running into the exact same issue recently. I found this bug report which mentions installing nvidia-370 from ppa:graphics-drivers/ppa. After doing that I'm able to lock and unlock my desktop without screwing up the background - hopefully that helps in your case too!


2

I've had this problem for the past few days. The problem seems to be with the nvidia-smi tool that ships with NVIDIA drivers. I tried multiple driver versions, but the same problem arises. I did a little reading and it seems that nvidia-smi is not compatible with a lot of lower spec'd GeForce graphics cards anyway, so you can disable it and the problem goes ...


2

What always works is disabling your NVIDIA card, see Bo rislav's answer. If you need to use your NVIDIA graphics card and this happens, I would recommend executing gala -r from the Applications menu as a temporary workaround: I'm pretty sure this is a NVIDIA driver issue, but there is an existing Gala issue: https://github.com/elementary/gala/issues/21


2

First, check what drivers are avaliable for your system: sudo ubuntu-drivers devices | grep -o nvidia-[[:digit:]]* Then install the one you want (replace XXX with the correct number): sudo apt install nvidia-XXX In case you have Optimus Technology you would also want to install this: sudo apt install nvidia-prime In case you want to fine tune your ...


2

Try this: $ sudo add-apt-repository ppa:graphics-drivers/ppa $ sudo apt update $ sudo apt install nvidia-367 nvidia-settings For GTX860M you can also try: sudo apt install nvidia-375 nvidia-settings


2

No, you don't need to and, in fact, you can't have multiple versions of a driver installed. You have an option to install other versions because the newest drivers do not always work best. If you run into any problems with nvidia drivers you can install older versions and see how they work. A currently installed version will be replaced automatically.


2

I have Nvidia GTX 765m, had screen tearing fixed. 2 things to do: 1) In Firefox open new tab, go to about:config and set gfx.xrender.enabled to true 2) Create a new folder /etc/X11/xorg.conf.d and inside there create a file 20-intel.conf which contents are: Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "...


2

Same problem with me, Nvidia GeForce GTX 1050, using the latest 384.98 Nvidia Driver. The problem disappears if I switch the driver to use the "Power Saving Mode" which disables the Nvidia GPU and uses the Intel one instead - the return from suspend is much faster and there are no visual defects like the ones on the picture above. It looks like a problem ...


2

Assuming that you're using prime profiles and not bumblebee, you're wanting primesync described here: https://devtalk.nvidia.com/default/topic/957814/prime-and-prime-synchronization/ To easily enable this in Loki, make sure that you have the latest OS updates and proprietary Nvidia drivers enabled. Do the following steps from the terminal: 1.) sudo nano /...


2

There's workaround on this link: https://github.com/elementary/greeter/issues/166#issuecomment-437144185


2

I got it fixed! Special thanks to fosslinux.com for his article here: https://www.fosslinux.com/1462/how-to-install-nvidia-gpu-drivers-in-elementary-os.htm He wrote it for Loki but it worked great for me with Juno! This is foslinux.com's instructions: STEP 1: Starting from Loki, elementary OS doesn’t support PPA. So let’s first enable it. Launch ‘...


1

It may be due to kernel issues. Try to boot with an older kernel from grub menu as below. Select Advanced options for elementary os Select the kernel which u think is suitable If that works, you can remove the new kernel while retaining the older one. But be sure to check which kernel u currently using by uname -r and try not mess with it. To remove ...


1

The rule #1 for installing Nvidia Drivers is to disable the xorg-nouveau graphics driver package. Because it makes your computer into a black screen. See this post for installing apropiately the nvidia driver.


1

I uninstalled all of the Nvidia Drivers through the terminal in recovery mode. Then I installed nvidia-331 (a more stable version), with sudo apt-get install nvidia-331 and then rebooted into the UI. Currently the brightness doesn't work and the scaling is off, but it's a start.


1

That has nothing to do with your graphics card. Are you sure the file you are trying to play has subtitles? Or are you trying to open a subtitle file? Also, if you have your graphics drivers correctly installed you should have a NVIDIA X Server Settings icon in your Applications menu. The correct console command is nvidia-settings.


1

I had this desktop artifacting with nvidia-367 but it went away when I updated to nvidia-370. The drivers are still a mess and I still get the artifacting briefly after resuming (with Windows assets, like you mentioned), but the desktop artifacting appears to be over. That's a driver bug, if you find the open ticket (Google is littered with mentions of ...


1

If the graphics issues are only happening in your desktop background, I had the same issue and resolved it by upgrading to nvidia-370. The directions to do that are covered in another question.


1

Firs ensure you have turned off secure-boot from bios setup. You can try the bumblebee method. It's cleaner and easier to switch, no need to logout. To try it out, first uninstall any driver installed, or start fresh. However elementary doesn't ship with the ppa tools by default, to install them run: sudo apt install software-properties-common You'll ...


1

I had the same issue. This is what I am doing as a workaround: sudo apt install xbacklight Once installed go to System Settings>Keyboard>Shortcuts>Custom> and bind the follow commands to keys of your choice To Decrease: xbacklight -dec 10 To Increase: xbacklight -inc 10


1

I make my own brightness hotkeys using xbacklight. sudo apt-get install xbacklight After xbacklight is installed: Go into System Settings Keyboard Custom There is a little plus sign on the bottom right that says "add" when you hover over it. Make two custom commands xbacklight -inc 8 xbakclight -dec 8 Set the keys for these to (ctrl + (brightness up ...


1

Seems to me that your xrandr --newmode syntax is incomplete (without the enclosing quotes). Also, you should check this answer to make sure you're following the steps correctly, and you're giving xrandr the parameters it needs. Finally, remember that in order to make xrandr modes permanent, you should create a script to add them at boot time.


Only top voted, non community-wiki answers of a minimum length are eligible