10

There isn't a setting for it in the freya gala notification plugin. You can report it as a feature request. How can I report an issue with elementary OS to the developers?


9

What worked for me: Switch to next desktop (windows key + right arrow) Now you can click the "X" to dismiss the notification Return to your daily business


9

At the moment there is not. However, it is a feature that is currently being worked on for the next release of elementary OS :)


7

To the first question, you can open a terminal and type: killall appcenter Now the reminder dessapears from Planck. To the second question, you can try to show all the hidden startup applications. Open a terminal and type: sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop Then launch the Gnome session properties from terminal:...


5

The list of apps and their notification settings is held in gsettings at org.pantheon.desktop.gala.notifications apps. You can edit this either directly with the gsettings command in Terminal or by installing dconf Editor. There is currently some work being done to handle this automatically in the future. You can track the issue here: https://bugs.launchpad....


4

This is how I fixed it: In Terminal, run sudo nano /usr/share/themes/elementary/gtk-3.0/apps.css This brings up an editor. Under the Gala section, add: .gala-notification GtkLabel { color: #fff; } Save, log out and back in. More info in Switchboard Desktop Plug bug #1459530.


4

elementary relies on applications notifying the OS that they want to use notifications by setting a property in their .desktop file. Applications not built/controlled by elementary are not guaranteed to do this You can add the following line to the bottom of the .desktop file for the application in question and it should show up in the notifications ...


4

The AppCenter periodically shows updates because it runs in the background on startup. To disable its notifications, set it to not run on startup: mkdir ~/.config/autostart/ cp /etc/xdg/autostart/io.elementary.appcenter-daemon.desktop ~/.config/autostart/ This copies the AppCenter startup directions from the general autostart folder to your personal folder....


3

I found an answer that works for me. I can use the command notify-send More info at: https://wiki.archlinux.org/index.php/Desktop_notifications


3

Yes, you can. Disturb mode can be set via the dconf boolean value org.pantheon.desktop.gala.notifications.do-not-disturb. You can toggle it with a script like this (saved as ~/bin/toggle_do-not-disturb) #!/bin/sh KEY='/org/pantheon/desktop/gala/notifications/do-not-disturb' dconf write $KEY $(if [ $(dconf read $KEY) = 'true' ]; then echo false; else echo ...


3

You can disable notifications for your printer under: System Settings -> Notifications For me there are two entries Printer and System Config Printer Notification. Maybe just toggle them off/on helps to dismiss the notification.


3

Enable notifications for VLC: Open menu Tools > Preferences. Now, under Show settings, select the All radio button. Then, from the left sidebar, choose Control interfaces. There, check the LibNotify Notification Plugin checkbox, then click the Save button. By default the notification appears for 4000 ms, i.e. 4 seconds. You can change this duration in the ...


3

I wrote a bunch of bash scripts a while ago, and struggled with this issue as well. This is what I have going now, and it works: This icon is located in ~/.local/share/icons. In this case it's a .svg file, but it will also work with other types: This is a python example: And these are the results: The general idea is to put the icon file in the icons ...


2

Instead of trying to figure out, which CSS value is messed up, you could easily reinstall the elementary theme: sudo apt-get install --reinstall elementary-theme Don't forget to restart/relogin afterwards.


2

This is my first time answering something on stack exchange. I found your post while trying to figure out the same problem. Finally found the answer on this site http://www.devdungeon.com/content/desktop-notifications-python-libnotify I realize you are using subprocess but i also tried it and had the same problem. The code below may need some tweaking for ...


2

I looked around in the Elementary Keyboard Shortcuts and didn't find anything. Fortunately, this is still possible. The command line to run to show notifications is this: wingpanel -o messages If you open up a terminal and run that, it should work. With that in mind, you can go into System Settings -> Keyboard -> Shortcuts. From there, select Custom and ...


1

Option 1 Speaker icon in panel > Sound settings > Sound effects > Mute button Option 2 Navigate to folder: /usr/share/sounds/freedesktop/stereo and change bell.oga (requires sudo) to another stereo ogg sound effect Option 3 Download the freedesktop theme to your home folder http://people.ubuntu.com/~dylanmccall/soundgallery/ and save it in ~/.local/...


1

Spotify doesn't register its notifications with the system properly and since its development future appears spotty, my solution for now is to turn off sounds in the "Other" notifications option. This deactivates sounds for all unregistered applications, but such is the way of things.


1

This issue is now resolved. All I did was update Loki. (Unfortunately I do not have anything more specific than this)


1

Just as the post you linked says you can open the file by entering sudo scratch-text-editor /usr/share/themes/elementary/gtk-3.0/apps.css in the terminal. Once it's open look for the section that starts with this /******* * Gala * *******/ The default CSS code looks like this: .gala-notification { border: none; border-radius: 4px; ...


1

Slack notifications can be enabled in the app.


1

In System Settings>Notifications you can set if notifications play sound. :)


1

You could install a file manager that offers this feature, such as Nautilus. There is a bug report for adding this feature to Pantheon-Files. See also: Will the developers add the option to automount external media & devices?


1

There are not any settings to increase the length that notifications stay on the screen. If you miss a notification, you can always review it in the notification indicator


1

There's no easy way to do that. The ordering of the indicators is hard-coded, as you can see here.


1

Try this quick workaround sudo touch /usr/lib/libunity-electron_notification_fix Then restart session.


1

You can have a look at Nylas N1: https://www.nylas.com/n1. Its free and is open source.


1

I was able to remove it by using dconf sudo apt-get install dconf-editor #to install dconf-editor Open dconf-editor --> org --> pantheon --> gala --> notifications. Here you will see: apps the corresponding value should have entries like: 'appname:show,on'. But you will see an entry without appname like just ':show,on'. (The actual syntax is :['{APP-NAME}...


Only top voted, non community-wiki answers of a minimum length are eligible