5

As an interim solution you can install dconf-editor and change the key org/gnome/system/location to enabled. After that, the Night light settings will work as expected. You can also change the setting in the terminal without installing anything by executing gsettings set org.gnome.system.location enabled true Please execute sudo apt-get install dconf-...


5

You might want to look at the package redshift (universe packages) or fluxgui (in the PPA: https://launchpad.net/~nathan-renniewaldock/+archive/ubuntu/flux)


3

f.lux is more reliable than Redshift and has a wing panel icon to easily adjust the color and pause it. sudo add-apt-repository ppa:nathan-renniewaldock/flux sudo apt update sudo apt install fluxgui


2

This will be in elementary OS Juno 5.0 without the need for any thirdparty software. See https://medium.com/elementaryos/juno-progress-for-january-february-9b276042716e#770b and https://github.com/elementary/wingpanel-indicator-nightlight


1

You can do this easily with gsettings. The key you are looking for is night-light-enabled which is in the org.gnome.settings-daemon.plugins.color schema. The value can be either true or false. To disable Night Light, set the value to false with the set sub-command as in the following. $ gsettings set org.gnome.settings-daemon.plugins.color night-light-...


1

Is is also necessary to change a line in /etc/geoclue/geoclue.conf change this line: url=https://location.services.mozilla.com/v1/geolocate?key=99054b086f8a4b9fa033e4a75801ab52 to this: url=https://location.services.mozilla.com/v1/geolocate?key=geoclue


1

Try this: Wingpanel Nightlight Indicator https://github.com/elementary/wingpanel-indicator-nightlight


1

I see what you're talking about. It seems like it's resetting back to 11:00 PM, but once you click off the time setting, it should be set to 11:59 PM. UPDATE: After clarifying things with Rajiv, this does appear to be a bug. After setting to 11:59 PM, closing the Settings window and re-opening, the time reverts to 11:00 PM. I checked the elementary OS ...


1

I installed Juno yesterday, and night light was working during installation from an USB, but later it did not show up, and I experienced the same behavior. And it's weird, but just setting the schedule to manual and changing the time made it show up and work perfectly. Hope it helps


1

f.lux apparently currently does not support monitors with high colour depth. Redshift does. Redshift also seems more happy with dealing with multiple different multiple monitor set ups. As a result I have had to move from f.lux to Redshift after quite a few years happy usage for I hope they continue to develop it.


Only top voted, non community-wiki answers of a minimum length are eligible