Hot answers tagged

6

What version of elementary OS you are using? Please try selecting your Language to French(Canada) and then select layout English(Canada) from Layout setting under Keyboard.


5

I use this script now https://github.com/yamnikov-oleg/switch-layout Works fine!


5

Go to System Settings -> Keyboard $ io.elementary.switchboard keyboard Press the + (plus) button to add a new one Select French (Canada) Select English (Canada) variant Github I wrote a report on this, it needs a redesign https://github.com/elementary/switchboard-plug-keyboard/issues/201


1

I found the solution (I did the wrong combination before): sudo dpkg-reconfigure keyboard-configuration Choose Generic 105-key PC (intl.) Choose English (US) Choose English (US) - English (intl., with AltGr dead keys) Choose Right Alt (AltGr) Choose No compose key And that's it :)


1

You can try the following: Open im-config through terminal sudo im-config click OK button to go next Click Yes to update system config. Select Ibus as input method for the system Click Ok and Ok for the next windows. Then restart your computer. The sudo at step 1 is crucial. Without sudo the system just uses the default setting regardless of what you ...


1

Open Slingshot and search for "Keyboard", click on the highlighted result: Search for Portuguese (Brazil) and add it as a Layout. Now you can add accents!


1

After changing your keyboard settings, do in terminal: setxkbmap -query You should see the options you have chosen,e.g: setxkbmap -query rules: evdev model: pc105 layout: de variant: mac options: terminate:ctrl_alt_bksp You can try setting this command: setxkbmap -model pc105 -layout pl -option 'lv3:lwin_switch' with your ...


1

After many researches I found what was happening. The settings (from thinkpad + br) was being interfered by an additional options added by another model (korean). How I solved: First, checking the layout info with: # setxkbmap -query rules: evdev model: thinkpad60 layout: br options: korean:ralt_rctrl,grp:shifts_toggle Second, setting ...


1

You can remove the keyboard indicator via the command line sudo apt remove --purge wingpanel-indicator-keyboard Or via any package manager remove the wingpanel-indicator-keyboard package.


1

Unfortunately, this option doesn't work on Freya & Loki now. Follow the progress of fixes you can here, also you can post bounty for this bug.


1

It seems that the correct scheme where to find the switch-input key is: org.gnome.desktop.wm.keybindings I successfully changed the keyboard input keybinding with the following command: gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Super>f']" Now, if I press Super+F it changes my keyboard layout.


1

this solution here worked very well for me on first try: http://mylinuxideas.blogspot.de/2015/04/enable-desktop-icons-and-right-click-on.html (I was setting up a skylake intel NUC i3 with elementary and OSX Yosemite theme for my wife to make the transition from a mac as easy as possible for her. BTW: I LOVE this little setup with elementary! Works like a ...


1

I was just looking at another answer (https://elementaryos.stackexchange.com/a/9277/7446 ) to a related question (about why shift-alt-tab behaviour was strange), and I think it might explain your problem too. In Elementary, go to settings -> keyboard -> layout, and you might find that shift-alt-tab is mapped to switch keyboard layouts. I disabled that ...


1

Keyboard indicator appears after add two or more layouts in keyboard settings.


Only top voted, non community-wiki answers of a minimum length are eligible