Hot answers tagged

7

I found that ibus did not work with Freya. Instead I used fcitx with mozc for Japanese Input, using the instructions from the elementary os subreddit. NOTE: Make sure you remove the ibus package before you go through the folliwng steps, else the input-switcher will not work. Add the Fcitx repository: sudo add-apt-repository ppa:fcitx-team/nightly Update ...


4

You can change the keyboard layout in System Settings > Keyboard > Layout and add a new layout there with the plus button in the bottom left. I have no knowledge of Japanese signs, but enabling a Japanese (Kana) seemed to work for me. The default shortcut to cycle through different keyboard layouts in Freya is AltSpace. You can change this in System ...


3

Support for ibus on elementary is not yet complete, but you can still use it with some inconsistencies I just tested it and the only problem was the indicator on wingpanel that didn't update accordingly when switching between different input methods (not a problem if you are only going to use the Vietnamese layout). You should have ibus-unikey installed, if ...


3

Yes you can. First you setup your ibus by command ibus-setup Chose the Input Method tab. --> Select an input method --> Add language what do you want. My example is Vietnamese - Unikey as you see in the picutre. Vietnamese is language Unikey is type of input After Add language you will go to Application --> System Settings --> Keyboard --> Universal ...


2

Open terminal and type $ sudo apt install ibus-avro Type in terminal sudo im-config and select OK then Yes Select Ibus as input method for the system Click Ok and Ok for the next windows. Then restart your computer. Type in terminal ibus-setup and remember your keyboard shortcut to switch layout, in our case it's Ctrl + Space Choose Input Method tab and ...


1

You can do the following to solve the problem- Install your desired input method for IBus. Run ibus-setup command from terminal. Select 'Input method' tab and Add your desired input method. Close 'IBus Setup' and run ibus-daemon -drx in terminal. It starts IBus daemon but It doesn't show IBus on the panel, it brings up the input method popup and let us ...


1

If you wish to use Japanese input follow the elementary subreddit here but with step (3) replaced with either sudo apt-get install fcitx fcitx-anthy im-config sudo apt-get install fcitx fcitx-mozc im-config Depending on whether you wish to use (discontinued but widely used) anthy or (maintained by Google) mozc input.


1

Knumber10 From your screenshot it would appear that you have a few extra icons in your wingpanel so this solution may be redundant. However, let's give it a shot! There is a site maintained by mdh34 that is the unofficial guide to restore indicator functionality on Elementary OS. The TLDR boils down to this, if you want to install the prepackaged .deb ...


1

You can try the following: Open im-config through terminal sudo im-config click OK button to go next Click Yes to update system config. Select Ibus as input method for the system Click Ok and Ok for the next windows. Then restart your computer. The sudo at step 1 is crucial. Without sudo the system just uses the default setting regardless of what you ...


1

As I can see you already installed iBus Avro now you need to change Input Method Configuration only. Open Terminal and type sudo im-config Select Ok then Yes Select Ibus as input method for the system Click Ok and Ok for the next windows. Then restart your computer.


1

Try running im-config in a terminal, then continue until you can select the ibus option. (this will allow to use ibus as imput method). when finished, add ibus-daemon -drx to startup applications then restart your session and you should be able to use all the configuration you have made about ibus. i recomend you to disable the app-laucher shortcut in order ...


1

I just installed nimf for Korean input and it works like a charm. I don't use Japanese but nimf does support Japanese with anthy so give it a try! First install nimf with sudo apt-get install nimf , then run im-config -n nimf , then reboot. Next, run nimf-settings and set up your hotkey to switch input methods. Reboot again and it should work! Just remember ...


1

Don't forget to restart ibus by command: ibus restart Find and add Vietnamese layout into ibus: ibus-setup Final step - add ibus into the system tray: Run this command in your terminal: gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'us'), ('ibus', 'Unikey')]"​ OR install dconf-editor then config it like picture: Enjoy it!


1

You can do the following to solve the problem- Install your desired input method for IBus. Run ibus-setup command from terminal. Select 'Input method' tab and Add your desired input method. Close 'IBus Setup' and run ibus-daemon -drx in terminal. It starts IBus daemon but It doesn't show IBus on the panel, but it brings up the input method popup and let us ...


Only top voted, non community-wiki answers of a minimum length are eligible