Hot answers tagged

5

I just recreated the problem and was able to fix it by deleting the ~/.config/monitors.xml file. Note that by deleting this file all settings for displays will be lost. The file is in a hidden folder, so to be able to find it you need to make hidden folders visible in the file browser. To do this press ctrl+h.


3

Press CTRL+ALT+F1 to open a TTY virtual terminal.Then type your username and password and once you have logged in type rm ~/.config/monitors.xml and press ENTER to delete the file @joost said about. Thanks to @joost for telling the file


2

I finally managed to fix this issue following steps given here Install Nvidia driver instead nouveau. The issue was that, although the nvidia drivers were correctly installed, the nouveau drivers were still being used, even if the nvidia drivers were selected in 'Software & Updates'/Additional drivers. Steps I followed: Blacklist the modules. Open the ...


1

I see you are using the Intel Corporations display driver. Do you have a built in graphics chip from either Nvidia or Amd cause if you do you might want to install the latest drivers for ubuntu from either of them to make it work properly. I am not sure about AMD but to install nvidia drivers here is what you do sudo add-apt-repository ppa:graphics-drivers ...


1

Seems to me that your xrandr --newmode syntax is incomplete (without the enclosing quotes). Also, you should check this answer to make sure you're following the steps correctly, and you're giving xrandr the parameters it needs. Finally, remember that in order to make xrandr modes permanent, you should create a script to add them at boot time.


1

We can use command pactl pactl - Control a running PulseAudio sound server on terminal first, list our available properties in our machine using this command: pactl list cards based on my hardware above, i set output:hdmi-stereo as my default profile using this command: pactl set-card-profile 0 output:hdmi-stereo if we want to set to internal ...


1

This seems to be a limitation (bug?) of the current sound setting app. The current workaround is to install PulseAudio Volume Control from the AppCentre, and to select a HDMI configuration profile. References: Related Stackexchange Issue Related Github Issue


1

I'm facting similar issues on HP Spectre x360. Loki worked great, but Juno is terrible. In response to Unable to disable built-in monitor, I have found a way to turn it off: Find out the display names: xrandr | grep conn | grep -v dis Disable the desired display: xrandr --output <display> --off On my machine, first command returned: eDP-1 ...


1

I don't know If you are still around. I never done this but I just gathered info I believe might help you First You need to install Nvidia drivers Install: $ sudo apt install software-properties-gtk software-properties-common Then use the command: $ sudo ubuntu-drivers list You should get something like this (probably different version numbers): ...


1

An eOS system update was just pushed and seems to have solved this issue. The monitor now displays with the proper resolution. Setting monitor positions and primary/secondary settings is still really jank but it is possible to work with it until everything is right.


1

One more power cycle (full power off and power on) did it (kept HDMI cable plugged in throughout). It would be nice, however, to have a method that didn't rely on pure luck, as I power cycled several times previously with no effect. Perhaps xrandr can manually force a state change?


1

I don't know why or when, but it sorted itself - probably one of the daily patches. Thanks, eOS team!


1

I don't think this particular issue is hardware specific; I'd file an issue at github.com/elementary/pantheon-greeter.


1

So for anyone else who may be experiencing this issue: The lack of HDMI audio is documented on Ubuntu's AMDGPU and AMDGPU-Pro wiki pages. As of Ubuntu 16.04, only the open source AMDGPU/amdgpu-Pro official open-source Radeon drivers can be used on newer model GPU's and APU's(like mine), it specifically notes: "The open source AMDGPU driver does not ...


1

It seems this is a problem introduced by Pulseaudio 8. Pulseaudio 9 claims to fix the problem (See "Automatic routing improvements", Pulseaudio 9 Release notes). Upgrading to Pulseaudio 9 doesn't seem possible in Loki or is beyond my techincal level. (EDIT: here is someone trying it in Ubuntu 16.04 and running into unmet dependencies, as I did...). I even ...


1

So the thing that worked was simply unplugging the HDMI cable and plugging it back in, I have to do this after every reboot, it's a bit annoying but manageable.


1

Check if this helps you. I know it's another distro, but their documentarion is awesome and can help you in many other situations. https://wiki.archlinux.org/index.php/intel_graphics#SNA_issues


Only top voted, non community-wiki answers of a minimum length are eligible