Hot answers tagged

34

To change font in the Terminal you need dconf-editor. Install it, if you haven't done so: sudo apt-get install dconf-tools Run it and go to path org > gnome > desktop > interface > monospace-font-name. Enter name of desired font and font size. For example Anonymous Pro 11. You can also use the command in Terminal instead of the dconf-editor.


31

To change the font of just the terminal (pantheon-terminal), you can use the dconf-editor (requires an install) or the gsettings command. Edit the font property in the org.pantheon.terminal.settings schema. For example: $ gsettings set org.pantheon.terminal.settings font 'FreeMono 10' You will have to close and reopen the terminal for the changes to take ...


23

Quick Fix - Text Scaling You can increase the text size of most interface elements by turning on 'Large Text' in the Universal Access settings. Applications Menu -> System Settings -> Universal Access -> Seeing -> Large Text The Large Text slider toggles the value of org.gnome.desktop.interface text-scaling-factor between 1.0 and 1.25. If you want a ...


16

Just try this on your terminal: sudo apt-get install ttf-mscorefonts-installer


13

They should be placed in the following folders For personal use TTF files in ~/.local/share/fonts/truetype (old way was ~/.fonts/truetype) OTF files in ~/.local/share/fonts/type1 (old way was ~/.fonts/type1) For system wide use TTF files in /usr/local/share/fonts/truetype OTF files in /usr/local/share/fonts/type1 Then sudo fc-cache and you should see ...


7

The good news is, you may find that many of the fonts used in elementary OS are already in Ubuntu! They are: Raleway (logotype font) Droid Sans (window titles) Open Sans (various) Alternative, you can install the elementary-fonts package from the elementary OS Stable PPA.


7

I think what you may be looking for can be done by using dconf-editor. If you do not have it installed, you can do so in Terminal with this: sudo apt install dconf-editor Once installed, open dconf-editor and in the left pane navigate to org> gnome> desktop> interface then look for 'text-scaling-factor' in the right pane. The default is, of course, set to ...


5

I solved it after googling a while; this applies to all gnome based enviroments (at least according to this) Just run the following lines on terminal, then reset the system normally. Done. gsettings reset org.gnome.desktop.interface font-name gsettings reset org.gnome.desktop.interface document-font-name gsettings reset org.gnome.desktop.interface ...


5

If you want to change the font color, you can use Configurator. Once you've installed the application, you go to org.pantheon.terminal.settings and change the value of foreground to any color you want. The default color in my system is #94a3a5 If you don't want to use Configurator(or dconf-editor) you an use terminal and paste this gsettings set org....


5

TrueType fonts can be installed from file manager - double click the .ttf file, font manager will open, click "install". To install multiple fonts system wide: ttf files: $ sudo cp ./yourpath/*.ttf /usr/share/fonts/truetype/ opentype: sudo cp ./yourpath/*.otf /usr/share/fonts/opentype/ And then: sudo fc-cache -fv


5

If you already havent, install elementary-tweaks (For elementary freya): sudo add-apt-repository ppa:mpstark/elementary-tweaks-daily sudo apt-get update sudo apt-get install elementary-tweaks Then go to System Settings > Tweaks > Fonts and select the Monospace Font you want as well as its size. You can customize many other things as well from here.


5

For versions 5.0 above: gsettings set io.elementary.terminal.settings font 'FiraCode 10'


4

Elementary OS System Fonts: Default Font: Droid Sans Regular Document Font: Open Sans Regular Monospace Font: Droid Sans Mono Regular Titlebar Font: Droid Sans Bold I recommend you to save all system fonts in a separate directory if something fails.


4

The default font for terminal is Roboto Mono 10. You can find all default variables at this repository on github.com : elementary/default-settings


3

Solution: It was neither Electron nor Elementary OS but the Nvidia driver. All I had to do was disable FXAA Antialiasing in the antialiasing settings. Now everything is sharp again: Atom, GitKraken and even Steam. So, if you come across blurry fonts, follow these steps: Open Nvidea X Server Settings Go to X Screen 0 -> Antialiasing Settings Remove the ...


3

Fonts can be downloaded and installed manually: Download fonts from the elementary/fonts repository at GitHub. Navigate into the folders of the desired fonts. Save the *.ttf files into ~/.fonts (you might have to make hidden files and directories visible using the shortcut Ctrl+h). Open terminal and type sudo fc-cache -f -v to rebuild font cache


2

I followed the instructions provided here. This is what I did to have it working. Created the FiraSans directory in /usr/share/fonts/truetype $ sudo mkdir -p /usr/share/fonts/truetype/FiraSans Moved the ttf font files to that directory and then updated the cache $ sudo fc-cache -f -v Initially, I did try with the OTF files and later moved to TTF files. ...


2

Create a .font folder in home if it doesn't exists and copy all your fonts on the .font folder.


2

You can do many customizations using elementary-tweaks switchboard plugin. But the older repository is not maintained by the original author anymore. Fortunately it's been forked by some other devs and the source is available in Github. Here is the project link https://github.com/elementary-tweaks/elementary-tweaks It also has a PPA. So, add the ppa and ...


2

The problem was that I was using googlefonts which I symlinked to my ~/.fonts directory. The link was broken when I was installing some stuff. After cloning the repo again and creating the directory directly within the ~/.fonts folder, everything went back to normal


2

You can install the application dconf-editor with your terminal and there you can change these setting. Type in your terminal... sudo apt install dconf-editor Then, after installation finished open dconf-editor and go to org > gnome > desktop > interface Now on the right side there is a point called 'font-name' and after that its defined with 'Open ...


2

You can try elementary tweaks for do that, you can install it with this common : sudo apt install software-properties-common sudo add-apt-repository ppa:philip.scott/elementary-tweaks sudo apt-get update sudo apt-get install elementary-tweaks Elementary Tweaks will show on system settings


2

sudo sed -i '/>Monaco/{N;N;N;s/>Cousine/>Monaco/}' /etc/fonts/conf.avail/31-croscore-elementary.conf


2

The thing that worked for me is Fonts looks weird at Loki (and just in my user session!). How do I fix it? But I got an error: GLib-GIO-Message: 21:06:40.395: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications. I solved it as described here https://blog.csdn.net/juwenkailaodi/article/details/86525841] ...


2

You have to install them. Check if Gnome Fonts are installed (normally is), then just click on font file and it will install.


2

There is a discussion on Reddit about that. It seems that on some displays the font looks ugly but apparently not on all displays and not all font types. I've noticed this problem immediately after installation, replacing Hera with Odin on the same computer, the font is just rendered badly. Cassidy mentioned that they are looking into this.


2

I had exactly same problem. It seems that replacing Inter font with Ubuntu Regular font make things a little better. Also today there is system update in AppCentre which maybe brings some improvements. Please check it out. I also tried to find beforementioned discussion on this topic at Reddit. This problem is described in rather long post reviewing cons of ...


1

edit /etc/lightdm/pantheon-greeter.conf for example, I'm using Roboto font for the login screen [greeter] #activate-numlock=true #default-wallpaper=/usr/share/backgrounds/elementaryos-default #high-contrast=false #onscreen-keyboard=false #screensaver-timeout=60 font-name=Roboto 11


1

I recommend Menulibre https://smdavis.us/projects/menulibre/ It's simple GUI to add applications to slingshot and/or change names, icons etc. However, if you want to keep simple. Make a .desktop entry in /usr/share/applications. https://wiki.archlinux.org/index.php/Desktop_entries


Only top voted, non community-wiki answers of a minimum length are eligible