10

There is currently a Bug that you can only add one calendar of your Google account. But you can add multiple Google Calendars to Maya via CalDAV. URL: https://apidata.googleusercontent.com/caldav/v2/calendarID/events User: is your email-address The calendarID is your email (for your main calendar). For other calendars you can find it in your Google ...


7

For Gmail: Go to Go to https://myaccount.google.com/security Click App passwords: Generate it and copy In calendar app enter google email and generated password.


6

To synchronize your account on Google Calendar, you must configure it to accept third party applications. You can find more information at Google Calendar Support


4

You can enable a option to show events in the date time indicator with the following command: gsettings set com.canonical.indicator.datetime show-events true Alternatively, you can enable using dconf-editor sudo apt-get install dconf-editor Now open dconf-editor --> com --> canonical --> indicator --> datetime --> show-events


4

There are some bugs for now, but I got it working with two-step authentication. I cannot setup Google Calendars without installing Evolution. After my calendars got setup in Evolution, they did become visible in Maya (native calendar app) as well. There is often an offset of one day for your daily appointements (https://bugs.launchpad.net/maya/+bug/1442188) ...


4

The answer (thanks to Giovanni Caligaris on google+) is to install gnome-calendar, gnome-online-accounts and then use the command XDG_CURRENT_DESKTOP=GNOME gnome-control-center To access the gnome settings and set your account there.


3

I use 2-Step Verification for all my Google stuff. The way I got around this was to set an App password for Calendar. The option is under 2-Step Verification on the https://myaccount.google.com/security page.


3

Exchange generally allows you to publish a calendar feed in .ics format. This will give Maya read-only access to your calendar. Here are instructions on publishing the feed in Outlook 2007. You can also publish the feed from the Outlook web app. Unfortunately, read/write Exchange support on Linux is limited. You might have better luck using the Outlook Web ...


3

I finally got it working after using the explicit calendar URL available under the 'other' clients setup option at https://fruux.com/sync/new/ Do not simply use 'https://dav.fruux.com/' as the calendar URL otherwise it will not work.


2

I can confirm, OwnClound via CalDAV, event in the right panel for today not shown, but if you select the next day, event from day before are there. There is a 1 day shift


2

You can do it by adding an app password that you are going to use in Calendar. https://security.google.com/settings/security/apppasswords


2

Open Calendar and click the "Create New Event" toolitem in the headerbar Under "Title", type in the name of your event. For example "Dancing at 7pm" Press Enter or click the arrow icon in the entry Calendar will do its best to parse the title and fill out other details for you :)


2

There is no such feuture for now but the issue has been drafted: https://blueprints.launchpad.net/maya/+spec/different-views (cf., https://bugs.launchpad.net/maya/+bug/1073336)


2

You may need to enable "less secure apps" in your Google settings. For more details, see this answer regarding a similar problem with Pantheon Mail. Maya and Geary do not support OAuth, which Google now requires by default. Hopefully, a future Pantheon Online Accounts release will add OAuth support. Until then, enabling "less secure apps" should do the ...


2

For Google you need to authorize "Less secure apps" here https://www.google.com/settings/security/lesssecureapps Once you turn that on you should be able to add your Google calendar.


2

Maya Calendar, also knows as Calendar, has a plugin named maya-calendar-plugin-google, installed by default. You can go to options and add multiples accounts. In order to add them, they must configured to thirdy party applications. Look at: Google Calendar Support


1

It is actually possible to ad iCloud calendars via CalDAV. I'm doing it. Your issue might be that you have two factor authentication enabled for your icloud account. If that is the case, you need to generate an application password, here: https://appleid.apple.com/account/manage Then, configuring maya is fairly straightforward: But not everything is ...


1

You can hover over the calendar name in the gear menu (top right) and a trash icon appears. However, there are two special system calendars (Birthdays&Anniversaries / Personal) that you cannot delete but hide.


1

This is a known bug, you can mark "it affects me as well" in the bug tracker: https://bugs.launchpad.net/maya/+bug/1355090


1

I have the same issue, been searching for a solution for a long time and haven't found any. It's silly, considering the fact that the only problem is Evolution server (which is used by Maya, just as Gnome-calendar and California) using wrong URL for Yahoo calendars. The correct URL is https://caldav.calendar.yahoo.com/dav/YOUR_USERNAME/Calendar/...


1

It looks like a known bug, reported 2015-02-10, but in undecided state. You can follow it at Maya at Launchpad There are some workaround solutions that you can try at: Maya bug no. 1388515 See comments #11 and #13. You can mark it as affect to you, in order to find a solution by Maya dev team.


1

You can use Davmail to access your Exchange account and transform the calendar access to CalDAV. First, install Davmail from http://davmail.sourceforge.net/ Configure it by pointing it to your Exchange OWA URL (you will have to do it the first time you run the application. If you want to change something later you will have to do it by modifying the ....


1

Maya is currently not designed to support this. According to elementary guidelines it also should not support this: they adhere the principle of apps doing one thing, and doing that in a great way. Calendars are not todo lists, so there are other apps better suited for this purpose. I.e. Go For It is a very nice app for this.


1

I was experiencing the same unresponsive behaviour yesterday after an update. I couldn't track it down to Maya, but basicly the whole system froze a few seconds after login. For me, the issue was resolved today by updating the system again: Go to console after the system has started up (ctrl+alt+F1 or just ctrl+F1) Run sudo apt-get update followed by sudo ...


1

Open terminal and run the following commands: To uninstall maya-calendar sudo apt-get remove maya-calendar To uninstall `maya-calender and dependencies: sudo apt-get remove --auto-remove maya-calendar Purge your config/data too: sudo apt-get purge --auto-remove maya-calendar Caution! Purged config/data can not be restored by reinstalling the package


1

sudo apt-get purge maya-calendar will remove the application, while sudo apt-get autoremove will remove the package's dependencies. As for the mail client, I don't really have any advice. I just use my browser.


1

I know it is an old thread but for someone who is looking for more answers as I did: I have self hosting Nextcloud instance on Apache using Raspberry Pi 3 and I have generated self-signed certificate for it. The eOS calendar refused to connect at all. I had to generate the certificate through Let’s Encrypt and now it’s working flawlessly.


1

You will be asked for password while connecting to the caldav, and you can store the passwd for later. Try to use username without "@mysite.com", it should work (it did for me). BR, m.


1

This feature is not available in Maya at the moment. As per your first attempt, you can only sync the application with your main calendar connected to your Google account. See this answer in Maya's launchpad page for confirmation. I also see a possible workaround there, but personally I haven't tested it.


Only top voted, non community-wiki answers of a minimum length are eligible