3

Autoremove removes packages installed automatically for dependencies. So, if you need to keep that package, it needs to be installed itself, not as a dependency. Simply remove the package and reinstall. It is not a bug, it's more like a design choice by the devs. Two tips: IMHO, using a wrapper to apt-get, like aptitude or synaptic, saves a lot of ...


1

I think I resolved this. Apparently the sources.list isn't the only place that contains repositories. I ended up opening the software center and went to edit >software sources. There was a repo for steam and tox. Once I removed those apt-get behaved normally. Sorry!


1

This can be resolved by installing aptitude with: sudo apt-get install aptitude Then running sudo aptitude install libssl-dev and selecting the options as follows.


1

I've got this problem before and, unfortunately, I couldn't solve it without adding a ppa. Please note that you have limited slots to ppas, so use it only when you really need it. If you can avoid it, please do so. Also, keep an updated backup of your system, because packages cannot be checked for security loopholes. I would also strongly advise you to ...


1

I start with def of autoremove from man apt-get autoremove is used to remove packages that were automatically installed to satisfy dependencies for other packages and are now no longer needed. It means the packages you have listed are dependencies and are installed to satisfy dependency of other package(s). The reason for ...


Only top voted, non community-wiki answers of a minimum length are eligible