Questions tagged [uefi]

Questions about the Unified Extensible Firmware Interface that finally replaced the BIOS on newer desktops and laptops with the release of Windows 8. UEFI is independent from CPU architectures and supports booting via UEFI with and without secure boot enabled as well as legacy booting via CSM.

Filter by
Sorted by
Tagged with
16 votes
1 answer
16k views

How can I fix a secure boot failing to grub when I installed 0.3.1?

Boot into the system in UEFI mode failed.. Why does 0.3 support UEFI but 0.3.1 doesn't? Bug Reports:0.3.1 UEFI / Secure Boot support incompatibleFreya UEFI install boots to grub prompt I can't boot ...
  • 783
8 votes
1 answer
5k views

Cannot boot Freya after installing alongside Windows on UEFI

I have installed elementary OS Freya on UEFI in the same way that I installed it on legacy mode. But I can't boot to Freya and there is no Grub on start-up. I also tried to create an entry for Grub (...
4 votes
4 answers
18k views

GRUB not showing after installing Elementary OS alongside Windows 10

I've tried to install elementary OS alongside Windows 10 in a UEFI machine. I first did it with Secure Boot enabled, using the "something more" option. I created the boot, root and swap partitions as ...
  • 497
3 votes
1 answer
624 views

Bootloader Issue with Freya [duplicate]

Update: I found a solution! I am having the same problem as this person, but the solution is not working for me. I am booted into a grub prompt with minimal bash editing. My partitions are: boot ...
  • 121
6 votes
5 answers
23k views

Installing in UEFI mode

I'm having difficulties installing elementary OS Freya in UEFI mode. My BIOS supports both legacy and UEFI. With other Ubuntu distros my boot menu gives me the option to boot the live CD or usb using ...
  • 61
5 votes
2 answers
3k views

UEFI and Legacy boot

I have a small USB drive that I use to run elementary OS. I want to use this in multiple PC's so it can't have any specific configuration. The issue is that I like to use it on my work PC as ...
4 votes
1 answer
2k views

Installing elementary OS alongside Windows 10

I recently tried to install elementary OS on my Asus laptop, where I previously installed Windows 10 (it came with no OS when I bought it). The installation is weird: when I proceed with the wizard, ...
  • 191
2 votes
1 answer
3k views

How to install elementary OS Freya using rEFInd

My computer currently has Windows 10 installed with secure boot ON and 100GB of unallocated space.The disk formatted as GPT and CSM off in firmware settings. Now I would like to install elementary OS ...
  • 2,733
2 votes
1 answer
3k views

Force UEFI installation?

I'm on a fresh install of Elementary OS Loki. Right after the install screen about installing third-party and background updates, I have this pop-up: Force UEFI installation? This machines's firmware ...
  • 4,244
1 vote
1 answer
1k views

Empty /boot/efi after fresh install of Juno

I did a fresh install of Juno on a laptop that I previously used with Loki. However after the installation finishes and the laptop reboots, I get just black screen with a message about missing boot ...
  • 683