Questions tagged [script]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
14 views

can't make "sleep" command to run in executable script.sh using "io.elementary.terminal" command

As mentioned in the title, can't make sleep command to work in an executable script.sh with an io.elementary.terminal command is there something i'm missing? #!/bin/sh io.elementary.terminal -n -e &...
zensir's user avatar
  • 23
1 vote
0 answers
188 views

How do I display an icon with `notify-send`?

If I run notify-send --icon=address-book-new "My notification" the notification that comes up has an "info" icon: And if I look at the notification in the notification popover, ...
Lukas's user avatar
  • 38
1 vote
1 answer
13 views

How to write an alias to accept variables

I want to set an alias so that I can swiftly log in to one of my workstations. For example, I must enter ssh [email protected] to log in to one of my machines. Sometimes, the hostname ...
Saurabh Lambe's user avatar
0 votes
1 answer
45 views

How to execute sudo commands after login?

I would like to execute a command which requires sudo privileges. Specifically, I want to set my CPU frequency to a performance governor using the following script. sudo cpufreq-set -g performance ...
Orlando Lewis's user avatar
0 votes
0 answers
313 views

How to run a bash script in terminal from the applications menu in elementary OS 5.1

I tried to add an application menu item to launch a simple bash script: #!/bin/bash GTK_CSD=0 grass74 on terminal to start an application, both with the AppEditor utility and manually by entering ...
Andrew-63's user avatar
  • 101
1 vote
1 answer
477 views

Undervolting XPS 13 9360

I have just installed eOS on my Dell xps 9360 and I'm hoping to get a bit more juice out of the aging battery. I see people on win10 undervolting the CPU/GPU to get more battery life and I bumped into ...
jmbmkn's user avatar
  • 13
2 votes
0 answers
50 views

Mute sound before / after suspeding

I find it annoying when I forget to stop videos before closing my laptop and then having sound played when opening it in public. I tried to add a script to /lib/systemd/system-sleep: #!/bin/bash ...
dfsg76's user avatar
  • 143
2 votes
1 answer
625 views

How to add a script to start up sequence so that it applies before the actual login screen?

So I have this script that changes the resolution of on of my monitors that works and that I was able to run on login by adding it in settings»Applications»Startup. The only problem is that I need it ...
Tin jus's user avatar
  • 21
1 vote
1 answer
119 views

Run a script on shutdown

I have a very simple script that I want to run every time I shut down my computer. How can the script be automatically executed once I press the 'Shut Down' or 'Restart' button?
Giancarlo's user avatar
  • 121
0 votes
1 answer
157 views

Can I generate a custom notification? [solved]

Is there a way to generate a custom notification, and how? I have a bash script that performs rsync backups, and this script runs as a cronjob. I want to have that script generate a notification to ...
Aijalon-2's user avatar
0 votes
2 answers
155 views

Cannot bind keyboard shortcut to .sh

elementary OS 0.4.1 Loki I am trying to create a keybinding (like CTRL+Z) to a script file, but it never executes. Steps: System Settings -> Keyboard -> Shortcuts -> Custom -> Add I ...
schmoopy's user avatar
  • 137
0 votes
1 answer
698 views

Detecting USB Insertion/Removal

Is there any way to detect when a usb flash drive/stick/etc gets plugged in a usb port? To be more specific, I need to have a way to detect usb insertion/removal and use this information in a python ...
geo1230's user avatar
  • 156
0 votes
2 answers
347 views

Network Manager Restart Script Issue

I've created a script to restart the network manager using #!/bin/bash sudo service network-manager restart I've named the file network-restart.sh and ran chmod +x network-manager.sh to set ...
pretz's user avatar
  • 2,310
1 vote
0 answers
103 views

Why doesn't Pantheon Files remember default application for scripts?

The executable scripts are always executed if clicked in Pantheon Files, even if the default application to be used is changed for them to a text editor under Properties-Open with. I have noticed ...
user avatar