Questions tagged [apt]

Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

Filter by
Sorted by
Tagged with
0
votes
3answers
241 views

How can I fix updating issues?

Whenever I update the OS through AppCenter, my laptop freezes and becomes unresponsive to both keyboard and mouse input. I have left my computer in this state for several hours (approximately 9) only ...
1
vote
1answer
272 views

Low disk space on file system

Low disk space on file system message on: Elementary: elementary OS Freya (64-bit) Built on "Ubuntu 14.04 LTS" File manager: Files 0.2.4 I want to create more disk space and running the command df-h ...
0
votes
1answer
311 views

Getting an error on update

I am running eos juno on a razer blade late 2016 model laptop. I tried to do a sudo apt-get update && upgrade on terminal Err:13 http://in.archive.ubuntu.com/ubuntu bionic-updates/main i386 ...
0
votes
1answer
172 views

Grub2 unknown filesystem after apt dist-upgrade

Yesterday I did a apt dist-upgrade on my Juno installation. This morning I found my PC unbootable. Since I couldn't find a fix for it, I started to reinstall my system. After a clean install (on a ...
2
votes
2answers
880 views

Accidentally created a bad source list- How to delete it?

I'm new to Linux and was attempting to install the Brave Browser using the instructions on the website, listed below: curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-...
0
votes
2answers
135 views

Error on launching the “App Store”

I get the following error when I launch the AppCentre. It reads E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC' I ...
2
votes
2answers
743 views

Brave Browser and repo update

I have tried to add the repo for Brave Browser. It adds fine, but then I get this problem with it being insecure. How can I add this repo to an exceptions list? I understand apt is going to phase out ...
0
votes
2answers
2k views

Cannot install gcc and g++ on Elementary OS Juno

Yesterday, I installed Elementary OS Juno. This is a fresh install. When I tried to install g++ it gave me following stream of Errors. Basically some dependencies are unmet. When I tried to install ...
0
votes
2answers
2k views

Problems installing elementary tweaks in Juno

Following these steps: sudo add-apt-repository -y ppa:philip.scott/elementary-tweaks sudo apt update sudo apt install elementary-tweaks I get this output, indicating an error: guillermo@guillermo-...
0
votes
1answer
550 views

How configure apt-get with proxy

I'm new one on elementary, I work behind a proxy. I cant get work apt -get behind a proxy , i tried to edit /etc/apt/apt.conf but i can't find, thanks for your help
0
votes
1answer
1k views

Juno Failed to Fetch Updates - Missing Release file

I've just installed elementary OS Juno, but I'm getting into trouble when I try to get updates, both via AppCenter or terminal. It seems it cannot fetch updates since it cannot find Release file in ...
4
votes
2answers
4k views

How to fix gpg: keyblock resource `/etc/apt/trusted.gpg.d/<key>.gpg': resource limit

I frequently receive errors as follows while running apt-get update: [...] gpg: keyblock resource `/etc/apt/trusted.gpg.d/pdfmod-team-ppa.gpg': resource limit gpg: keyblock resource `/etc/apt/...
3
votes
3answers
4k views

Error installing OS updates — “Too few items to process”

I was downloading OS updates as per usual while working, and when I finished working I realized the installation had gotten stuck. I was trying to install another package and wanted to use apt, which ...
0
votes
0answers
138 views

Cannot Install Shutter Elementary Os [duplicate]

pk@pk:~$ sudo apt-get install -f shutter Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you ...
2
votes
3answers
2k views

Why is my Elementary OS Not Updating via terminal / Apps are not updating from App Center?

I am not able to update apps or the OS. While upgrading from the terminal, I am getting this error message: Do you want to continue? [Y/n] y (Reading database ... 271161 files and directories ...
1
vote
1answer
92 views

Broken apport return [Sub-process /usr/bin/dpkg returned an error code (1)]

When I try to update the system or install updates through: sudo apt update; sudo apt upgrade -y; I get an error: Sub-process /usr/bin/dpkg returned an error code (1) When processing the following ...
1
vote
1answer
2k views

Cannot install Elementary Tweaks in Loki (no release file for the repo)

I'm back to elementary after some absence and I hope to keep using it, but I have no big incentive so far. After discovering that adding repos was disabled by default, as well as the Ubuntu's ...
2
votes
1answer
5k views

apt update “does not have a Release file”

I'm trying to fix this issue when running sudo apt update: E: The repository 'https://download.docker.com/linux/ubuntu loki Release' does not have a Release file. N: Updating from such a repository ...
1
vote
1answer
2k views

Missing release files during apt update [duplicate]

I will post it here, since I cannot find chat to ask a question or any specific place to post bugs. Sorry, if it's wrong place to post such bug, redirect me in right direction please. My setup ...
0
votes
1answer
518 views

Unable to install any softwares

I just installed elementary on my HP Pavilion, dual boot with the pre-installed Windows 10. I can't install anything, using either the app center or apt-get. Here's what is happening when I try to ...
0
votes
1answer
2k views

apt-get and add-apt-repository not working

When I try to use the command sudo apt-get install chromium-browser, I get the output Reading package lists... Done Building dependency tree Reading state information... Done You might want to ...
1
vote
1answer
85 views

apt-get is busted, linux noob

elementary os hasn't been able to update for a long time now. Apt get update works, but i get a bunch of 404 errors. The errors are only for arm64 packages and im on an AMD64 system so i havnt been ...
1
vote
0answers
573 views

apt update fails with GPG Error for appcenter xenial InRelease no public key

since a few days I cannot apt update any more, it says Hit:1 http://repo.steampowered.com/steam precise InRelease Hit:2 http://de.archive.ubuntu.com/ubuntu xenial InRelease ...
0
votes
2answers
105 views

How can I roll back Firefox back to previous version?

After doing a dist-upgrade Firefox got updated to the latest version, how can I go back to the previous version?
1
vote
1answer
209 views

Not able to install applications

This error keeps showing up E: mysql-common: subprocess installed post-installation script returned error exit status 2 E: libmysqlclient20: 25.0000:dependency problems - leaving unconfigured
1
vote
1answer
406 views

Prevent Background Downloading of updates

Firstly thank you to everybody that contributes to Elementary OS, what a great product. Please help, I have limited bandwidth which is costly where I am. I have tried numerous ways of disabling the ...
0
votes
1answer
211 views

Problem with apt-get update in crontab @reboot

I wrote a simple bash script to keep my system updated, and put it on a crontab to execute @reboot: (sudo apt-get update) >> /home/raphael/Documents/Logs/updateLogs.txt (sudo apt-get upgrade -...
1
vote
1answer
514 views

`apt update` is broken and appcenter doesn't show any apps

I haven't done anything weird I don't think. Haven't changed any of my sources or anything like that. When trying an apt update I get this: [~] ∞ sudo apt update Hit:1 http://ppa.launchpad.net/...
4
votes
1answer
3k views

Why is packagekitd is running?

I look into processes on my laptop. It is T420. There is one process in top five. It is packagekitd. /usr/lib/packagekit/packagekitd. I don't understand why do I need packagekitd running?
1
vote
2answers
4k views

How do I resolve GPG NO_PUBKEY errors?

After attempting to update within the command line, the system ends with these errors. Reading package lists... Done W: GPG error: https://repo.skype.com/deb ...
3
votes
1answer
297 views

App Center package website down [closed]

I upgraded the App Center to 0.2.3, but then the site, http://packages.elementary.io/appcenter, the packages are hosted on is reporting a bad gateway. The App Center isn't showing anything other than ...
0
votes
0answers
135 views

Cannot install/update packages. Pantheon Files error [duplicate]

As the title says, I cannot install or update any packages, either from console via apt-get nor in the AppStore. The following packages have unmet dependencies: pantheon-files : Depends: libpantheon-...
1
vote
1answer
108 views

I extendedly removed apt package manager, how to fix?

I have removed apt as I was removing keyring with the Synaptic Package Manager. Removed the following ESSENTIAL packages: apt Completely removed the following packages: ubuntu-keyring Removed the ...
1
vote
2answers
1k views

Hash Sum Mismatch Error

I am getting a hash sum mismatch error. I have several ppa's hopefully this is not the cause. tweaks, libreoffice, and caffeine, vivaldi, opera I followed the instructions Update error (sudo apt-get ...
0
votes
2answers
263 views

Getting errors while using the command sudo apt-get update

When I use the command I seem to be getting these errors: Err:46 http://ppa.launchpad.net/t-tujikawa/ppa/ubuntu xenial/main amd64 Packages 404 Not Found Ign:52 http://ppa.launchpad.net/t-...
0
votes
1answer
532 views

Why do I get these errors?

W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/elementary-os-ubuntu-os-patches-xenial.list:1 and /etc/apt/sources.list.d/patches.list:1 W: ...
0
votes
0answers
709 views

Install libgtk2.0-0:i386 dependency problems [duplicate]

I'm trying to install libgtk2.0-0:i386 to solve this error: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory However, when I try ...
0
votes
1answer
188 views

What does this error mean? (“Ignoring file '20auto-upgrades.ucf-dist'”)

apt update gives me this error: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension What should I do?
0
votes
2answers
117 views

Can't install kdenlive and kdeconnect, 403 forbidden

I have this problem: I can't succeed in installing kdeconnect and kdenlive. I get error 403 forbidden all the time. Here's my output from terminal: http://pastebin.com/raw/6HFzfMVu Anyone else had ...
0
votes
1answer
185 views

Install f-spot - no installation candidate

I tried to install f-spot, but apt says there is no installation candidate for f-spot: $ sudo apt-get install f-spot Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
968 views

I've added the Daily PPA and Appstream causes an error when trying to upgrade

I've added the Daily PPA (don't worry, I have another partition with a stable elementary, this is just for learning) and when I try to apt upgrade -f (or the same without the -f) I get the following ...
2
votes
1answer
336 views

Error while adding PPA on elementary OS freya

Whenever i try to add any PPA it shows me the following error Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 91, in sp = SoftwareProperties(options=options) File ...
0
votes
2answers
869 views

Lost the appcenter in Loki

I lost the app center in loki after doing sudo apt-get autoremove i cant seem to locate the file or the app. A correct name of the package might help me install it
0
votes
1answer
195 views

Unable to install uberwriter

I am unable to install Uberwriter on Loki. I get the following when trying to run apt-get update after adding the uberwriter repo with sudo add-apt-repository: W: The repository 'http://ppa.launchpad....
0
votes
1answer
756 views

Error update “ Could not get lock /var/lib/dpkg/lock”

sometimes appear a update alert icon on top right beside the wifi icon, but i can't update because this lock by the way, first I ran the shell command, after this, I tried the update software
5
votes
1answer
3k views

“could not find a distribution template for Ubuntu/n/a” error in elementary OS

I got message like this : root@ferryready-Satellite-L510:/home/ferryready# curl -sL http://i-hate-farms.github.io/spores/install | sudo bash - Installing the repository... OK Traceback (most recent ...
1
vote
0answers
94 views

Can't open Software Center / 404 Not Found with apt-get update [closed]

Hello, I seem to be having trouble with opening Software Center, when I click on it nothing happens, I'm new to elementary OS and Linux. I think I did something wrong when I tried to update a ...
0
votes
1answer
296 views

Trouble installing Grive tools on Loki

When using sudo apt-get update in order to install grive-tools to elementary, I get this: W: The repository 'http://ppa.launchpad.net/thefanclub/grive-tools/ubuntu xenial Release' does not have a ...
0
votes
1answer
360 views

Install packages on elementary OS with downgrade

I've been grappling with installing some Ubuntu packages with apt-get so I thought I'd post an example for anyone else struggling with Elementary OS. Here libssl or openssl won't install and these are ...
0
votes
2answers
506 views

apturl doesn't work in Loki

apturl is installed. When clicking such a link (like on https://apps.ubuntu.com) in Epiphany and Firefox nothing happens. Even tried it Palemoon, with the same result. In both Firefox and Palemoon I ...