Questions tagged [apt]

Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

Filter by
Sorted by
Tagged with
11
votes
1answer
1k views

Can I use aptitude instead of apt-get without problems?

I would like to use aptitude since its parameters are more consistent. You can install it with: sudo apt-get install aptitude Are there any reasons not to use it with elementary OS?
7
votes
1answer
741 views

Can I restore apt-get sources to the default?

I'm new with elementary OS but I have used ubuntu for a while before. I was trying to install Steam and I had a problem, I had to install a lib of 32bits (ia32-libs) and all good, but today, I was ...
6
votes
1answer
2k views

Is it safe to use “apt-get autoremove”?

Months ago i read a note like "not use autoremove because it break the meta package on Freya", is it safe to use now? I have so many packages which are no longer needed. EDIT: Thank you so much ...
5
votes
1answer
2k views

“apt-get upgrade” fails with errors (E: Encountered a section with no Package: header) and (W: Duplicate sources.list entry)

Distro: elementary OS Freya 0.3 (no modifications apart from installing bumblebee and proprietary video drivers) Laptop: MSI ghost GS60 2PC I have, for about the last month, been getting messages ...
5
votes
1answer
2k views

“could not find a distribution template for Ubuntu/n/a” error in elementary OS

I got message like this : root@ferryready-Satellite-L510:/home/ferryready# curl -sL http://i-hate-farms.github.io/spores/install | sudo bash - Installing the repository... OK Traceback (most recent ...
5
votes
1answer
1k views

Why can I not install dconf-tools?

Whenever I try to install dconf-tool I get this error: Reading package lists... Done Building dependency tree Reading state information... Done Package dconf-tools is not available, but is ...
5
votes
2answers
2k views

Cannot install wine and playonlinux

sudo apt-get install wine Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you ...
4
votes
3answers
5k views

Error while doing 'sudo apt update': no Release file

Whenever I do sudo apt update, I get the following response: Ign:1 http://ppa.launchpad.net/elementary-os/stable/ubuntu loki InRelease Hit:2 http://in.archive.ubuntu.com/ubuntu xenial InRelease ...
4
votes
2answers
3k views

How to fix gpg: keyblock resource `/etc/apt/trusted.gpg.d/<key>.gpg': resource limit

I frequently receive errors as follows while running apt-get update: [...] gpg: keyblock resource `/etc/apt/trusted.gpg.d/pdfmod-team-ppa.gpg': resource limit gpg: keyblock resource `/etc/apt/...
4
votes
1answer
2k views

Why is packagekitd is running?

I look into processes on my laptop. It is T420. There is one process in top five. It is packagekitd. /usr/lib/packagekit/packagekitd. I don't understand why do I need packagekitd running?
4
votes
0answers
310 views

Can't open Software Center [closed]

I am a beginner on Linux so I don't know what went wrong but the Software Center wont open anymore, if I click it it will open and close immediately. Also, on the top bar it will appear the message on ...
3
votes
1answer
744 views

Unable to install skype on elementary OS

I am using elementary os freya. I followed this post to install skype. ravan@ravan:~$ sudo apt-get install skype Reading package lists... Done Building dependency tree Reading state ...
3
votes
1answer
142 views

How can I install indicator-session without pulling in extra packages?

I removed indicator-session by accident. Now, when I try to install it again through apt-get I get this. The following NEW packages will be installed: indicator-session libaccount-plugin-1.0-0 ...
3
votes
2answers
237 views

Adobe Flash Plugin Vulnerable

I'm having trouble with the Adobe Flash Plugin. Firefox, with which I substituted Midori, blocks it. I have tried to re-install it from the software center, I have installed flashplugin-installer, I ...
3
votes
3answers
4k views

Error installing OS updates — “Too few items to process”

I was downloading OS updates as per usual while working, and when I finished working I realized the installation had gotten stuck. I was trying to install another package and wanted to use apt, which ...
3
votes
1answer
287 views

App Center package website down [closed]

I upgraded the App Center to 0.2.3, but then the site, http://packages.elementary.io/appcenter, the packages are hosted on is reporting a bad gateway. The App Center isn't showing anything other than ...
3
votes
1answer
170 views

Strategies for dealing with horribly out of date software in the Ubuntu repos

It's been about 5 years since I've used an Ubuntu based distro as my daily driver and now I'm starting remember some of the reasons why I ditched it for Arch Linux; horribly out of date software ...
3
votes
1answer
204 views

Everything hangs on installing wine

I have tried to install wine (using apt-get install wine) up today. However, after working a bit, the whole desktop decided to hang and I couldn't move the mouse. IIRC, it was showing up "processing ...
2
votes
3answers
1k views

Why is my Elementary OS Not Updating via terminal / Apps are not updating from App Center?

I am not able to update apps or the OS. While upgrading from the terminal, I am getting this error message: Do you want to continue? [Y/n] y (Reading database ... 271161 files and directories ...
2
votes
4answers
8k views

How can I run a Terminal command as “root”?

I tried to install Git using this command apt-get install git, but getting this: E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration ...
2
votes
1answer
3k views

Cannot install OpenJDK 8

I am trying to install OpenJDK 8 in Freya but I can't find in any repository. If I try sudo apt-get install openjdk-8-jdk I get Unable to locate package And when I try to search it via sudo ...
2
votes
2answers
487 views

Brave Browser and repo update

I have tried to add the repo for Brave Browser. It adds fine, but then I get this problem with it being insecure. How can I add this repo to an exceptions list? I understand apt is going to phase out ...
2
votes
1answer
94 views

is it safe to leave packages held back?

I'm running elementary OS freya and have a very stable system, just the way I like it. Today I did an apt-get update and apt-get upgrade and the following message appeared: The following packages ...
2
votes
2answers
395 views

Fresh installation - apt-get update fails with 403 forbidden

I am quite new to Linux. After I did fresh install from iso and update system components from AppCenter(appcenter) I wanted to install net-tools using apt-get. firstly I did sudo apt-get update but ...
2
votes
1answer
950 views

I've added the Daily PPA and Appstream causes an error when trying to upgrade

I've added the Daily PPA (don't worry, I have another partition with a stable elementary, this is just for learning) and when I try to apt upgrade -f (or the same without the -f) I get the following ...
2
votes
1answer
152 views

Mine apt-get update gives an error?

After i type sudo apt-get update ubuntu shows the following error. W: Failed to fetch http://archive.canonical.com/dists/freya/partner/binary-amd64/Packages 404 Not Found [IP: 91.189.92.150 80] W: ...
2
votes
1answer
277 views

Missing index files from elementary repo

After doing a package update I get a 404 error when it's trying to fetch http://ppa.launchpad.net/elementary-os/os-patches/ubuntu/dists/freya/main/binary-i386/Packages How can I solve that missing ...
2
votes
1answer
209 views

Problems with broken packages and apt-related issues

At the moment I'm unable to update my system or install/uninstall any package. The source of the problem seems to be a broken package (tv-maxe installed from ppa:venerix/pkg) with unmet dependencies ...
2
votes
1answer
319 views

Error while adding PPA on elementary OS freya

Whenever i try to add any PPA it shows me the following error Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 91, in sp = SoftwareProperties(options=options) File ...
2
votes
2answers
72 views

Warning Notification Updates

since two days ago, there's some warning icon appear on my top bar like this I've try click Show Updates but said my system already updated (last action bout two days ago too) This is my apt lists $...
2
votes
1answer
58 views

Graphic glitch after interrupted apt upgrade?

I'm new to this forum, so sorry for any mistakes.. Today I booted my Elementary OS into this (see the screenshot). Blurred or missing texts, no text in menus... But pages and menus a rendering ...
2
votes
2answers
401 views

Accidentally created a bad source list- How to delete it?

I'm new to Linux and was attempting to install the Brave Browser using the instructions on the website, listed below: curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-...
1
vote
1answer
103 views

I extendedly removed apt package manager, how to fix?

I have removed apt as I was removing keyring with the Synaptic Package Manager. Removed the following ESSENTIAL packages: apt Completely removed the following packages: ubuntu-keyring Removed the ...
1
vote
2answers
4k views

How do I resolve GPG NO_PUBKEY errors?

After attempting to update within the command line, the system ends with these errors. Reading package lists... Done W: GPG error: https://repo.skype.com/deb ...
1
vote
1answer
2k views

Can't install elementary-tweaks on Juno

I'm trying to install elementary-tweaks on Juno but adding the ppa is causing an error. Here is my console output... Err:7 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic ...
1
vote
1answer
1k views

Juno sources - no release file

I have just installed Juno but cannot update. sudo apt update [sudo] password for cipeos: Sorry, try again. [sudo] password for cipeos: Ign:1 http://ppa.launchpad.net/elementary-os/...
1
vote
2answers
1k views

Hash Sum Mismatch Error

I am getting a hash sum mismatch error. I have several ppa's hopefully this is not the cause. tweaks, libreoffice, and caffeine, vivaldi, opera I followed the instructions Update error (sudo apt-get ...
1
vote
1answer
4k views

apt update “does not have a Release file”

I'm trying to fix this issue when running sudo apt update: E: The repository 'https://download.docker.com/linux/ubuntu loki Release' does not have a Release file. N: Updating from such a repository ...
1
vote
1answer
72 views

apt-get is busted, linux noob

elementary os hasn't been able to update for a long time now. Apt get update works, but i get a bunch of 404 errors. The errors are only for arm64 packages and im on an AMD64 system so i havnt been ...
1
vote
1answer
479 views

`apt update` is broken and appcenter doesn't show any apps

I haven't done anything weird I don't think. Haven't changed any of my sources or anything like that. When trying an apt update I get this: [~] ∞ sudo apt update Hit:1 http://ppa.launchpad.net/...
1
vote
1answer
400 views

Unmet Dependencies and Broken Packages

When attempting to install Steam, I get this error message: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable ...
1
vote
1answer
493 views

apt search does not work

I run elementary OS on my laptop and after I did the usual update and upgrade, sudo apt search stopped working. I've been looking everywhere for an answer and nobody seems to have had this problem! ...
1
vote
1answer
107 views

Native videos app can't play some type of videos

I have a problem with the native videos app: I'm not able to play specific videos in it (Screen is black) while I can play some other videos. Using VLC (Which somehow can play the target files with ...
1
vote
1answer
327 views

Error when running `sudo apt-get update`

I've got the following error(s): Hit:1 http://ro.archive.ubuntu.com/ubuntu bionic InRelease Hit:2 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic InRelease ...
1
vote
1answer
76 views

Broken apport return [Sub-process /usr/bin/dpkg returned an error code (1)]

When I try to update the system or install updates through: sudo apt update; sudo apt upgrade -y; I get an error: Sub-process /usr/bin/dpkg returned an error code (1) When processing the following ...
1
vote
1answer
2k views

Cannot install Elementary Tweaks in Loki (no release file for the repo)

I'm back to elementary after some absence and I hope to keep using it, but I have no big incentive so far. After discovering that adding repos was disabled by default, as well as the Ubuntu's ...
1
vote
1answer
660 views

elementary OS Update

I just installed elementary OS 0.4.1 Loki on an iMac over the last weekend and everything went swimmingly well. This AM when I try sudo apt-get update, I get this message: W: The repository '...
1
vote
1answer
396 views

(libcups2) dependency hell after apt upgrade

Some broken packages have been shipped in mainline. Package libcups2 has broken apt completely after an upgrade. When I try apt -f install the package manager suggests to remove a whole batch of ...
1
vote
1answer
208 views

Not able to install applications

This error keeps showing up E: mysql-common: subprocess installed post-installation script returned error exit status 2 E: libmysqlclient20: 25.0000:dependency problems - leaving unconfigured
1
vote
1answer
499 views

“Failed to download repository information”

I am connected to the Internet but when i want to check for updates I get the following message: