Questions tagged [apt]

Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

Filter by
Sorted by
Tagged with
0
votes
0answers
11 views

Apt related error (maybe appcenter?)

Sometimes, I think when I use AppCenter, my laptop randomly starts overworking itself. Upon investigation, it turns out that the log file /var/log/apt/term.log gets spammed with the lines Use of ...
0
votes
3answers
88 views

File manager deleted after update, now can't reinstall it (broken dependencies)

After a recent update and apt autoremove, the Elementary OS files app was somehow removed. I tried to reinstall it from the appstore, only for it to complain that tumbler and tumbler extras needed ...
1
vote
0answers
50 views

Can't remove packages after removal of third party repository

Seeing how Ubuntu 18.04 has an EOL version of PHP in the package repository, I ended up following this tutorial to install a newer PHP version. All seemed fine, but I ended up wanting to remove this ...
2
votes
1answer
81 views

Graphic glitch after interrupted apt upgrade?

I'm new to this forum, so sorry for any mistakes.. Today I booted my Elementary OS into this (see the screenshot). Blurred or missing texts, no text in menus... But pages and menus a rendering ...
0
votes
2answers
821 views

Failed to Authenticate apt upgrade

Command run: sudo apt upgrade [sudo] password for user: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages ...
0
votes
1answer
144 views

Updating Hera: Expected bionic but got trusty

When I check for updates on AppCenter, I get an error message "failed to fetch updates" W: Conflicting distribution: http://ppa.launchpad.net/deadsnakes/ppa/ubuntu bionic InRelease (expected bionic ...
0
votes
0answers
19 views

ElementaryOS repository doesn' t upgrade propertly

The repositories at launchpad and the app center one are down and giving sha issues when I try to upgrade my fresh installed ElementaryOS 5.1.7, I fix the issue using sudo apt upgrade --fix-missing ...
1
vote
2answers
76 views

Error when trying sudo apt-get update

I have the Hera OS 5.1. Now when I want to run sudo apt-get update I got the following errors. What can I do? Thanks in advance. Err:16 http://ppa.launchpad.net/djart/minidlna/ubuntu bionic Release ...
0
votes
1answer
208 views

Can't upgrade my packages

Short version: I can't upgrade my packages (I'm using Elementary OS 0.4.1, based on Ubuntu - that's why I'm asking here). Long version: First step I try fetching package informations via sudo apt-...
0
votes
1answer
678 views

No module named apt_pkg

Had this error while trying to install Lutris :sudo add-apt-repository ppa:lutris-team/lutris and then this came out : Traceback (most recent call last): File "/usr/bin/add-apt-repository", line ...
1
vote
2answers
1k views

Hash sum mismatch on apt update

Get:14 http://in.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB] Err:13 http://packages.elementary.io/appcenter xenial/main amd64 ...
1
vote
0answers
101 views

Install R 3.6.3 on elementary OS: unmet dependencies

I couldn't find R or Rstudio on the built-in Elementary app store thingie, so I'm following instructions from the R project to install R in my new Elementary OS sandbox. sudo apt-get install r-base-...
1
vote
1answer
27 views

Installing 'Lightzone' as a linux n00b

I'm hoping someone can help me. I'm trying out elementary os as a desktop os and have so far been impressed by how much of my home computing use is covered straightaway. installing a few extra apps ...
1
vote
1answer
184 views

(SOLVED) apt-get is trying to uninstall everything I've ever installed!

This evening, I installed the latest stable release (version 10) of LLVM, Clang, etc.. I used these commands: sudo apt-get install libllvm-10-ocaml-dev libllvm10 llvm-10 llvm-10-dev llvm-10-doc llvm-...
0
votes
0answers
27 views

Can't update becase of 'Appstream'

when i try to update my system via apt-get update or appcenter i get this message: The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer ...
0
votes
2answers
4k views

i have a problem with Android studio AVD and apt-get

so first. I've installed Android Studio and its working fine, except when I try to create AVD virtual device it says: An error occurred while creating the AVD. See idea.log for details. i found a ...
1
vote
1answer
250 views

add-apt-repository not working

When I try running sudo add-apt-repository ppa:openrazer/stable it hangs. I am on Elementary OS 5.1 Hera. No other repositories work. I have install software-properties-common and its dependencies. If ...
0
votes
0answers
28 views

synaptic error on bash showing when I open the terminal

I tried doing this to install apt-fast: sudo add-apt-repository -y ppa:apt-fast/stable sudo apt -y install apt-fast echo $'\nalias apt="apt-fast"' >> ~/.bashrc source ~/.bashrc and now, ...
0
votes
1answer
2k views

Repository „cdrom://elementary OS 5.0 _Juno_ - Stable amd64 (20181016) bionic Release“ does not contain the Release file

How can i solve this ? E: Repository „cdrom://elementary OS 5.0 _Juno_ - Stable amd64 (20181016) bionic Release“ does not contain the Release file. W: An update from this repository can not be ...
8
votes
3answers
13k views

Error while doing 'sudo apt update': no Release file

Whenever I do sudo apt update, I get the following response: Ign:1 http://ppa.launchpad.net/elementary-os/stable/ubuntu loki InRelease Hit:2 http://in.archive.ubuntu.com/ubuntu xenial InRelease ...
0
votes
1answer
282 views

404 NOT FOUND adding tweaks

this is a similar issue to this question by me. I just got a fresh install of EOS 5.1, so I am starting from scratch. I am trying to get Elementary Tweaks so I can install a custom theme, but when I ...
0
votes
1answer
953 views

I can' t update/upgrade or install anything

please, can anybody help me. after: sudo apt-get dist-upgrade djordje@dj:~$ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done You ...
2
votes
1answer
333 views

Haskell Platform last version

I have installed the latest available version of the Haskell platform on Elementary with apt-get But the actual version is pretty old: > sudo apt-get install haskell-platform Reading package lists....
2
votes
1answer
99 views

Can't install/remove, upgrade/update ANYTHING

I use OpenOffice, but got curious why so many Linux users and distributions are more into LibreOffice, so I downloaded it to check it out. When I tried to install it (a while back) I got an error ...
1
vote
1answer
2k views

Repository problems, on a new installed Juno

After a brand new installation of Elementaty Juno (I come from Linux Mint) I got errors like this one, when updating the system: El repositorio «http://packages.elementary.io/appcenter juno Release» ...
0
votes
1answer
70 views

Fresh Juno install can't update/install any packages

I've just completed a fresh install of 5.0 from the ISO on the website, but am unable to update/upgrade packages. Trying to run sudo apt update, or install anything from the AppCentre both result in ...
0
votes
1answer
90 views

404 Not Found error while running Apt and AppStore EOS Juno

when I open the app store in EOS Juno I am getting these errors: Failed to Fetch Updates This may have been caused by external, manually added software repositories or a corrupted sources file. E: ...
1
vote
1answer
2k views

Juno sources - no release file

I have just installed Juno but cannot update. sudo apt update [sudo] password for cipeos: Sorry, try again. [sudo] password for cipeos: Ign:1 http://ppa.launchpad.net/elementary-os/...
0
votes
1answer
54 views

Error with appcenter likely connected with python

I got this code when I open the appcenter. I recently dabbled in installing python stuff so might be connected to it. Also, when I ran sudo apt-update, this came out : Error Message
0
votes
1answer
25 views

Determine Missing Files

I am very new to Linux. My question is this : I have installed CodeBlocks IDE from the AppCenter, and tried to compile a simple "Hello World" program to no avail. After researching and looking at ...
1
vote
1answer
1k views

Update error unexpected size

Input code : sudo apt update Output with error : Get:1 http://bd.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB] Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease ...
0
votes
0answers
325 views

Error: could not find a distribution template for elementary/juno

I have a problem on my elementary os Juno. So when I want to add a ppa, it answers me : arthur@arthur:~$ sudo add-apt-repository ppa:mpstark/elementary-tweaks-daily Traceback (most recent call last): ...
1
vote
1answer
7k views

Can't install elementary-tweaks on Juno

I'm trying to install elementary-tweaks on Juno but adding the ppa is causing an error. Here is my console output... Err:7 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic ...
0
votes
2answers
230 views

Adwaita package removed - can’t boot in

I am not an expert in the terminal but I understand how it works a little. So I wanted to remove some themes from my elementary OS Loki. First I deleted the .theme folder, but on the tweaks I could ...
1
vote
1answer
314 views

Native videos app can't play some type of videos

I have a problem with the native videos app: I'm not able to play specific videos in it (Screen is black) while I can play some other videos. Using VLC (Which somehow can play the target files with ...
0
votes
1answer
653 views

apt-get: Unmet dependencies for almost every package

I'm running Elementary os 0.4.1 loki. After doing some magic with apt-get I managed to broke it so some packages won't install. Then I tried to fix it with some solutions I found on Google like apt-...
5
votes
1answer
2k views

Why can I not install dconf-tools?

Whenever I try to install dconf-tool I get this error: Reading package lists... Done Building dependency tree Reading state information... Done Package dconf-tools is not available, but is ...
1
vote
0answers
42 views

The repository 'http://http.us.debian.org/debian xenial Release' does not have a Release file [duplicate]

When I try update my elementary OS I get these error messages: W: The repository 'http://http.us.debian.org/debian xenial Release' does not have a Release file. N: Data from such a repository can't ...
0
votes
1answer
128 views

How to know which packages I have installed manually?

Where on the web is Loki's install manifest file? I want to compare it with the current build to see what I have installed? Or is there another way?
0
votes
1answer
417 views

Packages have unmet dependencies error

whenever i try to install anything, i get that. Me and my dumb self also decided to uninstall appcenter, this is another problem im having, sudo apt-get install appcenter Reading package lists... ...
1
vote
1answer
485 views

(libcups2) dependency hell after apt upgrade

Some broken packages have been shipped in mainline. Package libcups2 has broken apt completely after an upgrade. When I try apt -f install the package manager suggests to remove a whole batch of ...
1
vote
1answer
513 views

“Failed to download repository information”

I am connected to the Internet but when i want to check for updates I get the following message:
1
vote
1answer
786 views

elementary OS Update

I just installed elementary OS 0.4.1 Loki on an iMac over the last weekend and everything went swimmingly well. This AM when I try sudo apt-get update, I get this message: W: The repository '...
1
vote
1answer
199 views

Update error - signatures couldn't be verified because the public key is not available

I installed a few days ago(monday I think) elementary OS 5.0 Juno. Everything went really good, I'ma pretty experienced Linux user, I've been using ubuntu,elementary os and linux in general for quite ...
0
votes
1answer
380 views

Updates failure

I am not able to update my system for a long time. This is the failure text: Failed to fetch http://packages.elementary.io/appcenter/dists/xenial/main/dep11/Components-amd64.yml Could not open file /...
1
vote
1answer
2k views

Error when running `sudo apt-get update`

I've got the following error(s): Hit:1 http://ro.archive.ubuntu.com/ubuntu bionic InRelease Hit:2 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic InRelease ...
0
votes
2answers
2k views

Update error “apt-get update”

When I update to "sudo apt-get update" appears this errors into terminal. How can I solved it? Thanks! (...) Err:6 https://dl.bintray.com/aluxian/deb <channel>/main amd64 Packages 404 Not ...
1
vote
0answers
113 views

Failed to fetch update

full details from image E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /...
1
vote
0answers
29 views

I accidentally deleted the file /lib/ld-lsb.so.3

I accidentally deleted the file /lib/ld-lsb.so.3. I wanted to know if it's a necessary file to guarantee the good functionality of the system (last version of Elementary OS, equivalent to bionic ...
0
votes
3answers
1k views

Can't install Mega on Juno

On Juno the default Mega deb package is not installing because of missing dependencies which using sudo apt install -f does not resolve. In face of better solution I came here to see what can be done, ...