1

at office i need to connect to local resources through wired network and internet thought wifi. I had tried enabling settings/network/ethernet/advanced settings/IPv4/Routes/Use this connection only for resources on its network. and i got the lan conection but the internet connection sometimes work and sometimes not, then i just need to unplug the cable, reload the browser and when i get back internet connection, replug the cable. Also i had tried looking for the ip route getting only the wireless conection as default:

default via 192.168.0.1 dev wlp3s0  proto static  metric 600 
192.168.0.0/24 dev wlp3s0  proto kernel  scope link  src 192.168.0.105  metric 600 
192.168.1.0/24 dev enp2s0  proto kernel  scope link  src 192.168.1.208  metric 100 

In ubuntu-gnome 16.10 i got this working but in elementary loki i got this problem.

Some ideas about it?

Thanks in advance!

PD: Sorry for my bad english

1

i had solved this by adding some lines to /etc/network/interfaces

auto enp2s0
iface enp2s0 inet dhcp
metric 601

where enp2s0 is my wired interface and 601 is the new metric having wifi 600 metric.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.