0

I can set up a screen resolution on both the laptop screen and the external monitor using xrandr and everything works fine, but my displays go back to normal when I restart lightdm. How can I make the changes permanent? I tried going through the monitors.xml file, but it isn't being updated. The Displays item in system settings isn't of much use...

1

I had pretty much the same problem with display on an external monitor - display was fitted badly; I hardly could see wingpanel or plank.

I solved it with changing config file in /boot/ directory.

In this file you need to find disable_overscan and change it's value to 1. Then a bit further down you'll find

overscan_bottom=48
overscan_left=48
overscan_right=48
overscan_top=48

you can change these values to fit your display into monitor.

Then save it and restart computer. It should be fine after few times. :)

  • Overscan is such a legacy curse! Some systems can't enable / disable it, and some monitors can't enable / disable it. And it isn't even really relevant anymore - so I wish they'd just burn it completely and stop building devices that ever use it! – SamMorrowDrums Feb 14 '17 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.