1

In OSX, you've the option to set a physical click on the lower right corner of the touchpad to be your Secondary (right) click. I can't seem to figure out to duplicate this functionality in Elementary OS Loki.

Here's some details:

  • Macbook 5,1 (Late 2008)
  • Elementary OS 0.4 Loki
  • No physical buttons, just a single pad that can be clicked
  • The touchpad is setup for right handed use
  • Primary (left) click works fine
  • I can tap with two fingers to active the Secondary (right) click menu
  • The issue is the combination of physical click to the lower right of the touchpad registers the same as Primary (left) click.

Running xinput --list my touchpad shows up as being a bcm5974

When I run xinput --list-props bcm5974 I get the following output of options:

Device 'bcm5974':
    Device Enabled (142):   1
    Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (276): 1
    libinput Tapping Enabled Default (277): 0
    libinput Tapping Drag Enabled (278):    1
    libinput Tapping Drag Enabled Default (279):    1
    libinput Tapping Drag Lock Enabled (280):   0
    libinput Tapping Drag Lock Enabled Default (281):   0
    libinput Accel Speed (282): 0.875000
    libinput Accel Speed Default (283): 0.000000
    libinput Natural Scrolling Enabled (284):   0
    libinput Natural Scrolling Enabled Default (285):   0
    libinput Send Events Modes Available (260): 1, 0
    libinput Send Events Mode Enabled (261):    0, 0
    libinput Send Events Mode Enabled Default (262):    0, 0
    libinput Left Handed Enabled (286): 0
    libinput Left Handed Enabled Default (287): 0
    libinput Scroll Methods Available (288):    1, 1, 0
    libinput Scroll Method Enabled (289):   1, 0, 0
    libinput Scroll Method Enabled Default (290):   1, 0, 0
    libinput Click Methods Available (291): 1, 1
    libinput Click Method Enabled (292):    0, 1
    libinput Click Method Enabled Default (293):    0, 1
    libinput Disable While Typing Enabled (294):    1
    libinput Disable While Typing Enabled Default (295):    1
    Device Node (263):  "/dev/input/event8"
    Device Product ID (264):    1452, 566
    libinput Drag Lock Buttons (296):   <no items>
    libinput Horizonal Scroll Enabled (265):    1

Has anyone figure out a way to get this to work?

2

elementary OS 0.4 Loki uses LibInput and not xinput.

You can change your click method in System Settings > Mouse & Touchpad.

To use touchpad areas for right clicking instead of Multitouch, change the click method to "Touchpad areas" under "Physical Clicking".

  • 1
    Now that was a hell of a lot easier! – Ray Dec 29 '16 at 20:40
  • With libinput, you still need xinput if you want to view the devices and settings or is there another CLI tool you can use? – Ray Dec 29 '16 at 20:45
  • @Ray The Arch WIki has a bunch of information about using libinput from Terminal wiki.archlinux.org/index.php/Libinput – Daniel Foré Dec 29 '16 at 20:46
  • Thanks, any chance within the eOS GUI there's a way to disable tap to drag? – Ray Dec 29 '16 at 20:48
  • @Ray If you have more questions you should open a new question ;) But no there's no such setting at the moment – Daniel Foré Dec 29 '16 at 20:49
1

The short answer is to change the property Click Method Enabled (292) from 0, 1 to 1, 0. No idea what the heck this means, but it works.

UPDATE: While below works to set Click Method Enabled, Daniel's answer shows how the same is accomplished via the eOS GUI without much effort.

I found the answer buried in a random redhat post: https://bugzilla.redhat.com/show_bug.cgi?id=1214477

For my device the command was:

 xinput --set-prop bcm5974 292  1 0

After changing this setting verified:

  • Secondary (right) click works when clicking lower right corner of touchpad
  • Two finger tap still works for Secondary click
  • Primary (left) click still works (thankfully!)
  • Single finger tap to select (Primary click) still works as well
  • Changing other properties in the Elementary OS System Settings does not revert the property setting

However... xinput property setting changes don't persist across login/logout (thus lost every restart/shutdown).

I tried putting the xinput commands in .xsession, .xsessionrc, and .bash_profile--none worked.

What finally worked was to create a file /usr/share/applications/configure_touchpad.desktop with the following content:

[Desktop Entry]
Name=Custom Touchpad Config
Comment=Set your mouse and touchpad preferences
Exec= xinput --set-prop bcm5974 278 0 &&  xinput --set-prop bcm5974 292 1 0
Icon=/usr/share/icons/HighContrast/256x256/devices/input-touchpad.png
Terminal=false
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Settings;HardwareSettings;X-GNOME-Settings-Panel;System;

I then logged out and logged back in. (Seems to be needed to make app show up in the System Settings startup app list). Went into System Settings->Applications->Startup, search for the name "Custom" and added it to my startup.

Hope this Helps others!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.