1

I'm having this small issue with Loki on an Asus E402S laptop:

the internal soundcard works fine and also do the headphones if I manually choose them as an output with pavucontrol, but when I plug or unplug the headphones jack it doesn't automatically switch between headphones and laptop speaker.

Any advice for this? Thank you!

0

I'm not sure, but I think that it's like that by default in elementary.

Whenever, I connect my bluetooth speakers or headphones, I have to change output in sound settings.

|improve this answer|||||
  • I also think sound is managed in this way by default. I assume this is a purposeful design. I find it to be a non issue and it is the same way in my Windows machine. – Eosdude Mar 31 '17 at 20:02
0

I was able to have elementary OS auto switch to my bluetooth headphones by loading a extra module:

Add the following line to: /etc/pulse/default.pa

load-module module-switch-on-connect

Sources:

Maybe there is a similar trick for regular headphones?

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.