I have a problem with Airplane Mode (AM) in elementary OS Loki (latest release, updated as of today). I am not sure whether this is a Gnome issue (see for instance this thread), a Pantheon issue or something completely different.

Here is my problem: I cannot disable AM; if the radiobutton is flipped, AM remains in the same state. I can only choose from VPN and Proxy, but no network interfaces are present.

Invoking the following command

sudo rfkill list all

returns that no devices (hci0: bluetooth and phy0: Wireless LAN) are soft or hard blocked. I tried

sudo rfkill unblock 1

which correspondes to phy0. Also tried blocking and unblocking it. There is a hardware switch on the laptop. I have tried to switch this back and forth, and it does indeed make hci0 and phy0 to appear as soft blocked. This does not yield a solution, though.

Let us look in the Network manager's internal state:

cat /var/lib/NetworkManager/NetworkManager.state



OK, so that is not it... Moreover, ifconfig states that only the loopback interface is enabled. Running

ifconfig [dev] up

makes the device show up when running ifconfig, but it still does not give me a network connection. Subsequently running down and up does not remedy either.

I tried starting elementary OS in recovery mode. First, I enable network and then, resume the process arriving at the desktop. Now, the network works perfectly (however, the network settings still reports that Airplane Mode is ON), so it is clearly not a hardware issue.

Finally, I have also tried resetting to defaults (button in the About window). This had virtually no effect at all on the network manager. I really want to avoid reinstalling elementary OS for this reason.

Any hints?

  • If it has any relevance, the laptop is a HP Elitebook 840 G3. Commented Dec 28, 2016 at 11:09
  • @Daniel The intention was not for this to be a bug report, rather a question on how to resolve the current state. Commented Dec 28, 2016 at 19:20
  • I've reopened the question. In the future, please phrase titles as a question and make sure that your question is clear. This post reads as a bug report and it's not very clear that you're intending to ask a question Commented Dec 28, 2016 at 20:20

1 Answer 1


One way of solving this problem is to do

sudo apt-get install --reinstall elementary-desktop

It might seem a bit drastic but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.