4

I installed MS Office using Play on Linux, but when I click on my file (.docx or other) for "open with: Microsoft Word", there isn't in the possible choices!

Is there a way to open directly the file without open first Microsoft Word (and select: open file -> myfile.docx)?

  • You can add it to the choices in the Open with…/Other application menu. – lemonslice Dec 24 '16 at 7:47
  • @lemonslice I've already tried, even with /Other application / Se all there isn't – Paolo Zaia Dec 24 '16 at 9:19
4
  • Open Playonlinux

  • Select 'Configure'

  • Select your virtual drive (e.g. Office2007)

  • Under 'General' tab click 'Make a new shortcut for this virtual drive'

  • Select the icon you want (e.g. WINWORD.EXE) and press next

  • Give it a name (let's say MSWord)

  • Close Playonlinux.

  • Look in $HOME for MSWord.desktop

  • Copy that to ~/.local/share/applications

  • Select a .docx file (or what you need), right-click, 'Properties', 'Open with', Other application, 'Show all applications', look for MSWord. ('Set as default' should be enabled.)

If the desktop file has no proper icon, look for it in ~/.PlayOnLinux/icones/full_size. Copy it to ~/.local/share/icons and rename it so as to add the png extension (e.g. winword.png) then edit the Icon line of the desktop file (e.g. Icon=winword). Other lines that are worth editing are maybe:

Name=Microsoft Office Word;

and

Categories=Office;WordProcessor;
  • you are my hero! – Paolo Zaia Apr 2 '17 at 9:44
2

You should look for the .desktop file of the Microsoft Word (in ~/.local/share/applications/wine/Programs) and append %F to the line that starts with Exec=.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.