2

I've been playing with Loki for a few days and generally like it on my new chromebook replacement (HP Stream 11), so I'll probably be popping in here to ask a few more questions.

This one is about this (apparently) notoriously finicky wireless card. All the fixes I'm finding with search have led me to broken links or suggestions to use commands that eOS doesn't understand? cd doesn't seem to work in terminal, f'ex. Not sure what it does at any rate.

I've found the new version of one of the fixes, an "rtlwifi" fix from github. I realize that I have no idea how to run it. So my one question is: how do I run the extracted files?

My problem with the driver is that the signal strength is really, really weak. As in, I need to be within 5-10 feet of the router to get even just a little bit of signal. It doesn't drop - it's just weak as hell.

If there are other suggestions, too, I'm all ears.

  • I use HP laptop and RTL8723be too. I've tried a lot of things and I spent my hours. Unfortunately.. You can track my opened issue - github.com/lwfinger/rtlwifi_new/issues/184 – efkan Dec 22 '16 at 7:46
  • Unfortunately @efkan, my problem was weak signal strength, not dropped connections. I don't think my solution will help you. – lokeen Dec 30 '16 at 16:52
  • I wish your solution works for you consistently. Please let me know if your wireless card drops connection. Especially when not shutted down for a coupke of days. If so you might mark "this bugs affected me" on this page bugs.launchpad.net/elementaryos/+bug/1379087 happy new year! :) – efkan Dec 31 '16 at 8:11
  • Does your wifi still work after you wake up your laptop from suspend? I have the same wireless card RTL8723BE. My wifi works fine with your fix, thanks for that! But my wifi appears to be hardblocked after waking up from suspend, and I've tried loads of fixes but none of them work. Can you help me out? – Varun Gupta May 24 '18 at 15:08
  • I haven't had a single wifi problem since running these fixes so I can't help you. If you start another thread, hopefully you'll get some answers. I've run into a few problems with waking it up every now and then, but a hard reboot usually solves the issue. – lokeen May 25 '18 at 17:57
1

I'm sure this is bad form, but I'm going to post the answer to my own question since it involved a lot more than the answer provided by woopsi.

I started there, but ran into problems at sudo modprobe rtl8723be, aka loading the new driver. (I was able to do the previous unloading step without issue.) This step required a signed UEFI key for my machine, which was beyond my purview to write, so I had to disable Secure Boot. Unfortunately, I was no able to access the boot menu no matter what key I pressed, so I had to follow the advice here to modify the GRUB file.

TL;DR, open up a terminal, type sudo nano /etc/default/grub, change GRUB_HIDDEN_TIMEOUT=0 to #GRUB_HIDDEN_TIMEOUT=0, save, then update the actual GRUB file by typing sudo update-grub and restarting. Access boot menu, disable Secure Boot, start eOS as normal.

Unfortunately, just loading the new driver didn't work. After more digging, I discovered that this is because of an antenna issue with the network card, as outlined by lwfinger here.

So I needed to manually test the card's two antenna connectors to see which one actually works. Go back into terminal, cd ~/rtlwifi_new, and type:

sudo modprobe -rv rtl8723be

sudo modprobe -v rtl8723be ant_sel=1

Check to see if this works. Get close to the router, toggle airplane mode, or what have you (no reboot required). If it doesn't, try the second antenna connector:

sudo modprobe -rv rtl8723be

sudo modprobe -v rtl8723be ant_sel=2

Antenna connector #2 seems to work for more users than #1 - it was the second one in my case also.

At any rate, my wifi works now. I haven't restarted my machine since doing this, so I'm not sure if I need to run these commands at every restart yet, but if I do, the advice on how to automate that is here:

So I added these lines to /etc/rc.local (above exit 0) so that it would run each time my laptop boots up.

sleep 10

sudo modprobe -r rtl8723be

sudo modprobe rtl8723be ant_sel=1

Note: change ant_sel=1 to ant_sel=2 if required.

Hope this helps somebody.

  • 1
    Posting the answer to your own question isn't bad form at all - it's super helpful! Thanks! :) – Ryan DeBeasi Dec 30 '16 at 17:38
  • After having the second antenna selected for a couple of days, it stopped working, and the first antenna is the one that works now. I don't know why this is - I thought it was purely a hardware thing, but maybe not. – lokeen Jan 18 '17 at 22:50
0

Actually, Loki should install on it's own the driver since it's a problematic one(RTL8723BE)

Check the first answer, it will help you.

  • OK, I think I did everything that said to do, but now my network icon has an elipsis on it instead of an "x", and when I click it, it says airplane mode has been enabled even though the airplane mode toggle in the lower left corner of the window is not actually on. If I toggle it on, I get a notification about it, and when I toggle it off again, the "airplane mode is enabled" message goes away. The elipsis on the network icon doesn't change. – lokeen Dec 23 '16 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.