0

NOTE: Before you mark the question duplicate and give me the link to this solution: Install Nvidia dual-graphics driver on Loki? I have to state that I tried it and it automatically installed nvidia-367 drivers but the nvidia-settings panel did not show any configurations or settings, meaning that the new drivers were not properly installed.

So i'm asking you, is there anyone who is using Loki (up-to-date) with Intel HD + NVIDIA cards and managed to install NVIDIA drivers and use optimus or bumblebee or any means to achieve successful switching between graphics cards?

This solution: How can i switch between Intel and Nvidia Graphics card? also suggests the same thing but I don't see any "PRIME-profiles" (or any other profiles or settings) in the NVIDIA X Server Settings panel.

And if anyone knows, can someone explain why is it so hard to successfully install latest NVIDIA drivers without getting black screens, login loops and many other problems? I tried and also read many questions and solutions about this problem, but the solutions are neither permanent nor simple.

Thank you!

By the way: I have ASUS UX303UB, I don't know if this is an issue with this laptop model.

0

So, I actually made it.

First, I have removed everything related with nvidia

sudo apt-get remove bumblebee (if installed)

sudo apt-get remove nvidia*

First, following this solution: https://elementaryos.stackexchange.com/a/7548/7861

sudo ubuntu-drivers list

sudo ubuntu-drivers autoinstall

NOTE: I forgot to mention that, when I was installing nvidia-367 drivers, terminal prompted me to turn off UEFI secure boot. After the reboot, Secure boot was disabled. Maybe it has something to do with the secure boot. (Some digging in google shows that secure boot sometimes restricts the OS to access third party features.

And then installing primus with:

sudo apt-get install primus

With primus, bumblebee is also installed.

Next, edit /etc/bumblebee/bumblebee.conf

driver=nvidia

KernelDriver=nvidia-367

LibraryPath=/usr/lib/nvidia-367:/usr/lib32/nvidia-367

XorgModulePath=/usr/lib/nvidia-367/xorg,/usr/lib/xorg/modules

NOTE: nvidia-367 is my version, you should change the numbers for your nvidia driver version

Reboot

After all these steps, I could finally see the "PRIME Profiles" section in nvidia-settings screen. When I run glxgears, primusrun glxgears or optirun glxgears, I get different FPS values (much higher with optirun) and I guess it shows that it is finally working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.