4

I just got alerted to two updates but the update page in the AppCenter is blank, even though regular app pages work.

Tried using the software updater which got one of the two updates in, but I can't get the other update in nor can I figure out why the updates page is empty.

Anybody have any ideas?

  • What does apt list --upgradable say in a terminal window? – lemonslice Dec 20 '16 at 15:40
  • what updates exactly? disable all added ppas and try if there's any change – user170 Jan 10 '17 at 13:24
  • Do you have any third-party ppas enabled and have you installed anything exotic like MakeHuman? I vaguely recall having to change the version of PackageKit either for MakeHuman or PyCharm but may be mistaken. – codecowboy Apr 22 '17 at 6:50
1

I had this issue also and tried everything, including removing/purging appcenter, reinstalling, updating, upgrading, etc. but no suggestions that I found worked.

Finally, I looked through as many logs as I could and tried:

sudo apt-get remove appcenter

sudo apt-get purge packagekit

... as I had seen some errors thrown up regarding packagekit which seemed related.

Rebooted. Then reinstalled packagekit and appcenter, and everything works again!

Edit: Interestingly, and sadly, this fix only lasted until my next reboot. Then the problem is back. This leads me to believe that for whatever reason, the problem might be related to appcenter's relationship with packagekit.

I have replicated the fix by removing packagekit again, and reinstalling, which so far is lasting.

  • what updates can't you make? do you have manually added ppa-s? is sudo apt update giving errors regarding a ppa? if so, disable all ppa-s and try again – user170 Jan 10 '17 at 13:26
  • 1
    Appcenter would not provide any updates. By that I mean, the update window would be completely blank. It wouldn't show any installed software, and it wouldn't search for updates. I could update for using sudo apt update, and it wouldn't throw any errors, so I'm not sure what the issue was precisely. I actually ended up doing a clean install of eOS and now, inexplicably, the problem is gone. – Jason Waddington Jan 17 '17 at 7:37
0

I'm facing the same problem with the AppCenter, the updates page is blank nothing is shown, none of the apps installed, neither updates. I usually update the system through AppCenter, I remember that this problem began to occur after I ran the sudo apt autoremove command that theoretically would remove packages that are no longer used, but it seems that Removed more than it should. Older kernels were removed and with that the Nvidia driver stopped working, I had to reinstall it. I can update the system normally from the command line, no problem. To install applications I have to use the command line also since in App Center it just keeps waiting ... and does not install the application, sudo apt list --upgradable normally lists packages that can be updated

What I've done to try to fix the problem:

1 - sudo apt-get purge appcenter

2 - sudo apt-get purge packagekit

3 - Restart, reinstall, unsuccessful

4 - I removed any other software source I could find

5 - Restart, unsuccessful

6 - Follow the procedures on the links:

Empty AppCenter

No software is shown in AppCenter except what is installed

Loki AppCentre updates page blank, can't do 1 update

I can't find FireFox in the AppCenter of Loki, although I have installed it

Also unsuccessfully, do you have any idea how to fix it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.