I have a question regarding drive mounts.

I installed Elementary on a separate SSD. 3 partitions - swap, file system and home.

I then installed a 1TB hard drive. The drive was partitioned to ext4 and mounts as /media/user1/Drive

What I then did was add another user - user2 as a standard desktop user.

When I log into user2, the drive appears in the sidebar of Files as "Drive" but when I click on it, I get a note something like you do not have permission etc.

So I edited the /etc/fstab to mount the drive at startup. Though I wanted to mount the drive as /mnt/Drive. So that's what I put in the /etc/fstab entry. It worked, so user2 can access the drive through the folder /mnt/Drive with full read write access but, it doesn't appear under Devices in Files sidebar. The orginal entry - /media/user1/Drive - still appears in the sidebar but still no permission.

What I would like to do is mount the drive for both users in /mnt/Drive and have the drive appear under devices in the Files sidebar as Drive for both users.

Is there any reason why internal drive gets mounted as /media/user1/Drive but then doesn't share it? Does it matter if it is changed to /mnt/Drive?

Any help appreciated, best alternative solutions etc.

1 Answer 1


Try method described here: https://askubuntu.com/questions/351991/mounting-disk-drives-among-different-users. It worked OK for me. Note however that the last command given should be sudo chgrp <groupname> <mountpoint>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.