2

I have been using ElementaryOS Loki for the last few days using my Monitor connected via HDMI for audio. However today when watching a youtube video, I paused it and resumed it and there was no sound. Since then even after numerous restarts I cant get sound, even if i plug in some headphones. I have tried Pulse Audio which does show sound attempting to play, but can't seem to find the right audio device to play it. Typed aplay -l which does show HDMI as device 3 Have also tried killing the audio, as well as reinstalling pulse but cant get it to work.

Edit: When using the default sound controllers HDMI is no longer showing despite using the monitor.
Edit 2: Managed to get HDMI to show in the output list however it cant play sound still. Headphones do play sound when I change The config in pulse to "Analog Stereo Duplex" but there is some static when no music is playing.
Edit 3: Got rid of the static by disabling loopback in aslamixer

  • Have you tried playing audio from another app or another site? – jrock2004 Dec 19 '16 at 13:15
  • I have tried multiple apps, still no HDMI sound. And some static with headphones. – Adam Fenwick Dec 30 '16 at 11:35
  • And please add your answer separately as answer not as edit to the question. – Hasan Apr 16 '19 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.