6

I just installed ElementaryOS on my Macbook Air, and so far I'm liking it. There is one thing which really annoys me though.

In Ubuntu (or OSX) when I'm on a large website or in a large text document and I want to scroll to the end (or somewhere in the middle), I simply scroll very fast with two fingers so that when my fingers leave the touchpad it keeps on scrolling until I reached the point that I want. When I do this in ElementaryOS it stops scrolling when my fingers leave the touchpad, which means I need to scroll a zillion times to get to the point of my interest.

Since I do this all the time during my work it is really a must for me to have.

Is it possible to somehow make ElementaryOS mimic this behavior so that I don't need to scroll so many times to get to the point I'm interested in within the document? All tips are welcome!

ps. I just tested scrolling on the same Macbook with Ubuntu 16.04. The scrolling on Ubuntu is not smooth at all, but it does keep on scrolling when my fingers let go of the touchpad, just like in OSX, which suggests it is somehow possible.

  • I'm not sure if you meant this, but on my laptop it continues scrolling a bit. It doesn't go to the end but maybe one screen down. In your case it just stops or it does something similar to what I said earlier? – Maccer Dec 10 '16 at 13:12
  • @Maccer - It stops almost immediately, maybe it scrolls a tiny bit more, but definitely not much. This is pretty much the only thing that still keeps me from using ElementaryOS more. I would even be happy to pay for this feature. – kramer65 Dec 11 '16 at 16:50
  • On elementary, do you get different behavior on built-in apps vs. third-party apps? Or is the behavior consistent everywhere? elementaryos.stackexchange.com/questions/8954/… – Ryan DeBeasi Dec 13 '16 at 14:45
  • @RyanDeBeasi - It is pretty much consistent across all apps. – kramer65 Dec 27 '16 at 16:48
1

Just a suggestion, you can try to emulate a wheel with this script.

#!/bin/bash
xinput set-int-prop "TOUCHPAD" "Evdev Wheel Emulation" 8 1
xinput set-int-prop "TOUCHPAD" "Evdev Wheel Emulation Button" 8 3
xinput set-int-prop "TOUCHPAD" "Evdev Wheel Emulation Timeout" 16 200
xinput set-int-prop "TOUCHPAD" "Evdev Wheel Emulation Axes" 8 6 7 4 5

You must change "TOUCHPAD" with your own touchpad name, you can get it with xinput -list

Sources (french) : https://doc.ubuntu-fr.org/touchpad#emuler_la_molette

|improve this answer|||||
  • Excuse me for taking so long. I really appreciate your answer. I just ran xinput -list, and I indeed get a list, but I'm not sure which one is my trackpad: prnt.sc/do4xsf . Do you know what I need to insert into the TOUCHPAD part of your bash code? – kramer65 Dec 26 '16 at 18:18
  • Alright, I tried changing "TOUCHPAD" for 10 (10 is the int of what I think is my touchpad), but that didn't work. It didn't seem to change anything. Any other ideas? – kramer65 Dec 26 '16 at 19:01
  • Try the 11, 10 is a keyboard. – Shining Dec 26 '16 at 19:05
  • I tried 11 as well, but that doesn't seem to change anything either. It should work instantly right, I don't need to restart or anything (I'm booted from a usb, so that would be dificult anyway)? I also ran xinput list-props 10 for both 10 and 11`: prnt.sc/do5lps . I don't know if that tells you anything? – kramer65 Dec 26 '16 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.