7

I can't seem to add any applications. I receive a notice saying "Waiting for package manager lock". I like Elementary but I am stuck and unable to install any additional programs. Should I do a clean install of Elementary....ie start again from scratch?

  • I gave up on Elementary and returned to Mint. – Denny in Ohio Feb 9 '17 at 15:03
11

Had same problem - in the end fixed using sudo dpkg --configure -a from a hint provided when trying sudo apt-get update.

  • The sudo dpkg --configure -a worked for me in Loki. Thanks !! – user8313 Jan 26 '17 at 16:51
  • This worked for me. Thank you! What did it do? – Fly by Night Apr 26 '17 at 17:37
  • Can you explain what this command is doing? – JohnnyBizzle May 3 '18 at 19:21
3

That's probably because some other program is using apt or you aren't running it with sudo. Just reboot and then do sudo apt install [program]

  • Tried that. Numerous times. In fact I just did it in an attempt to install Shotwell. Ya da ya da ya da ..... and then "unable to correct problems. you have held broken packages. Great. How do I "unhold" them? I have 14 apps in a logjam waiting to be downloaded. Are they all unbroken? Whatever....how do I clear them from the queue? – Denny in Ohio Dec 1 '16 at 21:35
  • oh btw I appreciate your suggestion...hope I didn't sound flippant or unappreciative! – Denny in Ohio Dec 1 '16 at 21:43
  • Open /etc/apt/sources.list then check what PPAs you've added. Use ppa-purge ppa:nameofppa to delete them. That's going to remove/downgrade some packages as well but may solve the broken packages thingy. When you've deleted all PPAs do sudo apt update && sudo apt full-upgrade. If that works correctly you can start to add the PPAs you need again but run the previous command after adding another PPA so you find which one was causing the issue. Also, if you do sudo apt get update and look at the output it may give you some info about what PPA is causing this. – Maccer Dec 2 '16 at 10:23
  • /etc/apt/sources.list . Permission denied. sudo apt get update. Invalid operation get. – Denny in Ohio Dec 2 '16 at 13:55
  • Well go figure....it appears that a system update rectified the problem. Yet I don't understand exactly how that occurred since the "jam up" wouldn't allow me to run the system update previously. So chalk it up to magic? – Denny in Ohio Dec 2 '16 at 14:46
2

I successfully used sudo dpkg --configure -a once a couple of days ago and it worked, but tonight I can't get anything to work.

When I try sudo dpkg --configure -a I get this:

dpkg: error: dpkg status database is locked by another process

When I try /etc/apt/sources.list I get

bash: /etc/apt/sources.list: Permission denied

I'm curious; why is permission to display a list of PPAs denied the administrator?

At https://askubuntu.com/questions/13965/waiting-for-other-software-manager-to-quit it says to check in System Monitor for a process that looks like an apt or an apt-get or a synaptic process and kill it. I can't see any.

That page also suggests trying sudo rm /var/lib/dpkg/lock and it didn't give me an error message but there was no indication that it did anything and I still can't update.

I have shut the computer down two or three times to no avail.

Sorry I can't highlight the commands like you guys have. I looked at the advanced help and couldn't see how to do it.

Edit: I just tried to update from the terminal using sudo apt-get update and this is what I got (I took the http: out of the first nine lines because I had too many links):

Hit:1 //us.archive.ubuntu.com/ubuntu xenial InRelease
Ign:2 //dl.google.com/linux/chrome/deb stable InRelease                                         
Get:3 //security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                           
Get:4 //us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]                          
Hit:5 //dl.google.com/linux/chrome/deb stable Release                                           
Hit:7 //ppa.launchpad.net/elementary-os/stable/ubuntu xenial InRelease                          
Hit:8 //ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial InRelease                      
Get:9 //us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]

Fetched 306 kB in 0s (321 kB/s)

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
duane@duane-desktop:~$ sudo dpkg --configure -a

Setting up libdvd-pkg (1.4.0-1-1) ...

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

dpkg: error processing package libdvd-pkg (--configure):

subprocess installed post-installation script returned error exit status 1

Errors were encountered while processing:
 libdvd-pkg

There is a process called dconf-service. Should I end or kill it?

I can't believe it! I decided to shut things down and go to bed, so I clicked to close the Terminal and it said that there was a process running in the Terminal and, of course, it would quit if I closed. I closed and then tried updating and the system and Firefox both updated.
I started using the Terminal because I couldn't update and I had quit Terminal several times during this process, but this time it was different.
I wish I knew why.

I still can't display the list of PPAs. That's weird.

1

In case of worst case scenario, which is not the case in this posting, if you would ever consider a re-install, I made things really easy for you: http://www.leeuwtje-productions.me/en/

Just install a fresh Eos system, download the tool and install a complete elementary system set of software automatically!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.