My PC and laptop can't read the USB in BIOS or OS if it was created by dd command with elementary OS iso, but it works fine with other distros iso, no matter how many times that I download the iso file, it just won't work, the elementary OS iso only works with unetbootin.



  1. MD5 check:

enter image description here

laichiaheng@PC:~$ md5sum ~/下載/elementaryos-freya-amd64.20150411.iso >file.md5
laichiaheng@PC:~$ md5sum -c file.md5 
/home/laichiaheng/下載/elementaryos-freya-amd64.20150411.iso: 正確


MD5 is correct.


  1. dd command:

enter image description here

laichiaheng@PC:~$ sudo dd if=~/下載/elementaryos-freya-amd64.20150411.iso of=/dev/sdc
[sudo] password for laichiaheng: 
輸入 1744896+0 個紀錄
輸出 1744896+0 個紀錄
複製了 893386752 個位元組 (893 MB), 253.208 s, 3.5 MB/s

輸入=input, 輸出=output, 複製了=has copied


  1. check:

And I removed the usb disk, then pluged it in again, I couldn't see my 8G USB unless I mounted it as root, and I couldn't see it in the BIOS menu either.

enter image description here (elementary OS fail!!)

Then I tried Ubuntu

enter image description here

laichiaheng@PC:~$ sudo dd if=~/下載/ubuntu-14.04.2-desktop-amd64.iso of=/dev/sdc
輸入 2039808+0 個紀錄
輸出 2039808+0 個紀錄
複製了 1044381696 個位元組 (1.0 GB), 297.45 s, 3.5 MB/s

It appeared!

enter image description here (Ubuntu success!!)



Please fix this!!

  • 1
    Worked for me perfectly, installed elementary OS 3 times from usb stick, used dd to create it. Give us more details about "how exactly" it didn't work for you
    – V_Pavel
    Commented Aug 1, 2015 at 10:36
  • 1
    I also used dd. Perhaps your iso was corrupted on download? There are checksums for the iso's available here.
    – elmato
    Commented Aug 1, 2015 at 12:39
  • 1
    What didn't work? I'll think about downvoting this question if you don't elaborate.
    – user601
    Commented Aug 1, 2015 at 16:11
  • 1
    did you check the md5 hashes for the iso? Commented Aug 3, 2015 at 16:26
  • 1
    Using dd didn't seem to work for me either. I could not get my computer to boot from it (whether UEFI or legacy boot modes). Commented Aug 4, 2015 at 12:44

2 Answers 2


TL;DR: (probably because) the partition is marked hidden.

A dd-copied USB stick booted fine on a few machines I tried. But these were 5-10 year old desktop boxes with BIOS.

The elementary ISO is an ISOHYBRID, like pretty much every distro these days. That means the disk image is both a bootable CD and an MBR-partitioned hard disk; a clever hack. But looking at the partition table, it is marked type 17 (hex), or "Hidden HPFS/NTFS". Of course, that's not what the partition is, hidden or not. Apparently that was the convention for a period of time.

It also appears that the ISO was built with Debian live-build 3.0, which is now a few versions old. Debian 6 also uses the same partition type. Debian 5 was not ISOHYBRID, and had no MBR. Debian 7 and 8, and other current distros use partition type 00, which technically means "empty". That makes no sense either, but apparently it works better.

One more consistently visible effect of having a "Hidden HPFS/NTFS" partition is that the Files app or equivalent will not show it when you plug in the stick, for you to click-to-mount. But it is visible (and click-mountable) in the Gnome Disks app, for example.

Perhaps the particular BIOS/EFI you have also "honors" the partition type in the same way.

I changed that one partition type byte on the stick, and "elementary OS" appeared in the UI when I plugged it in, as you expected in your screenshots. As I mentioned earlier, it booted fine for me regardless, so I have no evidence on that aspect.

I tried to come up with a "one-liner" for you to patch the same byte so you could try it, but couldn't come up with something good. Maybe someone else might have an idea; or I could come up with a "three-liner" or "five-liner" if you really want to try.

Going forward, I have no working knowledge of the particulars of how elementary builds their distro, so it may not be as simple as "do it like this". But it seems like an issue they can track and prioritize.


The elementary OS developers recommend using Unetbootin to burn the ISO to a USB key.

Source: https://elementary.io/docs/installation

  • 1
    Thanks, but it should work by using dd command, and it did months ago, maybe there is something wrong with their updates?
    – JulianLai
    Commented Aug 3, 2015 at 14:30
  • Julian maybe there is something wrong with your boot priority in BIOS? As you can see method works for everyone except you, and you still blame the OS? Makes me wonder.
    – V_Pavel
    Commented Aug 5, 2015 at 8:11
  • No, my boot priority is fine, and as you can see it doesn't work for everyone, unless you haven't seen the comments.
    – JulianLai
    Commented Aug 7, 2015 at 16:38
  • I have given you every details that you were asking for, and you still say that it isn't elementary OS's fault! Then tell me why does dd work for every distros except elementary OS?
    – JulianLai
    Commented Aug 7, 2015 at 16:43
  • It is clearly and easy to see that elementary OS cause the problem.
    – JulianLai
    Commented Aug 7, 2015 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.